summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArpan Kapoor2016-05-10 09:50:37 +0530
committerArpan Kapoor2016-05-10 09:50:37 +0530
commit66ba29244c2a2c932fa4f136c267e713c0ffcaed (patch)
treedaca951385dc69725f4e59fda0f62c1c709a9d7d
parent2065c9ccec22dfe1032b7eec09123ff3995fd700 (diff)
downloadaur-66ba29244c2a2c932fa4f136c267e713c0ffcaed.tar.gz
Replace is_compat_task() with in_compat_syscall()
This change was introduced with commit id 5180e3e24fd3e8e7ea46fbe21e10f5ea3fb1edaa on Linus' tree.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD9
-rw-r--r--linux-4.6.patch24
3 files changed, 36 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bce5fac36ff4..fe80fa1343b3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,13 @@
# Generated by mksrcinfo v8
-# Sat Jan 2 18:01:50 UTC 2016
+# Tue May 10 04:12:58 UTC 2016
pkgbase = 8188eu-dkms
pkgdesc = Driver for Realtek RTL8188EUS (RTL8188EUS, RTL8188ETV) WLAN
pkgver = v4.3.0.8_13968
- pkgrel = 3
+ pkgrel = 4
url = http://www.realtek.com.tw/
install = 8188eu-dkms.install
- arch = i686
- arch = x86_64
- arch = arm
- arch = armv6h
- arch = armv7h
- license = GPL2
+ arch = any
+ license = GPL
depends = dkms
source = https://dl.dropboxusercontent.com/u/27457926/8188eu-v4.3.0.8_13968.tar.xz
source = blacklist-r8188eu.conf
@@ -21,6 +17,7 @@ pkgbase = 8188eu-dkms
source = linux-4.0.patch
source = linux-4.2.patch
source = linux-4.3.patch
+ source = linux-4.6.patch
source = no_debug.patch
sha256sums = c5604632f88ab6c68074635c73403a3f612f9f69b52af8fe9b96cf851db7a832
sha256sums = edaeafe28410017fabb742d6ccdf060a945150fb56e41084adb7b9dd66739e2b
@@ -30,6 +27,7 @@ pkgbase = 8188eu-dkms
sha256sums = b4614962e50f86690cdb30ccde013bb480f29b13b157e8feb05a799b5776369d
sha256sums = a8621280e07d95f6aa7ae1db8a285ba512990e0af3f8f43d54bfb4d0231d2551
sha256sums = 146a8d3b931861538ee36908e28d8ad774d5de0916e01511f48d84827c59cd99
+ sha256sums = 936e1701b72e5ecb6b79eba722da0586cee9aabc323ddc5a69b2c07d885d1fa1
sha256sums = 9b8453c15e39cf68ccc1a0d7dfb093439f89e3b2e7c40dd0fa8d0b8aa9956cdd
pkgname = 8188eu-dkms
diff --git a/PKGBUILD b/PKGBUILD
index f4b2676fac20..9c24d272e1a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,11 +3,11 @@
pkgname=8188eu-dkms
_pkgname=${pkgname%-*}
pkgver=v4.3.0.8_13968
-pkgrel=3
+pkgrel=4
pkgdesc="Driver for Realtek RTL8188EUS (RTL8188EUS, RTL8188ETV) WLAN"
-arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
+arch=('any')
url="http://www.realtek.com.tw/"
-license=('GPL2')
+license=('GPL')
depends=('dkms')
install=${pkgname}.install
source=("https://dl.dropboxusercontent.com/u/27457926/${_pkgname}-${pkgver}.tar.xz"
@@ -18,6 +18,7 @@ source=("https://dl.dropboxusercontent.com/u/27457926/${_pkgname}-${pkgver}.tar.
'linux-4.0.patch'
'linux-4.2.patch'
'linux-4.3.patch'
+ 'linux-4.6.patch'
'no_debug.patch')
sha256sums=('c5604632f88ab6c68074635c73403a3f612f9f69b52af8fe9b96cf851db7a832'
'edaeafe28410017fabb742d6ccdf060a945150fb56e41084adb7b9dd66739e2b'
@@ -27,6 +28,7 @@ sha256sums=('c5604632f88ab6c68074635c73403a3f612f9f69b52af8fe9b96cf851db7a832'
'b4614962e50f86690cdb30ccde013bb480f29b13b157e8feb05a799b5776369d'
'a8621280e07d95f6aa7ae1db8a285ba512990e0af3f8f43d54bfb4d0231d2551'
'146a8d3b931861538ee36908e28d8ad774d5de0916e01511f48d84827c59cd99'
+ '936e1701b72e5ecb6b79eba722da0586cee9aabc323ddc5a69b2c07d885d1fa1'
'9b8453c15e39cf68ccc1a0d7dfb093439f89e3b2e7c40dd0fa8d0b8aa9956cdd')
prepare() {
@@ -36,6 +38,7 @@ prepare() {
patch -p1 -i "${srcdir}/linux-4.0.patch"
patch -p1 -i "${srcdir}/linux-4.2.patch"
patch -p1 -i "${srcdir}/linux-4.3.patch"
+ patch -p1 -i "${srcdir}/linux-4.6.patch"
patch -p1 -i "${srcdir}/no_debug.patch"
# Disable power saving
diff --git a/linux-4.6.patch b/linux-4.6.patch
new file mode 100644
index 000000000000..56f03ef38c95
--- /dev/null
+++ b/linux-4.6.patch
@@ -0,0 +1,24 @@
+diff --git a/os_dep/linux/rtw_android.c b/os_dep/linux/rtw_android.c
+index fc2f8d8..d31974f 100644
+--- a/os_dep/linux/rtw_android.c
++++ b/os_dep/linux/rtw_android.c
+@@ -42,6 +42,10 @@
+ #define strncasecmp strnicmp
+ #endif
+
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(4, 6, 0))
++#define in_compat_syscall is_compat_task
++#endif
++
+ extern void macstr2num(u8 *dst, u8 *src);
+
+ const char *android_wifi_cmd_str[ANDROID_WIFI_CMD_MAX] = {
+@@ -512,7 +516,7 @@ int rtw_android_priv_cmd(struct net_device *net, struct ifreq *ifr, int cmd)
+ goto exit;
+ }
+ #ifdef CONFIG_COMPAT
+- if (is_compat_task()) {
++ if (in_compat_syscall()) {
+ /* User space is 32-bit, use compat ioctl */
+ compat_android_wifi_priv_cmd compat_priv_cmd;
+