summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzargbell2017-09-09 22:20:24 +0300
committerzargbell2017-09-09 22:20:24 +0300
commitdc12c7eedbfd230ba780652b42b6ae6d0ccd60ab (patch)
tree37a001a387c51706d29d0df8d389d4dffd4efc1b
downloadaur-dc12c7eedbfd230ba780652b42b6ae6d0ccd60ab.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD34
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..572faa83ba3a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = aarch64-elf-newlib-linaro-bin
+ pkgdesc = A C standard library implementation intended for use on embedded systems ARM64 (bare metal)
+ pkgver = 2.5.0
+ pkgrel = 1
+ url = http://www.linaro.org/downloads/
+ arch = x86_64
+ groups = aarch64-elf-linaro-toolchain-bin
+ license = BSD
+ options = !emptydirs
+ options = !strip
+ source = http://releases.linaro.org/components/toolchain/binaries/7.1-2017.08/aarch64-elf/sysroot-newlib-linaro-2017.08-aarch64-elf.tar.xz
+ sha512sums = de8860a939721c588484072d293b98a892669cc8b5b0089c41a82f2cdab136a38b502e5f180537e5ce59fe80cffab6dc396895c6d9bf9b6e32ce6d076688290c
+
+pkgname = aarch64-elf-newlib-linaro-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..236c2fd7e251
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: zargbell <zargbell@yandex.ru>
+
+_target=aarch64-elf
+_pkgdate=2017.08
+_pkgver=7.1
+
+pkgname=${_target}-newlib-linaro-bin
+pkgver=2.5.0
+pkgrel=1
+epoch=
+pkgdesc="A C standard library implementation intended for use on embedded systems ARM64 (bare metal)"
+arch=('x86_64')
+url="http://www.linaro.org/downloads/"
+license=('BSD')
+groups=(${_target}-linaro-toolchain-bin)
+depends=()
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs !strip)
+install=
+changelog=
+source=(http://releases.linaro.org/components/toolchain/binaries/${_pkgver}-${_pkgdate}/${_target}/sysroot-newlib-linaro-${_pkgdate}-${_target}.tar.xz)
+sha512sums=('de8860a939721c588484072d293b98a892669cc8b5b0089c41a82f2cdab136a38b502e5f180537e5ce59fe80cffab6dc396895c6d9bf9b6e32ce6d076688290c')
+
+
+package() {
+ mkdir -p ${pkgdir}/usr/${_target}
+ cp -a ${srcdir}/sysroot-newlib-linaro-${_pkgdate}-${_target}/usr/* ${pkgdir}/usr/${_target}
+}