summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortinxy2016-07-03 13:40:05 +0200
committertinxy2016-07-03 13:40:05 +0200
commitcb576ff48832b2bec8888214f56668b5bd8580bc (patch)
tree6eedd6e2adc35987e60bf6c18c61fc7276e3e216
downloadaur-aard2-slob.tar.gz
Upstream version: Commit 47 (hash 31ad0e7)
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD32
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1548e5e8382d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = aard2-slob
+ pkgdesc = Aard 2 Dictionary - Tool to work with Slob (sorted list of blobs) dictionary files.
+ pkgver = 47.31ad0e7
+ pkgrel = 1
+ url = https://github.com/itkach/slob
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = python
+ depends = python-pyicu
+ source = slob::git+https://github.com/itkach/slob.git
+ sha512sums = SKIP
+
+pkgname = aard2-slob
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..25caeaac8c19
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Tinxy <arch ät tinx døt eu>
+
+pkgname=aard2-slob
+_pkgname=slob
+pkgver=47.31ad0e7
+pkgrel=1
+pkgdesc="Aard 2 Dictionary - Tool to work with Slob (sorted list of blobs) dictionary files."
+url='https://github.com/itkach/slob'
+arch=('any')
+license=('GPL3')
+depends=('python' 'python-pyicu')
+makedepends=('git')
+source=("${_pkgname}::git+https://github.com/itkach/slob.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ echo "$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ #python setup.py build
+
+ echo "#!/usr/bin/python" > "${srcdir}/${_pkgname}.py"
+ cat "${_pkgname}.py" >> "../${_pkgname}.py"
+}
+
+package() {
+ cd "${srcdir}"
+ install -Dm755 "${_pkgname}.py" "${pkgdir}/usr/bin/${_pkgname}"
+}