summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-11-27 17:51:56 -0600
committerLuis Martinez2022-11-27 17:51:56 -0600
commitd2ebc295c053b6e49439b5746518139279b5c371 (patch)
treef6749c2619c21f9f59cc128aaebd5831c5c37f7f
parent0ccca34abff94efd4f345e871577e7ffb493985c (diff)
downloadaur-aaxtomp3.tar.gz
package cleanup
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
2 files changed, 9 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b528760c3626..278787bb7ddf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = aaxtomp3
pkgdesc = Convert Audible's .aax filetype to MP3, FLAC, M4A, or OPUS
pkgver = 1.3
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/KrumpetPirate/AAXtoMP3
arch = any
license = custom:WTFPL
- depends = bash>=3.2.57
- depends = ffmpeg>=2.8.3
+ depends = bash
+ depends = ffmpeg
depends = lame
optdepends = jq: only if --use-audible-cli-data is set or converting an .aaxc file
optdepends = mediainfo: adds additional media tags
diff --git a/PKGBUILD b/PKGBUILD
index b8a5d9fc2355..f9d28901b3e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,12 @@
pkgname=aaxtomp3
pkgver=1.3
-pkgrel=1
+pkgrel=2
pkgdesc="Convert Audible's .aax filetype to MP3, FLAC, M4A, or OPUS"
arch=('any')
url='https://github.com/KrumpetPirate/AAXtoMP3'
license=('custom:WTFPL')
-depends=(
- 'bash>=3.2.57'
- 'ffmpeg>=2.8.3'
- 'lame')
+depends=('bash' 'ffmpeg' 'lame')
optdepends=(
'jq: only if --use-audible-cli-data is set or converting an .aaxc file'
'mediainfo: adds additional media tags')
@@ -20,8 +17,8 @@ sha256sums=('7165c405660cf20b36d50ecad76c669d9daae16b5391755d3338a029b0346eb8')
package() {
cd "AAXtoMP3-$pkgver"
- install -Dm 755 AAXtoMP3 interactiveAAXtoMP3 -t "$pkgdir/usr/bin/"
- install -Dm 644 _config.yml -t "$pkgdir/usr/share/$pkgname/"
- install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
- install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dv AAXtoMP3 interactiveAAXtoMP3 -t "$pkgdir/usr/bin/"
+ install -Dvm644 _config.yml -t "$pkgdir/usr/share/$pkgname/"
+ install -Dvm644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+ install -Dvm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
}