summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSean Greenslade2023-01-31 00:27:20 -0800
committerSean Greenslade2023-01-31 00:27:20 -0800
commitef633735365f06dcde7b42aea6ea386a2732a885 (patch)
tree22a34bf9657a51eda86bde1937f40504c89a8fc2
parent8af013d96db4746d2e15b7473924f5dbe26b8704 (diff)
downloadaur-abiword-gtk2.tar.gz
Verbump to 3.0.5
Removed segfault patch, since that was fixed in the release. Also added GPG signature download and verification.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD18
-rw-r--r--glib2-segfault-fix.patch16
3 files changed, 15 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5af0b42733a7..8f3daa14def9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = abiword-gtk2
pkgdesc = Fully-featured word processor, GTk2, No plugins, Lite version
- pkgver = 3.0.4
- pkgrel = 3
+ pkgver = 3.0.5
+ pkgrel = 1
url = https://www.abisource.com
arch = i686
arch = x86_64
@@ -17,12 +17,12 @@ pkgbase = abiword-gtk2
optdepends = hunspell: for spell checking
conflicts = abiword
conflicts = abiword-plugins
- source = abiword-3.0.4.tar.gz::https://abisource.com/downloads/abiword/3.0.4/source/abiword-3.0.4.tar.gz
+ source = abiword-3.0.5.tar.gz::https://abisource.com/downloads/abiword/3.0.5/source/abiword-3.0.5.tar.gz
+ source = abiword-3.0.5.tar.gz.asc::https://abisource.com/downloads/abiword/3.0.5/source/abiword-3.0.5.tar.gz.asc
source = enchant-2.patch
- source = glib2-segfault-fix.patch
- sha256sums = e93096cb192e5bc19d62e180fc5eda643206465315a710113ae5036bc2a1a5d7
+ validpgpkeys = 6C44DB3E0BF3EAF5B433239A5FEE05E6A56E15A3
+ sha256sums = 1257247e9970508d6d1456d3e330cd1909c4b42b25e0f0a1bc32526d6f3a21b4
+ sha256sums = SKIP
sha256sums = f510f4df2cf597f5493f52ce855b4209628d7622b03532c2ef221f8b7032a349
- sha256sums = 8a4d873309b5cec444b0cf88141f190a35d8225ea143a57cca6366275788c175
pkgname = abiword-gtk2
-
diff --git a/PKGBUILD b/PKGBUILD
index f1771465b1b7..36d6e0cea347 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
# Contributor: Richard Jackson <rj@iinet.net.au>
pkgname=abiword-gtk2
_pkgname=abiword
-pkgver=3.0.4
-pkgrel=3
+pkgver=3.0.5
+pkgrel=1
pkgdesc='Fully-featured word processor, GTk2, No plugins, Lite version'
arch=('i686' 'x86_64')
license=('GPL')
@@ -15,20 +15,18 @@ optdepends=('hunspell: for spell checking')
conflicts=('abiword' 'abiword-plugins')
url='https://www.abisource.com'
source=("$_pkgname-$pkgver.tar.gz::https://abisource.com/downloads/$_pkgname/$pkgver/source/$_pkgname-$pkgver.tar.gz"
- enchant-2.patch
- glib2-segfault-fix.patch)
-sha256sums=('e93096cb192e5bc19d62e180fc5eda643206465315a710113ae5036bc2a1a5d7'
- 'f510f4df2cf597f5493f52ce855b4209628d7622b03532c2ef221f8b7032a349'
- '8a4d873309b5cec444b0cf88141f190a35d8225ea143a57cca6366275788c175')
+ "$_pkgname-$pkgver.tar.gz.asc::https://abisource.com/downloads/$_pkgname/$pkgver/source/$_pkgname-$pkgver.tar.gz.asc"
+ enchant-2.patch)
+sha256sums=('1257247e9970508d6d1456d3e330cd1909c4b42b25e0f0a1bc32526d6f3a21b4'
+ 'SKIP'
+ 'f510f4df2cf597f5493f52ce855b4209628d7622b03532c2ef221f8b7032a349')
+validpgpkeys=('6C44DB3E0BF3EAF5B433239A5FEE05E6A56E15A3') # Hubert Figuiere
prepare() {
cd $_pkgname-$pkgver
# Replace deprecated enchant functions
patch -Np1 -i ../enchant-2.patch
-
- # Fix for segfault when selecting/copying text
- patch -Np1 -i ../glib2-segfault-fix.patch
}
build() {
diff --git a/glib2-segfault-fix.patch b/glib2-segfault-fix.patch
deleted file mode 100644
index 040ead5d88a9..000000000000
--- a/glib2-segfault-fix.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- abiword-3.0.4/src/af/util/xp/ut_go_file.cpp 2021-04-29 13:06:35.196255120 -0700
-+++ abiword-3.0.4/src/af/util/xp/ut_go_file.cpp 2021-04-29 13:08:07.790716736 -0700
-@@ -1002,6 +1002,12 @@
- GFile *f = g_file_new_for_uri (uri);
- char *basename = g_file_get_basename (f);
- g_object_unref (G_OBJECT (f));
-+ if (!basename) // Try again since the "uri" might just be a plain path.
-+ {
-+ f = g_file_new_for_path (uri);
-+ basename = g_file_get_basename (f);
-+ g_object_unref (G_OBJECT (f));
-+ }
- #elif defined(GOFFICE_WITH_GNOME)
- char *raw_uri = gnome_vfs_unescape_string (uri, G_DIR_SEPARATOR_S);
- char *basename = raw_uri ? g_path_get_basename (raw_uri) : NULL;
-