summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli2021-09-30 23:45:44 +0200
committerDenis 'GNUtoo' Carikli2021-10-01 00:39:09 +0200
commit3081dcf989f0fcd13203fefdb14293bd407dfc69 (patch)
treea48c8808859be27c1f44ac779705221abe17ea6b
parent71902297cca0719b95cc0857474ec181f5bf9054 (diff)
downloadaur-abootimg.tar.gz
Switch to abootimg 0.6
The abootimg repository on github[1] that is used by the abootimg-git package doesn't have any tags. In addition the Guix package for abootimg[2] also uses the source code provided by Debian to build the abootimg package. So also using the source code provided by Debian looks like a good idea. In both the Debian package and the abootimg-git package from Aur (which this work is based on) pack-initrd and unpack-initrd are shipped as abootimg-pack-initrd and abootimg- unpack-initrd, so we kept that for compatibility with scripts, instructions, or applications using that. The Debian patch to abootimg was also added as it at least adds a manual which is a good thing to have. The package description was also changed a bit as this tool it only support the old boot images format. Note that while the git repository on github[1] doesn't have new commits since 2012, but having a package for abootimg (instead of packages for other tools that can extract components from Android boot images) is a good idea since abootimg is also used by diffoscope to produce more fine grained diffs between two Android boot images. [1]https://github.com/ggrandou/abootimg [2]https://guix.gnu.org/en/packages/abootimg-0.6/ Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD40
2 files changed, 30 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9093a6c29279..51ff5e7f5df4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
-pkgbase = abootimg-git
- pkgdesc = A tool to read/write/update android boot images
- pkgver = r38.7e127fe
+pkgbase = abootimg
+ pkgdesc = A tool to read/write/update old android boot images
+ pkgver = 0.6
pkgrel = 1
url = https://github.com/ggrandou/abootimg
arch = i686
@@ -12,10 +12,11 @@ pkgbase = abootimg-git
depends = util-linux
depends = cpio
provides = abootimg
- source = git+https://github.com/ggrandou/abootimg.git
+ source = http://http.debian.net/debian/pool/main/a/abootimg/abootimg_0.6.orig.tar.gz
+ source = http://http.debian.net/debian/pool/main/a/abootimg/abootimg_0.6-1.diff.gz
source = no-initrd.patch
- sha256sums = SKIP
- sha256sums = 5fe9400e71f1ade170c1e0e99f343881edca2022300c7e7a1d34d776c22cc126
-
-pkgname = abootimg-git
+ sha512sums = b96be8abe9bccfb7694c1d8f30b3a5dcc0e411b73fc78eb15f1488207032aa4737286be776b78e41bc14216e8d78ec768bbb2f91f0fe53192f08df8b6497d28f
+ sha512sums = 66884cf42c7c2121065cec6e974f3c6d301e058231b910db8e4816ed5274d7e6eb6045d1649b059c468e6760b16046ae7ef58756c810967e47e6214e0fc0612f
+ sha512sums = SKIP
+pkgname = abootimg
diff --git a/PKGBUILD b/PKGBUILD
index 3ef45dffe288..22f46210ba1e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,46 @@
-# Maintainer: Bailey Fox <bfox200012@gmail.com>
+# Contributor: Bailey Fox <bfox200012@gmail.com>
# Contributor: ajs124 < aur AT ajs124 DOT de >
# Contributor: Benoit Favre <benoit.favre@gmail.com>
# Contributor: Thomas Hebb <tommyhebb@gmail.com>
+# Contributor: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
-pkgname=abootimg-git
-pkgver=r38.7e127fe
+pkgname=abootimg
+pkgver=0.6
pkgrel=1
-pkgdesc="A tool to read/write/update android boot images"
+pkgdesc="A tool to read/write/update old android boot images"
arch=('i686' 'x86_64' 'arm' 'armv7h')
url="https://github.com/ggrandou/abootimg"
license=('GPL')
depends=('util-linux' 'cpio')
makedepends=('git')
provides=('abootimg')
-source=('git+https://github.com/ggrandou/abootimg.git'
- 'no-initrd.patch')
-sha256sums=('SKIP'
- '5fe9400e71f1ade170c1e0e99f343881edca2022300c7e7a1d34d776c22cc126')
-
-pkgver() {
- cd "abootimg"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
+source=("http://http.debian.net/debian/pool/main/a/abootimg/abootimg_${pkgver}.orig.tar.gz"
+ "http://http.debian.net/debian/pool/main/a/abootimg/abootimg_${pkgver}-1.diff.gz"
+ 'no-initrd.patch')
+sha512sums=('b96be8abe9bccfb7694c1d8f30b3a5dcc0e411b73fc78eb15f1488207032aa4737286be776b78e41bc14216e8d78ec768bbb2f91f0fe53192f08df8b6497d28f'
+ '66884cf42c7c2121065cec6e974f3c6d301e058231b910db8e4816ed5274d7e6eb6045d1649b059c468e6760b16046ae7ef58756c810967e47e6214e0fc0612f'
+ 'SKIP')
prepare() {
- cd "${srcdir}/abootimg"
+ cd "${srcdir}/abootimg-${pkgver}"
patch -p0 --binary < ../no-initrd.patch
+ patch -p1 --binary < ../abootimg_0.6-1.diff
}
build() {
- cd "${srcdir}/abootimg"
+ cd "${srcdir}/abootimg-${pkgver}"
make
gzip -f debian/abootimg.1
}
package() {
- cd "${srcdir}/abootimg"
+ cd "${srcdir}/abootimg-${pkgver}"
- install -d "${pkgdir}/usr/bin" "${pkgdir}/usr/share/man/man1/"
- install -t "${pkgdir}/usr/bin" abootimg abootimg-pack-initrd abootimg-unpack-initrd
- install -t "${pkgdir}/usr/share/man/man1/" debian/abootimg.1.gz
+ install -d "${pkgdir}/usr/bin"
+ install -d "${pkgdir}/usr/share/man/man1/"
+ install abootimg -t "${pkgdir}/usr/bin"
+ install pack-initrd "${pkgdir}/usr/bin/abootimg-pack-initrd"
+ install unpack-initrd "${pkgdir}/usr/bin/abootimg-unpack-initrd"
+ install debian/abootimg.1.gz -t "${pkgdir}/usr/share/man/man1/"
}