summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormorguldir2019-10-27 21:45:11 +0100
committermorguldir2019-10-27 21:45:11 +0100
commit6213d73f5bc933c375ae337c0dd926c01204b5ef (patch)
tree0568bb20cad1ee854f1b9874b20837dcbe673ccd
downloadaur-acquisition.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD27
3 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..aae11d7e277c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = acquisition
+ pkgdesc = Inventory management tool for Path of Exile.
+ pkgver = 0.8b
+ pkgrel = 1
+ url = https://github.com/xyzz/acquisition
+ arch = x86_64
+ license = GPL
+ makedepends = boost
+ makedepends = git
+ depends = qt5-base
+ depends = qt5-webengine
+ provides = acquisition
+ source = git+https://github.com/xyzz/acquisition#tag=0.8b
+ sha256sums = SKIP
+
+pkgname = acquisition
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c3338bd635d0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+acquisition*
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8cd10e12cbe7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: morguldir <morguldir@protonmail.com>
+
+pkgname=acquisition
+pkgver=0.8b
+pkgrel=1
+pkgdesc='Inventory management tool for Path of Exile.'
+arch=(x86_64)
+license=(GPL)
+url='https://github.com/xyzz/acquisition'
+depends=(qt5-base qt5-webengine)
+makedepends=(boost git)
+provides=(acquisition)
+source=("git+https://github.com/xyzz/acquisition#tag=$pkgver")
+sha256sums=(SKIP)
+
+build()
+{
+ cd $pkgname
+ qmake && make
+}
+
+package()
+{
+ cd $pkgname
+ mkdir -p "$pkgdir/usr/bin"
+ install -m755 "acquisition" "$pkgdir/usr/bin/acquisition"
+}