diff options
author | Arno Renevier | 2024-07-20 19:26:33 -0700 |
---|---|---|
committer | Arno Renevier | 2024-07-20 19:26:33 -0700 |
commit | 6228432880b8222bb75ea05bceaad5c028b24462 (patch) | |
tree | 588ea2454b47eddf1bf038ef94f472518c4a4445 | |
parent | ba176009a61237b72aff6e0dbe4c33e93fa245ae (diff) | |
download | aur-actdiag.tar.gz |
new version
Pushed a version on https://github.com/arenevier/actdiag
main changes upstream are:
- move tests outside to root directory (therefore, they are not
shipped in the distributed package anymore)
- switch to pytest
Other changes in PKGBUILD:
- do not use setup.py anymore, but use modern replacements
- fixes license value
- fix dependencies
- run tests
- remove unmaintained Changelog file
- remove conflict with unexisting actdiag-hg package
-rw-r--r-- | .SRCINFO | 26 | ||||
-rw-r--r-- | Changelog | 10 | ||||
-rw-r--r-- | PKGBUILD | 40 |
3 files changed, 44 insertions, 32 deletions
@@ -1,18 +1,24 @@ pkgbase = actdiag pkgdesc = Generate activity-diagram image files from spec-text files. - pkgver = 2.0.0 + pkgver = 3.1.0 pkgrel = 1 url = http://blockdiag.com/en/actdiag - changelog = Changelog arch = any - license = APACHE - makedepends = python-distribute + license = Apache-2.0 + checkdepends = python-docutils + checkdepends = python-pytest + checkdepends = python-pycodestyle + checkdepends = python-reportlab + makedepends = python-setuptools + makedepends = python-build + makedepends = python-installer + makedepends = python-wheel depends = python - depends = blockdiag>=2.0.0 - optdepends = python-reportlab: to use the PDF output format - conflicts = actdiag-hg - source = https://pypi.python.org/packages/source/a/actdiag/actdiag-2.0.0.tar.gz - sha512sums = e955b9b919e137f10ff128d5d8817b2da660b121937cab3386a866a0bff08218b6e777e302a9130616228af6c357c463ceeb12cb95b8734928001d8ad6a90250 + depends = blockdiag>=3.1.0 + depends = python-funcparserlib + optdepends = python-reportlab: for PDF export + optdepends = python-docutils: for RST parser + source = actdiag-3.1.0.tar.gz::https://github.com/arenevier/actdiag/archive/v3.1.0.tar.gz + sha512sums = 95b82dee00bd09c40b80857fa477b83bed9d20ab59af7b69ea5b75ba08d5fca73d5323b0e6feecd01e81cb7edd96eef90ec9dce85d97778af42df7d617a16e35 pkgname = actdiag - diff --git a/Changelog b/Changelog deleted file mode 100644 index 4ea01c08c291..000000000000 --- a/Changelog +++ /dev/null @@ -1,10 +0,0 @@ -2012-01-17 Julien Nicoulaud <julien.nicoulaud@gmail.com> - - * 0.3.0-2 : - Fix incorrect optdepends syntax. - -2011-11-26 Julien Nicoulaud <julien.nicoulaud@gmail.com> - - * 0.3.0-1 : - Initial release of the package. - @@ -1,20 +1,36 @@ -# Maintainer: Julien Nicoulaud <julien.nicoulaud@gmail.com> +# Maintainer: Arnaud Renevier <arno@renevier.net> +# Contributor: Julien Nicoulaud <julien.nicoulaud@gmail.com> + pkgname=actdiag -pkgver=2.0.0 +pkgver=3.1.0 pkgrel=1 pkgdesc="Generate activity-diagram image files from spec-text files." arch=(any) url="http://blockdiag.com/en/actdiag" -license=(APACHE) -depends=('python' 'blockdiag>=2.0.0') -optdepends=('python-reportlab: to use the PDF output format') -makedepends=(python-distribute) -changelog=Changelog -conflicts=('actdiag-hg') -source=("https://pypi.python.org/packages/source/a/${pkgname}/${pkgname}-${pkgver}.tar.gz") -sha512sums=('e955b9b919e137f10ff128d5d8817b2da660b121937cab3386a866a0bff08218b6e777e302a9130616228af6c357c463ceeb12cb95b8734928001d8ad6a90250') +license=('Apache-2.0') +depends=('python' 'blockdiag>=3.1.0' 'python-funcparserlib') +optdepends=('python-reportlab: for PDF export' + 'python-docutils: for RST parser') +makedepends=('python-setuptools' 'python-build' 'python-installer' 'python-wheel') +checkdepends=('python-docutils' 'python-pytest' 'python-pycodestyle' 'python-reportlab') +source=( + "$pkgname-$pkgver.tar.gz::https://github.com/arenevier/actdiag/archive/v$pkgver.tar.gz" +) +sha512sums=('95b82dee00bd09c40b80857fa477b83bed9d20ab59af7b69ea5b75ba08d5fca73d5323b0e6feecd01e81cb7edd96eef90ec9dce85d97778af42df7d617a16e35') + +build() { + cd actdiag-$pkgver + python -m build --wheel --no-isolation +} + +check() { + cd actdiag-$pkgver + PYTHONDONTWRITEBYTECODE=1 pytest +} package() { - cd "${srcdir}/${pkgname}-${pkgver}" - python setup.py install --root="$pkgdir/" --optimize=1 + cd actdiag-$pkgver + python -m installer --destdir="$pkgdir" dist/*.whl + install -vDm 644 {CHANGES,README}.rst -t "${pkgdir}/usr/share/doc/${pkgname}" + install -vDm 644 "${pkgname}.1" -t "${pkgdir}/usr/share/man/man1/" } |