summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBas Ammerlaan2018-06-28 01:41:24 +0200
committerBas Ammerlaan2018-06-28 01:41:24 +0200
commit0a7299be19e68ced96c2bf5c3f28debb885bea9d (patch)
treec609b0226dc20174c176b3c18b0b88491ac40405
downloadaur-acyls-icon-theme-git.tar.gz
Initial AUR packaging
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD47
-rw-r--r--acyls-icon-theme.install12
3 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c641748b7398
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = acyls-icon-theme-git
+ pkgdesc = Any Color You Like Simple icon pack
+ pkgver = 412.01a7ae3
+ pkgrel = 1
+ url = https://github.com/worron/ACYLS
+ install = acyls-icon-theme.install
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = gtk-update-icon-cache
+ provides = acyls-icon-theme
+ conflicts = acyls-icon-theme
+ replaces = acyls-icon-theme
+ options = !strip
+ source = git+https://github.com/worron/ACYLS.git
+ sha256sums = SKIP
+
+pkgname = acyls-icon-theme-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f57adc953550
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Bas Ammerlaan <steelbas@gmail.com>
+
+_pkgname=acyls-icon-theme
+pkgname=${_pkgname}-git
+pkgver=412.01a7ae3
+pkgrel=1
+pkgdesc='Any Color You Like Simple icon pack'
+arch=('any')
+url='https://github.com/worron/ACYLS'
+license=('GPL')
+depends=('gtk-update-icon-cache')
+makedepends=('git')
+conflicts=("${_pkgname}")
+provides=("${_pkgname}")
+replaces=("${_pkgname}")
+options=('!strip')
+source=('git+https://github.com/worron/ACYLS.git')
+sha256sums=('SKIP')
+install=${_pkgname}.install
+
+pkgver() {
+ cd ${srcdir}/ACYLS
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+package() {
+
+ install -dm 755 "$pkgdir"/usr/share/icons
+ cp -dr --no-preserve='ownership' ACYLS "$pkgdir"/usr/share/icons/
+
+
+# Make the GUI program starting script refer to /usr/share/icons instead of ~/.icons:
+
+# sed 's:~/.icons:/usr/share/icons:' "$pkgdir"/usr/share/icons/ACYLS/desktop/acyls.desktop > "$pkgdir"/usr/share/icons/ACYLS/desktop/acyls.desktop_tmp
+# mv "$pkgdir"/usr/share/icons/ACYLS/desktop/acyls.desktop_tmp "$pkgdir"/usr/share/icons/ACYLS/desktop/acyls.desktop
+
+# Copy .desktop file
+# mkdir "$pkgdir"/usr/share/applications/
+# cp --no-preserve='ownership' "$pkgdir"/usr/share/icons/ACYLS/desktop/acyls.desktop "$pkgdir"/usr/share/applications/
+
+# Fix permissions
+
+ find "${pkgdir}"/usr/share/icons/ -type d -exec chmod 755 {} \;
+ find "${pkgdir}"/usr/share/icons/ -type f -exec chmod 644 {} \;
+
+
+}
diff --git a/acyls-icon-theme.install b/acyls-icon-theme.install
new file mode 100644
index 000000000000..d012667cb36d
--- /dev/null
+++ b/acyls-icon-theme.install
@@ -0,0 +1,12 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f /usr/share/icons/ACYLS
+ echo "To run colour editor, run "sudo python3 /usr/share/icons/ACYLS/scripts/run.py""
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}