summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBioArchLinuxBot2024-08-25 18:03:54 +0000
committerBioArchLinuxBot2024-08-25 18:03:54 +0000
commitd49fcb42b5328a5bb2fb5d61b62d41a4bde720d1 (patch)
treecf03e30703c91aa8f86bd5ee6c4635e13afe7077
parent077548ec7bec6d48ea08f04b3059309b0d3926d3 (diff)
downloadaur-adapterremoval.tar.gz
[lilac] updated to 2.3.4-2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
-rw-r--r--arch-destdir.patch53
3 files changed, 7 insertions, 65 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a7083545d561..8c7750954c90 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = adapterremoval
pkgdesc = Remove remnant adapter sequences from High-Throughput Sequencing (HTS) data and trim low quality bases from the 3 prime end
- pkgver = 2.3.3
+ pkgver = 2.3.4
pkgrel = 2
url = https://github.com/MikkelSchubert/adapterremoval
arch = x86_64
@@ -12,9 +12,7 @@ pkgbase = adapterremoval
depends = gcc-libs
depends = bzip2
depends = zlib
- source = adapterremoval-2.3.3.tar.gz::https://github.com/MikkelSchubert/adapterremoval/archive/refs/tags/v2.3.3.tar.gz
- source = arch-destdir.patch
- sha256sums = a1bdc054319ede085fc8a4e9867c23ffed7df5e97b99d52221b7c587d19418fc
- sha256sums = 24f46744805fb8d4a506c05de47d1a2ab77897950057e72db682165ae412a8b3
+ source = adapterremoval-2.3.4.tar.gz::https://github.com/MikkelSchubert/adapterremoval/archive/refs/tags/v2.3.4.tar.gz
+ sha256sums = a4433a45b73ead907aede22ed0c7ea6fbc080f6de6ed7bc00f52173dfb309aa1
pkgname = adapterremoval
diff --git a/PKGBUILD b/PKGBUILD
index 9bc6a5a5eae3..6326fb970f8c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: bipin Kumar <kbipinkumar@pm.me>
pkgname=adapterremoval
-pkgver=2.3.3
+pkgver=2.3.4
pkgrel=2
pkgdesc='Remove remnant adapter sequences from High-Throughput Sequencing (HTS) data and trim low quality bases from the 3 prime end'
arch=('x86_64')
@@ -10,19 +10,16 @@ license=('GPL3')
depends=('glibc' 'gcc-libs' 'bzip2' 'zlib')
makedepends=('python-sphinx' 'libdeflate' 'isa-l')
source=(${pkgname}-${pkgver}.tar.gz::https://github.com/MikkelSchubert/adapterremoval/archive/refs/tags/v${pkgver}.tar.gz
- 'arch-destdir.patch'
)
-sha256sums=('a1bdc054319ede085fc8a4e9867c23ffed7df5e97b99d52221b7c587d19418fc'
- '24f46744805fb8d4a506c05de47d1a2ab77897950057e72db682165ae412a8b3')
+sha256sums=('a4433a45b73ead907aede22ed0c7ea6fbc080f6de6ed7bc00f52173dfb309aa1')
prepare() {
- cp *.patch ${pkgname}-${pkgver}
cd "${pkgname}-${pkgver}"
- # patch Makefile to be inline with archlinux build guidelines
- patch -p1 < arch-destdir.patch
+ sed -i '6s/:/?/' Makefile
}
build() {
cd "${pkgname}-${pkgver}"
+ export PREFIX="/usr"
make everything
}
diff --git a/arch-destdir.patch b/arch-destdir.patch
deleted file mode 100644
index aa8194d40496..000000000000
--- a/arch-destdir.patch
+++ /dev/null
@@ -1,53 +0,0 @@
---- a/Makefile 2023-04-01 23:03:38.896807602 +0530
-+++ b/Makefile 2023-04-02 00:26:38.886519015 +0530
-@@ -3,10 +3,10 @@
- #
-
- # Installation destinations
--PREFIX := /usr/local
-+PREFIX := /usr
-
- # Default compilation flags
--CXXFLAGS := ${CXXFLAGS} -std=c++11 -O3
-+CXXFLAGS := ${CXXFLAGS} -std=c++11 -O2
-
- ## Optional features; comment out or set to value other than 'yes' to disable
-
-@@ -20,7 +20,7 @@
- DEBUG_BUILD := no
-
- # Include coverage instrumentation in build
--COVERAGE := no
-+COVERAGE := yes
-
- ###############################################################################
- # Makefile internals. Normally you do not need to touch these.
-@@ -111,20 +111,20 @@
- install: build/$(PROG)
- @echo $(COLOR_GREEN)"Installing AdapterRemoval .."$(COLOR_END)
- @echo $(COLOR_GREEN)" .. binary into ${PREFIX}/bin/"$(COLOR_END)
-- $(QUIET) $(MKDIR) ${PREFIX}/bin/
-- $(QUIET) $(INSTALLEXE) build/$(PROG) ${PREFIX}/bin/
-+ $(QUIET) $(MKDIR) $(DESTDIR)${PREFIX}/bin/
-+ $(QUIET) $(INSTALLEXE) build/$(PROG) $(DESTDIR)${PREFIX}/bin/
-
- @echo $(COLOR_GREEN)" .. man-page into ${PREFIX}/share/man/man1/"$(COLOR_END)
-- $(QUIET) $(MKDIR) ${PREFIX}/share/man/man1/
-- $(QUIET) $(INSTALLDOC) $(PROG).1 ${PREFIX}/share/man/man1/
-+ $(QUIET) $(MKDIR) $(DESTDIR)${PREFIX}/share/man/man1/
-+ $(QUIET) $(INSTALLDOC) $(PROG).1 $(DESTDIR)${PREFIX}/share/man/man1/
-
- @echo $(COLOR_GREEN)" .. README into ${PREFIX}/share/adapterremoval/"$(COLOR_END)
-- $(QUIET) $(MKDIR) ${PREFIX}/share/adapterremoval/
-- $(QUIET) $(INSTALLDOC) README.md ${PREFIX}/share/adapterremoval/
-+ $(QUIET) $(MKDIR) $(DESTDIR)${PREFIX}/share/doc/adapterremoval/
-+ $(QUIET) $(INSTALLDOC) README.md $(DESTDIR)${PREFIX}/share/doc/adapterremoval/
-
- @echo $(COLOR_GREEN)" .. examples into ${PREFIX}/share/adapterremoval/examples/"$(COLOR_END)
-- $(QUIET) $(MKDIR) ${PREFIX}/share/adapterremoval/examples/
-- $(QUIET) $(INSTALLDAT) examples/*.* ${PREFIX}/share/adapterremoval/examples/
-+ $(QUIET) $(MKDIR) $(DESTDIR)${PREFIX}/share/adapterremoval/examples/
-+ $(QUIET) $(INSTALLDAT) examples/*.* $(DESTDIR)${PREFIX}/share/adapterremoval/examples/
-
- static: build/$(LIBNAME).a
-