summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThibaud Kehler2021-01-07 19:39:41 +0100
committerThibaud Kehler2021-01-07 19:42:36 +0100
commit9ba6ecfa34bc71c5ad81cb390365e6f704d6c6ec (patch)
tree8178f5306af6858aab5d02fcf615b00365b346c3
downloadaur-adnw-kbd-layouts.tar.gz
Initial commit of adnw-kbd-layouts
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..719dcd5bca82
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = adnw-kbd-layouts
+ pkgdesc = Keymaps for the german keyboard layouts AdNW and KOY
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://www.adnw.de/
+ arch = any
+ license = unknown
+ noextract = koy.map.gz
+ source = http://www.adnw.de/uploads/Main/Downloads/koy.map.gz
+ source = http://www.adnw.de/uploads/Main/Downloads/adnw.tar.gz
+ sha256sums = 49323903103d47ef985fdce30f17b5b4ce139ec8a5b6e452f45bc9e27b80a1d9
+ sha256sums = 7524d704a2972077297b1f885c7f50f6a5d042763567bb26b1e7caeaecd3b0e8
+
+pkgname = adnw-kbd-layouts
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fcb16c91ca3c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Thibaud Kehler <thibaud.kehler at gmx dot net>
+pkgname=adnw-kbd-layouts
+pkgver=1.0
+pkgrel=1
+pkgdesc="Keymaps for the german keyboard layouts AdNW and KOY"
+arch=(any)
+url="http://www.adnw.de/"
+license=('unknown')
+source=("http://www.adnw.de/uploads/Main/Downloads/koy.map.gz"
+ "http://www.adnw.de/uploads/Main/Downloads/adnw.tar.gz")
+noextract=("koy.map.gz")
+sha256sums=('49323903103d47ef985fdce30f17b5b4ce139ec8a5b6e452f45bc9e27b80a1d9'
+ '7524d704a2972077297b1f885c7f50f6a5d042763567bb26b1e7caeaecd3b0e8')
+
+build() {
+ # Add linebreak at EOF to avoid syntax error.
+ gunzip -c "koy.map.gz" | sed -e '$a\' | gzip > "koy.map.gz2"
+> "koy.map"
+}
+
+package() {
+ install -m644 -DT "koy.map.gz2" "$pkgdir/usr/share/kbd/keymaps/i386/adnw/koy.map.gz"
+ install -m644 -DT "adnw.map.gz" "$pkgdir/usr/share/kbd/keymaps/i386/adnw/adnw.map.gz"
+}