summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark t4802024-05-04 19:02:05 +0200
committerMark t4802024-05-04 19:02:05 +0200
commit9ce8b323beade8814ccdef690c9f1ecb7d5cfc98 (patch)
treee83c899df4a8c2fc2bf3a941eb738793faa9494c
parent846e21f9eafc848de5dcd32ec098bc05974cc33e (diff)
downloadaur-advancecomp.tar.gz
Adopt, remove COPYING (its the GPL3)
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD16
2 files changed, 13 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 386bb7020518..8f4cb1e1e489 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = advancecomp
pkgdesc = Recompression utilities for .zip .png .mng and .gz files using the 7-zip algorithm
pkgver = 2.6
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/amadvance/advancecomp
arch = x86_64
arch = aarch64
- license = GPL3
+ license = GPL-3.0-or-later
depends = gcc-libs
+ depends = glibc
depends = zlib
source = https://github.com/amadvance/advancecomp/releases/download/v2.6/advancecomp-2.6.tar.gz
sha512sums = 10cc2a72b0cf486868b52cdb78a8dc2c965bfa9f43f712fdf97af58e4b0eac62460a635fe58435e2efbc605ed281b8bf0dc560b08bbbe66ee5a8673ec40ea0a6
diff --git a/PKGBUILD b/PKGBUILD
index b0b15cb6825a..8bd6ef5552d5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Maintainer: Mark Collins <tera_1225 hat hotmail þot com>
+# Contributor: Carlos Aznarán <caznaranl@uni.pe>
# Contributor: Antonio Rojas <arojas@archlinux.org>
# Contributor: Eli Schwartz <eschwartz@archlinux.org>
# Contributor: Jens John <dev@2ion.de>
@@ -6,12 +7,16 @@
pkgname=advancecomp
pkgdesc="Recompression utilities for .zip .png .mng and .gz files using the 7-zip algorithm"
pkgver=2.6
-pkgrel=1
+pkgrel=2
arch=(x86_64 aarch64)
url="https://github.com/amadvance/${pkgname}"
-license=(GPL3)
-depends=(gcc-libs zlib)
-source=(${url}/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.gz)
+license=('GPL-3.0-or-later')
+depends=(
+ 'gcc-libs'
+ 'glibc'
+ 'zlib'
+)
+source=("${url}/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.gz")
sha512sums=('10cc2a72b0cf486868b52cdb78a8dc2c965bfa9f43f712fdf97af58e4b0eac62460a635fe58435e2efbc605ed281b8bf0dc560b08bbbe66ee5a8673ec40ea0a6')
build() {
@@ -25,5 +30,4 @@ build() {
package() {
cd ${pkgname}-${pkgver}
make DESTDIR="${pkgdir}" install
- install -Dm 644 COPYING -t "${pkgdir}/usr/share/licenses/${pkgname}"
}