summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJuraj Fiala2016-04-23 22:30:58 +0200
committerJuraj Fiala2016-04-23 22:30:58 +0200
commit45f157026d9b472705bc353c387dfd1881c97a84 (patch)
treecf98542035d249d1c5c9cdabcae3d22643642f71
parent4be0a5de33dbc0b238695cb6499036c3faf27cbb (diff)
downloadaur-45f157026d9b472705bc353c387dfd1881c97a84.tar.gz
Replace one horrible hack with one slightly less horrible hack.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD36
2 files changed, 26 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3495285da984..1426620b7d8a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat Apr 23 17:42:42 UTC 2016
+# Sat Apr 23 20:30:58 UTC 2016
pkgbase = adwaita-qt
pkgdesc = A style to bend Qt applications to look like they belong into GNOME Shell.
pkgver = 0.4
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/MartinBriza/adwaita-qt
arch = any
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index e07083c6dcf8..f0be72497f17 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgname=(
"$pkgbase-common"
)
pkgver=0.4
-pkgrel=2
+pkgrel=3
pkgdesc='A style to bend Qt applications to look like they belong into GNOME Shell.'
arch=('any' 'i686' 'x86_64')
url="https://github.com/MartinBriza/$pkgbase"
@@ -22,7 +22,7 @@ source=("https://github.com/MartinBriza/$pkgbase/archive/$pkgver.tar.gz")
sha256sums=('48ccf17088afb77e98fe409f4dc6fdccd035bbdbcb51f0c2f0da00ef204daba0')
prepare() {
- mkdir -p $pkgbase-$pkgver/build{-qt,-qt4}
+ mkdir -p $pkgbase-$pkgver/build{-qt5,-qt4,-common}
}
build() {
@@ -35,15 +35,33 @@ build() {
-DUSE_QT4=ON
popd
- pushd build-qt
+ pushd build-qt5
cmake .. \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DQT_ROOT=/usr/lib/qt
popd
+ pushd build-common
+ cmake .. \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ popd
+
+ # We don't want to install assets just yet
+ sed -ie '/(assets)/s/^/#/' CMakeLists.txt
+
make -C build-qt4
- make -C build-qt
+ make -C build-qt5
+
+ # Now we want the assets but we don't want anything else
+ sed -ie '/(assets)/s/^#//' CMakeLists.txt
+ sed -ie '/(src)/s/^/#/' CMakeLists.txt
+
+ make -C build-common
+
+ # Clean up
+ sed -ie '/(src)/s/^#//' CMakeLists.txt
}
package_adwaita-qt4() {
@@ -53,9 +71,6 @@ package_adwaita-qt4() {
cd $pkgbase-$pkgver
make install/fast DESTDIR=$pkgdir -C build-qt4
install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" README.md
-
- # The assets are in common
- rm -rf $pkgdir/usr/share
}
package_adwaita-qt5() {
@@ -64,16 +79,13 @@ package_adwaita-qt5() {
optdepends=('adwaita-qt4: Qt4 version')
cd $pkgbase-$pkgver
- make install/fast DESTDIR=$pkgdir -C build-qt
+ make install/fast DESTDIR=$pkgdir -C build-qt5
install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" README.md
-
- # The assets are in common
- rm -rf $pkgdir/usr/share
}
package_adwaita-qt-common() {
arch=('any')
license=('GPL')
- install -Dm644 -t "$pkgdir/usr/share/themes/Adwaita/qt/assets/" "$pkgbase-$pkgver/assets/"*.png
+ make install/fast DESTDIR=$pkgdir -C $pkgbase-$pkgver/build-common
}