summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraksr2015-06-23 11:41:04 +0200
committeraksr2015-06-23 11:41:04 +0200
commit9a8a4afd07aa6d4eb6a05571c37e3e28e28b6d14 (patch)
tree2669a4be37dd8a4699d29ae3fb3fa37ca13d832c
downloadaur-aee.tar.gz
Start.
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD54
-rw-r--r--fix_help_file_loc.patch25
-rw-r--r--fix_help_file_txt.patch16
-rw-r--r--fix_init_file_loc.patch12
5 files changed, 128 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6c9017d62b32
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = aee
+ pkgdesc = Advanced Easy Editor. Classic text editor with both curses and X11 interfaces.
+ pkgver = 2.2.15b
+ pkgrel = 2
+ url = http://www.users.qwest.net/~hmahon/
+ arch = i686
+ arch = x86_64
+ groups = editors
+ license = PerlArtistic
+ depends = libx11
+ source = http://www.users.qwest.net/~hmahon/sources/aee-2.2.15b.tar.gz
+ source = fix_init_file_loc.patch
+ source = fix_help_file_loc.patch
+ source = fix_help_file_txt.patch
+ sha256sums = 7abbaffe35018f9de87c8685f9bee2ea3f261e88ce60674f1a5a9a3a0f54d752
+ sha256sums = 1d41f9cabed74b20be28da6345af5e139cde13598aef692fbf905cfa3cc7ddce
+ sha256sums = 8d9c63ac16c0e06e7fe53ec322f3d09f4c9751a45a3e0955b8366e61ec15d81a
+ sha256sums = ad45d4bce57a3ce5392f83a680869353bcba236dc1c1bee7677c29e62cb005fc
+
+pkgname = aee
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1c8162edd9cd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: P. A. López-Valencia <vorbote AT users DOT sourceforge DOT net>
+# Submitter: Xavi Soler <xavi AT interrupciones DOT net>
+pkgname=aee
+pkgver=2.2.15b
+pkgrel=2
+pkgdesc="Advanced Easy Editor. Classic text editor with both curses and X11 interfaces. "
+arch=('i686' 'x86_64')
+url="http://www.users.qwest.net/~hmahon/"
+license=('PerlArtistic')
+groups=(editors)
+depends=('libx11')
+source=(http://www.users.qwest.net/~hmahon/sources/$pkgname-$pkgver.tar.gz
+ fix_init_file_loc.patch
+ fix_help_file_loc.patch
+ fix_help_file_txt.patch)
+sha256sums=('7abbaffe35018f9de87c8685f9bee2ea3f261e88ce60674f1a5a9a3a0f54d752'
+ '1d41f9cabed74b20be28da6345af5e139cde13598aef692fbf905cfa3cc7ddce'
+ '8d9c63ac16c0e06e7fe53ec322f3d09f4c9751a45a3e0955b8366e61ec15d81a'
+ 'ad45d4bce57a3ce5392f83a680869353bcba236dc1c1bee7677c29e62cb005fc')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ chmod 644 aee.c help.c localize.c help.ae
+ patch -p0 < "$srcdir/fix_init_file_loc.patch"
+ patch -p0 < "$srcdir/fix_help_file_loc.patch"
+ patch -p0 < "$srcdir/fix_help_file_txt.patch"
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make || return 1
+ make xae || return 1
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ gzip -1N aee.1
+ # Create directories
+ install -d "$pkgdir/usr/share/$pkgname"
+ install -d "$pkgdir/usr/share/doc/$pkgname"
+ install -d "$pkgdir/usr/share/licenses/$pkgname"
+ install -d "$pkgdir/usr/share/man/man1"
+ install -d "$pkgdir/usr/bin"
+ # Install files
+ install -pm644 aee.1.gz "$pkgdir/usr/share/man/man1"
+ install -pm644 help.ae "$pkgdir/usr/share/$pkgname"
+ install -pm644 README.aee "$pkgdir/usr/share/doc/$pkgname"
+ install -pm644 Changes "$pkgdir/usr/share/doc/$pkgname"
+ install -pm644 aee.1.ps "$pkgdir/usr/share/doc/$pkgname"
+ install -pm644 Artistic "$pkgdir/usr/share/licenses/$pkgname"
+ install -pm755 aee "$pkgdir/usr/bin"
+ install -pm755 xae "$pkgdir/usr/bin"
+}
+
diff --git a/fix_help_file_loc.patch b/fix_help_file_loc.patch
new file mode 100644
index 000000000000..e2ec1f356cc3
--- /dev/null
+++ b/fix_help_file_loc.patch
@@ -0,0 +1,25 @@
+--- help.c.old 1999-01-31 23:28:23.000000000 -0500
++++ help.c 2013-06-15 12:20:39.902488856 -0500
+@@ -11,10 +11,7 @@
+ #include "aee.h"
+
+ char *help_file_list[4] = {
+- "/usr/local/aee/help.ae",
+- "/usr/local/lib/help.ae",
+- "~/.help.ae",
+- "help.ae"
++ "/usr/share/aee/help.ae"
+ };
+
+ void
+--- localize.c.old 2002-07-06 00:02:21.000000000 -0500
++++ localize.c 2013-06-15 12:20:56.052376894 -0500
+@@ -64,7 +64,7 @@
+ catalog = catopen("aee", 0);
+ #endif /* NO_CATGETS */
+
+- ae_help_file = catgetlocal( 1, "/usr/local/lib/help.ae");
++ ae_help_file = catgetlocal( 1, "/usr/share/aee/help.ae");
+ main_buffer_name = catgetlocal( 2, "main");
+
+
diff --git a/fix_help_file_txt.patch b/fix_help_file_txt.patch
new file mode 100644
index 000000000000..38f049961633
--- /dev/null
+++ b/fix_help_file_txt.patch
@@ -0,0 +1,16 @@
+--- help.ae.old 2002-02-04 00:24:32.000000000 -0500
++++ help.ae 2013-06-15 12:40:19.692911745 -0500
+@@ -1058,11 +1058,11 @@
+
+ The file 'init.ae' may be used to set parameters and define keys to
+ perform certain functions within ae. This file may reside in three
+-locations: /usr/local/lib/init.ae, .init.ae in your home directory, and
++locations: /usr/share/aee/init.ae, .init.ae in your home directory, and
+ .init.ae in the current working directory.
+
+ First, aee checks for a system level initialization file, located in
+-/usr/local/lib. Next the user's home directory is checked for a file named
++/usr/share/aee. Next the user's home directory is checked for a file named
+ .init.ae, then the current directory. The settings from each file are read,
+ so that the directives from the most recently read file will take precedence
+ over previously read files. This allows, for example, the .init.ae file in
diff --git a/fix_init_file_loc.patch b/fix_init_file_loc.patch
new file mode 100644
index 000000000000..1a2ad3fa2ee0
--- /dev/null
+++ b/fix_init_file_loc.patch
@@ -0,0 +1,12 @@
+--- aee.c.old 2002-07-06 00:03:09.000000000 -0500
++++ aee.c 2013-06-13 12:49:23.995110401 -0500
+@@ -2611,8 +2611,7 @@
+ }
+
+ char *init_name[4] = {
+- "/usr/local/aee/init.ae",
+- "/usr/local/lib/init.ae",
++ "/usr/share/aee/init.ae",
+ NULL,
+ ".init.ae"
+ };