summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames An2016-07-24 15:23:46 -0400
committerJames An2016-07-24 15:23:46 -0400
commit3e455586838bcbb24b061b931e2390064c47b731 (patch)
treeb61a73f91810be5542b4e495f176ded2c1cd2052
parent363f08a73519e01dd55b92230381be7386fb5ce6 (diff)
downloadaur-3e455586838bcbb24b061b931e2390064c47b731.tar.gz
Downgraded PHP dependency from PHP 7 to PHP 5.6 as Drupal 7 and Aegir are not yet free of bugs.
-rw-r--r--PKGBUILD18
-rw-r--r--aegir.service4
-rw-r--r--aegir.target4
-rw-r--r--php-fpm.systemd.conf2
4 files changed, 14 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ead38955496b..0bf45629aae6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=aegir
pkgver=7.x_3.4
-pkgrel=1
+pkgrel=2
pkgdesc="Configuration for a dedicated Aegir server to host Drupal sites."
arch=('any')
url='http://aegirproject.org'
@@ -12,8 +12,8 @@ depends=(
"$pkgname-hostmaster"
'cron'
'nginx'
- 'php-fpm'
- 'php-gd'
+ 'php56-fpm'
+ 'php56-gd'
'rsync'
'mariadb'
'sudo'
@@ -36,13 +36,13 @@ source=("$pkgname.service"
'php.ini'
'sudoers'
)
-md5sums=('b0f2e5dca01b32c967cd823dab6b8779'
- '95bce00a6c0ac2a0b51642449554105b'
+md5sums=('c744355aae0ae7c5dd1ecadbbc312216'
+ '5b5658cd73aa4aa4d7492620a894e8ac'
'd43026960060bc677549baa26a24c9ee'
'2a640d69beeea0c03d80b75357a040fe'
'75535f9870f06c540f513262a9b7b1ab'
'496b1fa2533d1306318115e2b02984bd'
- 'f9ae0c781a7ccefc63329daaf81fca36'
+ '472dae0f2bd35c58815ec9649eea5861'
'0b53c23730e511946859d4e3c7fff982'
'0dab31966eada66adb159355ed814a54')
@@ -58,8 +58,8 @@ package() {
install -dm750 "$pkgdir/etc/sudoers.d"
install -Dm644 msmtprc "$pkgdir/etc/msmtprc.$pkgname"
install -Dm644 nginx.conf "$pkgdir/etc/nginx/$pkgname.conf"
- install -Dm644 php.ini "$pkgdir/etc/php/conf.d/$pkgname.ini"
- install -Dm644 php-fpm.conf "$pkgdir/etc/php/fpm.d/$pkgname.conf"
+ install -Dm644 php.ini "$pkgdir/etc/php56/conf.d/$pkgname.ini"
+ install -Dm644 php-fpm.conf "$pkgdir/etc/php56/fpm.d/$pkgname.conf"
install -Dm400 sudoers "$pkgdir/etc/sudoers.d/$pkgname"
install -Dm644 --owner=http --group=http <( ) "$pkgdir/var/spool/cron/$pkgname"
@@ -67,7 +67,7 @@ package() {
install -Dm644 "$pkgname.service" "$pkgdir/usr/lib/systemd/system/$pkgname.service"
install -Dm644 "$pkgname.target" "$pkgdir/usr/lib/systemd/system/$pkgname.target"
install -Dm644 nginx.systemd.conf "$pkgdir/usr/lib/systemd/system/nginx.service.d/aegir.conf"
- install -Dm644 php-fpm.systemd.conf "$pkgdir/usr/lib/systemd/system/php-fpm.service.d/aegir.conf"
+ install -Dm644 php-fpm.systemd.conf "$pkgdir/usr/lib/systemd/system/php56-fpm.service.d/aegir.conf"
msg2 'Creating $pkgname directory structure'
install --directory --owner=http --group=http --mode=6775 "$pkgdir/etc/drush"{,/cache{,/{complete,default,download,usage}}}
diff --git a/aegir.service b/aegir.service
index f7607c42f5d4..baf9fa8daf91 100644
--- a/aegir.service
+++ b/aegir.service
@@ -1,7 +1,7 @@
[Unit]
Description=Aegir queue daemon
-Wants=mysqld.service php-fpm.service
-After=mysqld.service php-fpm.service
+Wants=mysqld.service php56-fpm.service
+After=mysqld.service php56-fpm.service
[Service]
Type=simple
diff --git a/aegir.target b/aegir.target
index 9b73c8a76870..f07f644ed0f6 100644
--- a/aegir.target
+++ b/aegir.target
@@ -1,8 +1,8 @@
[Unit]
Description=Aegir Hosting System
Wants=aegir.service mailcatcher.service mailcatcher-smtp.socket network.target
-Requires=mysqld.service nginx.service php-fpm.service
-After=aegir.service mailcatcher.service mailcatcher-smtp.socket mysqld.service network.target nginx.service php-fpm.service
+Requires=mysqld.service nginx.service php56-fpm.service
+After=aegir.service mailcatcher.service mailcatcher-smtp.socket mysqld.service network.target nginx.service php56-fpm.service
[Install]
WantedBy=multi-user.target
diff --git a/php-fpm.systemd.conf b/php-fpm.systemd.conf
index 077629c67b9b..305284014f64 100644
--- a/php-fpm.systemd.conf
+++ b/php-fpm.systemd.conf
@@ -1,3 +1,3 @@
[Service]
ExecStart=
-ExecStart=/usr/bin/php-fpm --fpm-config /etc/php/fpm.d/aegir.conf
+ExecStart=/usr/bin/php56-fpm --fpm-config /etc/php56/fpm.d/aegir.conf