summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsetboolean2020-09-21 17:48:05 +0200
committersetboolean@icloud.com2020-09-21 17:48:09 +0200
commitdf18729b0e038772460dba12b27c718d73f51c0e (patch)
treeb540ae528246c8c702c649ab312b9b145c3f3388
parent57ab8c5cbc2207fcfdda7d464504b28eff5ae057 (diff)
downloadaur-afpfsng_git.tar.gz
Build patch for cmdlineafp.h
-rw-r--r--.SRCINFO6
-rw-r--r--001-cmdlineafp.patch12
-rw-r--r--PKGBUILD12
3 files changed, 25 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 63f33f9d666f..3522c307d32f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = afpfsng_git
pkgdesc = Fork of afpfs-ng that adds IPv6 support and several performance and stability improvements.
pkgver = f6e24eb
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/simonvetter/afpfs-ng
arch = x86_64
license = GPL3
@@ -10,8 +10,10 @@ pkgbase = afpfsng_git
depends = libgcrypt
provides = afpfs-ng
conflicts = afpfs-ng
+ source = 001-cmdlineafp.patch
source = git+https://github.com/simonvetter/afpfs-ng.git
- md5sums = SKIP
+ sha512sums = e7486fd27d81893c24469c2feb1c2d6f2b2f821a6e9068ef70a0236e3045927a72f040240ffcec1a2dbfa10311e12b392cf3e49c19d98cc6b7aafdbe42fb33c9
+ sha512sums = SKIP
pkgname = afpfsng_git
diff --git a/001-cmdlineafp.patch b/001-cmdlineafp.patch
new file mode 100644
index 000000000000..6a8625dfd5e3
--- /dev/null
+++ b/001-cmdlineafp.patch
@@ -0,0 +1,12 @@
+diff --color --unified --recursive --text afpfs-ng/cmdline/cmdline_afp.h afpfs-ng/cmdline/cmdline_afp.h
+--- afpfs-ng/cmdline/cmdline_afp.h 2020-09-21 17:10:42.665823984 +0200
++++ afpfs-ng/cmdline/cmdline_afp.h 2020-09-21 17:11:30.546858894 +0200
+@@ -1,7 +1,7 @@
+ #ifndef CMDLINE_AFP_H_
+ #define CMDLINE_AFP_H_
+
+-int full_url;
++extern int full_url;
+
+ int com_connect(char * arg);
+ int com_dir(char * arg);
diff --git a/PKGBUILD b/PKGBUILD
index 58611d6846f5..36db7db08a03 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Sebastian Oechsle <setboolean@icloud.com>
pkgname=afpfsng_git
pkgver=f6e24eb
-pkgrel=1
+pkgrel=2
pkgdesc="Fork of afpfs-ng that adds IPv6 support and several performance and stability improvements."
arch=('x86_64')
url="https://github.com/simonvetter/afpfs-ng"
@@ -16,15 +16,21 @@ replaces=()
backup=()
options=()
install=
-source=('git+https://github.com/simonvetter/afpfs-ng.git')
+source=('001-cmdlineafp.patch' 'git+https://github.com/simonvetter/afpfs-ng.git')
noextract=()
-md5sums=('SKIP')
+sha512sums=('e7486fd27d81893c24469c2feb1c2d6f2b2f821a6e9068ef70a0236e3045927a72f040240ffcec1a2dbfa10311e12b392cf3e49c19d98cc6b7aafdbe42fb33c9'
+ 'SKIP')
pkgver() {
cd "$srcdir/afpfs-ng"
git describe --always
}
+prepare() {
+ cd "$srcdir/afpfs-ng"
+ patch --forward --strip=1 --input="${srcdir}/001-cmdlineafp.patch"
+}
+
build() {
cd "$srcdir/afpfs-ng"
./configure