summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAinola2015-08-08 13:23:47 -0600
committerAinola2015-08-08 13:23:47 -0600
commit36413b3de9d99e91bea0a08e5451e9d84547705e (patch)
tree643d5db774a4856071af45a95081264a1e0d7a23
downloadaur-36413b3de9d99e91bea0a08e5451e9d84547705e.tar.gz
migrate from AUR3
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD48
-rw-r--r--ags.install11
3 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..465b434628d5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = ags-git
+ pkgdesc = Adventure Game Studio, a development tool that is primarily used to create graphical adventure games
+ pkgver = 3.3.4.1.7.geeb96c4
+ pkgrel = 1
+ url = https://github.com/adventuregamestudio/ags
+ install = ags.install
+ arch = i686
+ arch = x86_64
+ license = Artistic2.0
+ makedepends = git
+ makedepends = wxgtk
+ depends = allegro4
+ depends = dumb
+ depends = freetype2
+ depends = libogg
+ depends = libtheora
+ depends = libvorbis
+ optdepends = wine: for installing and configuring the game
+ source = git://github.com/adventuregamestudio/ags.git
+ md5sums = SKIP
+
+pkgname = ags-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6d67dccfc2af
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Ainola
+# Contributor: Ner0
+# Contributor: quantax -- contact via Arch Linux forum or AUR
+
+pkgname=ags-git
+pkgver=3.3.4.1.7.geeb96c4
+pkgrel=1
+pkgdesc="Adventure Game Studio, a development tool that is primarily used to create graphical adventure games"
+arch=('i686' 'x86_64')
+url="https://github.com/adventuregamestudio/ags"
+license=('Artistic2.0')
+depends=('allegro4' 'dumb' 'freetype2' 'libogg' 'libtheora' 'libvorbis')
+makedepends=('git' 'wxgtk')
+optdepends=('wine: for installing and configuring the game')
+install=ags.install
+source=('git://github.com/adventuregamestudio/ags.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/ags"
+ echo $(git describe --tags | sed s'/v\.//;s/-/./g')
+}
+
+prepare() {
+ cd "$srcdir/ags"
+ sed -i 's/-Wfatal-errors\ //' Engine/Makefile-defs.linux
+ git submodule update --init
+}
+
+build() {
+ cd "$srcdir/ags"
+
+ make -C Engine
+
+# cd Manual/
+# ./compile_documentation_unix.sh
+}
+
+package() {
+ install -Dm755 "$srcdir/ags/Engine/ags" "$pkgdir/usr/bin/ags"
+
+ install -Dm644 "$srcdir/ags/License.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+# install -dm755 "$pkgdir/usr/share/doc/$pkgname/html"
+# install -m644 "$srcdir/ags/Manual"/*.htm "$pkgdir/usr/share/doc/$pkgname/html/"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/ags.install b/ags.install
new file mode 100644
index 000000000000..62403a86f514
--- /dev/null
+++ b/ags.install
@@ -0,0 +1,11 @@
+post_install() {
+ echo ""
+ echo " In order to run a game, you must first install it either with Wine"
+ echo " or just use Windows installation"
+
+ echo " To run it type ags '/GameDir/Game.exe'"
+
+ echo " The native game configurator isn't supported yet,"
+ echo " so you must use the Windows one ('winsetup.exe') with Wine."
+ echo ""
+}