summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Beste2017-07-10 09:04:01 -0500
committerDan Beste2017-07-10 09:04:01 -0500
commit7ffc3b98180199fe0e5cb1c750030351f20393b4 (patch)
treea06911afaee89365452f16ac77734324c662061d
parent85df90e15f1c5f48ff8fe439904d556e962a47a4 (diff)
downloadaur-7ffc3b98180199fe0e5cb1c750030351f20393b4.tar.gz
Update PKGBUILD
-rw-r--r--PKGBUILD61
1 files changed, 29 insertions, 32 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6ceb41faf372..45564ab61f95 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname='ags-git'
_pkgname='ags'
-pkgver=3.4.1.4.r40.g8e66a52d
+pkgver=3.4.1.6.r56.g234c69ef
pkgrel=1
pkgdesc='Adventure Game Studio, a development tool that is primarily used to create graphical adventure games'
arch=('i686' 'x86_64')
@@ -18,54 +18,51 @@ optdepends=('wine: For non-native games')
conflicts=("${_pkgname}")
provides=("${_pkgname}")
source=(
- 'git+https://github.com/adventuregamestudio/ags.git'
- 'agslua::git+https://github.com/duncanc/Lua-for-AGS.git'
- 'git+https://github.com/google/googletest.git'
+ 'git+https://github.com/adventuregamestudio/ags.git'
+ 'agslua::git+https://github.com/duncanc/Lua-for-AGS.git'
+ 'git+https://github.com/google/googletest.git'
)
sha256sums=('SKIP' 'SKIP' 'SKIP')
pkgver() {
- cd "${_pkgname}"
+ cd "${_pkgname}"
- git describe --long --tags \
- | sed 's/\([^-]*-g\)/r\1/;s/-/./g' \
- | sed 's/v.//'
+ git describe --long --tags \
+ | sed 's/\([^-]*-g\)/r\1/;s/-/./g' \
+ | sed 's/v.//'
}
prepare() {
- cd "${_pkgname}"
+ cd "${_pkgname}"
- local submodules=(
- 'agslua'
- 'googletest'
- )
+ local submodules=(
+ 'Plugins/agslua/agslua'
+ 'Common/libsrc/googletest'
+ )
- for module in "${submodules[@]}"; do
- local submodule
- submodule=$(grep -F 'path = ' .gitmodules \
- | grep -F "${module}" \
- | awk '{print $3}')
-
- git submodule init "${submodule}"
- git config "submodule.${submodule}.url" "${srcdir}/${module}"
- git submodule update "${submodule}"
- done
+ for module in "${submodules[@]}"; do
+ git submodule init "${module}"
+ git config "submodule.${module}.url" "${srcdir}/${module}"
+ git submodule update "${module}"
+ done
}
build() {
- cd "${_pkgname}"
+ cd "${_pkgname}"
- make --directory=Engine
+ make --directory=Engine
}
package() {
- cd "${_pkgname}"
+ cd "${_pkgname}"
- install -D -m 755 \
- "Engine/${_pkgname}" \
- "${pkgdir}/usr/bin/${_pkgname}"
+ install -D -m 755 \
+ "Engine/${_pkgname}" \
+ "${pkgdir}/usr/bin/${_pkgname}"
- install -D -m 644 \
- "License.txt" \
- "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m 644 \
+ "License.txt" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
+
+# vim: expandtab shiftwidth=2 tabstop=2