summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Beste2017-06-04 14:20:45 -0500
committerDan Beste2017-06-04 14:20:45 -0500
commit85df90e15f1c5f48ff8fe439904d556e962a47a4 (patch)
tree0a5ab7801ae679e188f5bb33e61f5049b771e8dc
parent62fdd8c95884d019049f1d384fd05486e03808c8 (diff)
downloadaur-85df90e15f1c5f48ff8fe439904d556e962a47a4.tar.gz
Update PKGBUILD
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD42
2 files changed, 38 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 83766316b7ef..1bd8e9c72bba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ags-git
pkgdesc = Adventure Game Studio, a development tool that is primarily used to create graphical adventure games
- pkgver = 3.4.1.3.r7.gb4199b73
+ pkgver = 3.4.1.4.r40.g8e66a52d
pkgrel = 1
url = http://www.adventuregamestudio.co.uk/
arch = i686
@@ -9,6 +9,7 @@ pkgbase = ags-git
makedepends = git
depends = allegro
depends = dumb
+ depends = freetype2
depends = libogg
depends = libtheora
depends = libvorbis
@@ -16,6 +17,10 @@ pkgbase = ags-git
provides = ags
conflicts = ags
source = git+https://github.com/adventuregamestudio/ags.git
+ source = agslua::git+https://github.com/duncanc/Lua-for-AGS.git
+ source = git+https://github.com/google/googletest.git
+ sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = ags-git
diff --git a/PKGBUILD b/PKGBUILD
index 918970a471ab..6ceb41faf372 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,28 @@
# Maintainer: Dan Beste <dan.ray.beste@gmail.com>
-# Previously:
-# Maintainer: Frederic Bezies <fredbezies at gmail dot com>
-
+# Contributor: Frederic Bezies <fredbezies at gmail dot com>
# Contributor: Ainola
# Contributor: Ner0
# Contributor: quantax
pkgname='ags-git'
_pkgname='ags'
-pkgver=3.4.1.3.r7.gb4199b73
+pkgver=3.4.1.4.r40.g8e66a52d
pkgrel=1
-pkgdesc="Adventure Game Studio, a development tool that is primarily used to create graphical adventure games"
+pkgdesc='Adventure Game Studio, a development tool that is primarily used to create graphical adventure games'
arch=('i686' 'x86_64')
url='http://www.adventuregamestudio.co.uk/'
license=('custom: Artistic 2.0')
-depends=('allegro' 'dumb' 'libogg' 'libtheora' 'libvorbis')
+depends=('allegro' 'dumb' 'freetype2' 'libogg' 'libtheora' 'libvorbis')
makedepends=('git')
optdepends=('wine: For non-native games')
conflicts=("${_pkgname}")
provides=("${_pkgname}")
-source=('git+https://github.com/adventuregamestudio/ags.git')
-sha256sums=('SKIP')
+source=(
+ 'git+https://github.com/adventuregamestudio/ags.git'
+ 'agslua::git+https://github.com/duncanc/Lua-for-AGS.git'
+ 'git+https://github.com/google/googletest.git'
+)
+sha256sums=('SKIP' 'SKIP' 'SKIP')
pkgver() {
cd "${_pkgname}"
@@ -30,6 +32,26 @@ pkgver() {
| sed 's/v.//'
}
+prepare() {
+ cd "${_pkgname}"
+
+ local submodules=(
+ 'agslua'
+ 'googletest'
+ )
+
+ for module in "${submodules[@]}"; do
+ local submodule
+ submodule=$(grep -F 'path = ' .gitmodules \
+ | grep -F "${module}" \
+ | awk '{print $3}')
+
+ git submodule init "${submodule}"
+ git config "submodule.${submodule}.url" "${srcdir}/${module}"
+ git submodule update "${submodule}"
+ done
+}
+
build() {
cd "${_pkgname}"
@@ -39,11 +61,11 @@ build() {
package() {
cd "${_pkgname}"
- install -Dm 755 \
+ install -D -m 755 \
"Engine/${_pkgname}" \
"${pkgdir}/usr/bin/${_pkgname}"
- install -Dm 644 \
+ install -D -m 644 \
"License.txt" \
"${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}