summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJorge Barroso2015-06-15 21:27:45 +0200
committerJorge Barroso2015-06-15 21:27:45 +0200
commitdae1c6b0c80e2bc6f22e2aa3edaf183ae3d12a69 (patch)
tree8409f7e71acebf740fd9674182f6946f14d0a921
downloadaur-aircrack-m4-svn.tar.gz
Initial import
-rw-r--r--.AURINFO17
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD42
3 files changed, 77 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..20fd14188ecc
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,17 @@
+pkgbase = aircrack-m4-svn
+ pkgdesc = A GUI for aircrack-ng written in C++ an Qt.
+ pkgver = r18
+ pkgrel = 2
+ url = http://code.google.com/p/aircrackgui-m4/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = subversion
+ depends = qt4
+ depends = aircrack-ng
+ depends = macchanger
+ provides = aircrack-m4
+ source = svn+http://aircrackgui-m4.googlecode.com/svn/trunk/
+
+pkgname = aircrack-m4-svn
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..045710fa4c4f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = aircrack-m4-svn
+ pkgdesc = A GUI for aircrack-ng written in C++ an Qt.
+ pkgver = r18
+ pkgrel = 2
+ url = http://code.google.com/p/aircrackgui-m4/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = subversion
+ depends = qt4
+ depends = aircrack-ng
+ depends = macchanger
+ provides = aircrack-m4
+ source = svn+http://aircrackgui-m4.googlecode.com/svn/trunk/
+ sha512sums = SKIP
+
+pkgname = aircrack-m4-svn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bf7fc3b3b8fa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+#! /bin/bash
+# Maintainer: Jorge Barroso <jorge.barroso.11 at gmail dot com>
+# Contributor: lssjbrolli <lssjbrolli@gmail.com>
+pkgname=aircrack-m4-svn
+pkgver=r18
+pkgrel=2
+pkgdesc="A GUI for aircrack-ng written in C++ an Qt."
+arch=('i686' 'x86_64')
+url="http://code.google.com/p/aircrackgui-m4/"
+license=('GPL')
+depends=('qt4' 'aircrack-ng' 'macchanger')
+makedepends=('subversion')
+provides=(aircrack-m4)
+source=("svn+http://aircrackgui-m4.googlecode.com/svn/trunk/")
+sha512sums=('SKIP')
+
+_svnmod=trunk
+
+pkgver() {
+ cd trunk/
+ local ver="$(svnversion)"
+ printf "r%s" "${ver//[[:alpha:]]}"
+}
+
+build() {
+ msg "Starting build..."
+
+ rm -rf "$srcdir/$_svnmod-build"
+ cp -r "$srcdir/$_svnmod" "$srcdir/$_svnmod-build"
+ cd "$srcdir/$_svnmod-build"
+
+
+ qmake-qt4
+ make
+}
+
+package() {
+ cd "$srcdir/$_svnmod-build"
+ mkdir -p $pkgdir/usr/bin/
+ cp aircrack-GUI $pkgdir/usr/bin/aircrackgui-m4
+}
+