summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordroserasprout2016-08-25 12:45:09 +0300
committerdroserasprout2016-08-25 12:45:09 +0300
commit0ab880907b11470d6bc40211539e18d375d12cd7 (patch)
tree62823188b0366b0fd4f37f2fe0dbd702ccc6ce32
downloadaur-0ab880907b11470d6bc40211539e18d375d12cd7.tar.gz
initial commit
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD21
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b49566575390
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = airdcpp-webclient
+ pkgdesc = A peer-to-peer file sharing client with web user interface
+ pkgver = 1.2.0
+ pkgrel = 1
+ url = https://github.com/airdcpp-web/airdcpp-webclient
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = make
+ depends = miniupnpc
+ depends = boost
+ depends = bzip2
+ depends = zlib
+ depends = openssl
+ depends = glibc
+ depends = geoip
+ depends = leveldb
+ depends = websocketpp
+ depends = libnatpmp
+ depends = intel-tbb
+ options = !strip
+ source = airdcpp-webclient::git+https://github.com/airdcpp-web/airdcpp-webclient.git
+ sha256sums = SKIP
+
+pkgname = airdcpp-webclient
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..384144a4e4f1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: droserasprout <droserasprout@tuta.io>
+
+pkgname=airdcpp-webclient
+pkgver=1.2.0
+pkgrel=1
+pkgdesc="A peer-to-peer file sharing client with web user interface"
+arch=('i686' 'x86_64')
+license=('GPL2')
+url="https://github.com/airdcpp-web/${pkgname}"
+depends=('miniupnpc' 'boost' 'bzip2' 'zlib' 'openssl' 'glibc' 'geoip' 'leveldb' 'websocketpp' 'libnatpmp' 'intel-tbb')
+makedepends=('git' 'make')
+options=('!strip')
+source=("${pkgname}::git+${url}.git")
+sha256sums=('SKIP')
+
+package() {
+ cd ${pkgname}
+ cmake .
+ make
+ make install DESTDIR="$pkgdir"
+}