summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Kauselmann2019-02-22 19:10:42 +0100
committerFelix Kauselmann2019-02-22 19:10:42 +0100
commit321bccfd36aa8d4c959a95190549835197bd4070 (patch)
treec0cddbdfc708a031d48ca1ccc578a091a5991a25
parent6d321f4458a7917806332ec8cede01a4c0be5a56 (diff)
downloadaur-321bccfd36aa8d4c959a95190549835197bd4070.tar.gz
Update to 2.5.1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD11
-rw-r--r--boost.patch23
3 files changed, 9 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b5dfbcd93622..4eefa05bf61d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sa Feb 2 10:17:40 UTC 2019
+# Fr Feb 22 18:10:07 UTC 2019
pkgbase = airdcpp-webclient
pkgdesc = A peer-to-peer file sharing client with web user interface
- pkgver = 2.5.0
- pkgrel = 2
+ pkgver = 2.5.1
+ pkgrel = 1
url = https://github.com/airdcpp-web/airdcpp-webclient
arch = x86_64
arch = armv7h
@@ -21,10 +21,8 @@ pkgbase = airdcpp-webclient
depends = websocketpp
depends = libnatpmp
depends = intel-tbb
- source = https://github.com/airdcpp-web/airdcpp-webclient/archive/2.5.0.tar.gz
- source = boost.patch
- md5sums = 17e80ed002f6e956b39a2bb4154ea776
- md5sums = 03dd07a2bc073e5c4ca29b8f1480b2a5
+ source = https://github.com/airdcpp-web/airdcpp-webclient/archive/2.5.1.tar.gz
+ md5sums = a817cff71c03bbe3e524a3d215779786
pkgname = airdcpp-webclient
diff --git a/PKGBUILD b/PKGBUILD
index a64b741b922b..b88f6ad8fa46 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,22 +3,19 @@
# Contributor: atommixz <atommixz@gmail.com>
pkgname=airdcpp-webclient
-pkgver=2.5.0
-pkgrel=2
+pkgver=2.5.1
+pkgrel=1
pkgdesc="A peer-to-peer file sharing client with web user interface"
arch=('x86_64' 'armv7h')
license=('GPL2')
url="https://github.com/airdcpp-web/${pkgname}"
depends=('miniupnpc' 'boost' 'libmaxminddb' 'leveldb' 'openssl' 'geoip' 'leveldb' 'websocketpp' 'libnatpmp' 'intel-tbb')
makedepends=('cmake' 'git' 'npm')
-source=("https://github.com/airdcpp-web/airdcpp-webclient/archive/${pkgver}.tar.gz"
- "boost.patch")
-md5sums=('17e80ed002f6e956b39a2bb4154ea776'
- '03dd07a2bc073e5c4ca29b8f1480b2a5')
+source=("https://github.com/airdcpp-web/airdcpp-webclient/archive/${pkgver}.tar.gz")
+md5sums=('a817cff71c03bbe3e524a3d215779786')
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}/airdcpp-core"
- patch -p2 --ignore-whitespace < "${srcdir}/boost.patch"
}
build() {
diff --git a/boost.patch b/boost.patch
deleted file mode 100644
index d12a5f394ea3..000000000000
--- a/boost.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From c60336895b398f2557adf146c3b4a8a03a541e27 Mon Sep 17 00:00:00 2001
-From: maksis <maksis@adrenaline-network.com>
-Date: Sat, 2 Feb 2019 05:52:03 +0200
-Subject: [PATCH] Fix compiling with Boost 1.69
-
-https://github.com/airdcpp-web/airdcpp-webclient/issues/308
----
- airdcpp/airdcpp/Client.cpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/airdcpp/airdcpp/Client.cpp b/airdcpp/airdcpp/Client.cpp
-index 997d9dcde..1412ae9d0 100644
---- a/airdcpp/airdcpp/Client.cpp
-+++ b/airdcpp/airdcpp/Client.cpp
-@@ -143,7 +143,7 @@ void Client::reloadSettings(bool aUpdateNick) noexcept {
- }
-
- bool Client::changeBoolHubSetting(HubSettings::HubBoolSetting aSetting) noexcept {
-- auto newValue = !get(aSetting);
-+ auto newValue = static_cast<bool>(!get(aSetting));
- get(aSetting) = newValue;
-
- //save for a favorite hub if needed