summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Kauselmann2019-02-02 11:18:28 +0100
committerFelix Kauselmann2019-02-02 11:18:28 +0100
commit6d321f4458a7917806332ec8cede01a4c0be5a56 (patch)
tree6bed4a0faae4cfb164dee34b4980899011cc11c2
parent27ee7d10fd69762c60f1f317e560ad8b78af9791 (diff)
downloadaur-6d321f4458a7917806332ec8cede01a4c0be5a56.tar.gz
Fix compilation with boost 1.69.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
-rw-r--r--boost.patch23
3 files changed, 37 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c746cf962e62..b5dfbcd93622 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Di Dez 25 10:02:55 UTC 2018
+# Sa Feb 2 10:17:40 UTC 2019
pkgbase = airdcpp-webclient
pkgdesc = A peer-to-peer file sharing client with web user interface
pkgver = 2.5.0
- pkgrel = 0
+ pkgrel = 2
url = https://github.com/airdcpp-web/airdcpp-webclient
arch = x86_64
arch = armv7h
@@ -22,7 +22,9 @@ pkgbase = airdcpp-webclient
depends = libnatpmp
depends = intel-tbb
source = https://github.com/airdcpp-web/airdcpp-webclient/archive/2.5.0.tar.gz
+ source = boost.patch
md5sums = 17e80ed002f6e956b39a2bb4154ea776
+ md5sums = 03dd07a2bc073e5c4ca29b8f1480b2a5
pkgname = airdcpp-webclient
diff --git a/PKGBUILD b/PKGBUILD
index 06a8ed08af3a..a64b741b922b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,15 +4,22 @@
pkgname=airdcpp-webclient
pkgver=2.5.0
-pkgrel=0
+pkgrel=2
pkgdesc="A peer-to-peer file sharing client with web user interface"
arch=('x86_64' 'armv7h')
license=('GPL2')
url="https://github.com/airdcpp-web/${pkgname}"
depends=('miniupnpc' 'boost' 'libmaxminddb' 'leveldb' 'openssl' 'geoip' 'leveldb' 'websocketpp' 'libnatpmp' 'intel-tbb')
makedepends=('cmake' 'git' 'npm')
-source=("https://github.com/airdcpp-web/airdcpp-webclient/archive/${pkgver}.tar.gz")
-md5sums=('17e80ed002f6e956b39a2bb4154ea776')
+source=("https://github.com/airdcpp-web/airdcpp-webclient/archive/${pkgver}.tar.gz"
+ "boost.patch")
+md5sums=('17e80ed002f6e956b39a2bb4154ea776'
+ '03dd07a2bc073e5c4ca29b8f1480b2a5')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}/airdcpp-core"
+ patch -p2 --ignore-whitespace < "${srcdir}/boost.patch"
+}
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
diff --git a/boost.patch b/boost.patch
new file mode 100644
index 000000000000..d12a5f394ea3
--- /dev/null
+++ b/boost.patch
@@ -0,0 +1,23 @@
+From c60336895b398f2557adf146c3b4a8a03a541e27 Mon Sep 17 00:00:00 2001
+From: maksis <maksis@adrenaline-network.com>
+Date: Sat, 2 Feb 2019 05:52:03 +0200
+Subject: [PATCH] Fix compiling with Boost 1.69
+
+https://github.com/airdcpp-web/airdcpp-webclient/issues/308
+---
+ airdcpp/airdcpp/Client.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/airdcpp/airdcpp/Client.cpp b/airdcpp/airdcpp/Client.cpp
+index 997d9dcde..1412ae9d0 100644
+--- a/airdcpp/airdcpp/Client.cpp
++++ b/airdcpp/airdcpp/Client.cpp
+@@ -143,7 +143,7 @@ void Client::reloadSettings(bool aUpdateNick) noexcept {
+ }
+
+ bool Client::changeBoolHubSetting(HubSettings::HubBoolSetting aSetting) noexcept {
+- auto newValue = !get(aSetting);
++ auto newValue = static_cast<bool>(!get(aSetting));
+ get(aSetting) = newValue;
+
+ //save for a favorite hub if needed