summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Kauselmann2018-06-08 09:18:45 +0200
committerFelix Kauselmann2018-06-08 09:18:45 +0200
commit70633c4fc4a02e8fc82e2bd65a88b30e409acb89 (patch)
treefd7ea6fcef498933778ba4d9f8ee25179943c6fc
parentf7760eb6550a3dd3b55ca0e8944b2c818253a537 (diff)
downloadaur-70633c4fc4a02e8fc82e2bd65a88b30e409acb89.tar.gz
Fix build
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD24
2 files changed, 19 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0f43c63215df..36309c8c3d25 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,10 @@
+# Generated by mksrcinfo v8
+# Fr Jun 8 07:18:23 UTC 2018
pkgbase = airdcpp-webclient
pkgdesc = A peer-to-peer file sharing client with web user interface
pkgver = 2.3.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/airdcpp-web/airdcpp-webclient
- arch = i686
arch = x86_64
arch = armv7h
license = GPL2
@@ -12,20 +13,16 @@ pkgbase = airdcpp-webclient
makedepends = npm
depends = miniupnpc
depends = boost
- depends = boost-libs
- depends = bzip2
depends = libmaxminddb
- depends = gcc-libs
+ depends = leveldb
depends = openssl
depends = geoip
depends = leveldb
- depends = websocketpp
- depends = zlib
+ depends = websocketpp-git-dev
depends = libnatpmp
depends = intel-tbb
- options = !strip
- source = git+https://github.com/airdcpp-web/airdcpp-webclient.git#tag=2.3.0
- sha256sums = SKIP
+ source = https://github.com/airdcpp-web/airdcpp-webclient/archive/2.3.0.tar.gz
+ md5sums = 1241718cce0d238691b42e4dfa105b4d
pkgname = airdcpp-webclient
diff --git a/PKGBUILD b/PKGBUILD
index 9b25301b5ff7..81327222ee31 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,26 @@
-# Maintainer: droserasprout <droserasprout@tuta.io>
+# Maintainer: Felix Kauselmann <licorn@gmail,com>
+# Contributor: droserasprout <droserasprout@tuta.io>
# Contributor: atommixz <atommixz@gmail.com>
pkgname=airdcpp-webclient
pkgver=2.3.0
-pkgrel=1
+pkgrel=2
pkgdesc="A peer-to-peer file sharing client with web user interface"
-arch=('i686' 'x86_64' 'armv7h')
+arch=('x86_64' 'armv7h')
license=('GPL2')
url="https://github.com/airdcpp-web/${pkgname}"
-depends=('miniupnpc' 'boost' 'boost-libs' 'bzip2' 'libmaxminddb' 'leveldb' 'gcc-libs' 'openssl' 'geoip' 'leveldb' 'websocketpp' 'zlib' 'libnatpmp' 'intel-tbb')
+depends=('miniupnpc' 'boost' 'libmaxminddb' 'leveldb' 'openssl' 'geoip' 'leveldb' 'websocketpp-git-dev' 'libnatpmp' 'intel-tbb')
makedepends=('cmake' 'git' 'npm')
-options=('!strip')
-source=("git+${url}.git#tag=${pkgver}")
-sha256sums=('SKIP')
+source=("https://github.com/airdcpp-web/airdcpp-webclient/archive/${pkgver}.tar.gz")
+md5sums=('1241718cce0d238691b42e4dfa105b4d')
build() {
- cd ${pkgname}
- cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release .
- make -j2
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ cmake ./ -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_LIBDIR=lib
+ make
}
package() {
- cd ${pkgname}
- make install DESTDIR="$pkgdir"
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="$pkgdir" install
}