summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOpenSorcerer2023-06-12 18:02:10 +0200
committerOpenSorcerer2023-06-12 18:02:10 +0200
commit905aa2e860f162d0682dbb26bf9950c8726ea258 (patch)
treea6a9d90d20a915ed779f4f99edc5e2b9b9a393f8
parent1dfc7e0b762cb724eab521d20fb7e799fed717c8 (diff)
downloadaur-905aa2e860f162d0682dbb26bf9950c8726ea258.tar.gz
pkgver++, add transient deps
-rw-r--r--.SRCINFO12
-rw-r--r--Changelog-Suite.txt120
-rw-r--r--PKGBUILD21
3 files changed, 142 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 26aff74d7748..22b1aaba3e02 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = airvpn-suite
pkgdesc = AirVPN client software collection including Bluetit, Goldcrest and Hummingbird – stable
- pkgver = 1.2.1
+ pkgver = 1.3.0
pkgrel = 1
url = https://gitlab.com/AirVPN/AirVPN-Suite
install = airvpn-suite.install
@@ -9,10 +9,18 @@ pkgbase = airvpn-suite
license = GPL3
makedepends = git
makedepends = wget
+ makedepends = wireguard-tools
depends = dbus
depends = libxml2
depends = crypto++
depends = curl
+ depends = zlib
+ depends = lz4
+ depends = openssl
+ depends = zstd
+ depends = xz
+ depends = glibc
+ depends = gcc-libs
provides = hummingbird
provides = hummingbird-bin
provides = airvpn-suite-bin
@@ -22,7 +30,7 @@ pkgbase = airvpn-suite
conflicts = airvpn-suite-bin
conflicts = airvpn-suite-beta-bin
backup = etc/airvpn/bluetit.rc
- source = git+https://gitlab.com/AirVPN/AirVPN-Suite.git#commit=2252964899b6da4221c7ecfe14af8eacc714b40f
+ source = git+https://gitlab.com/AirVPN/AirVPN-Suite.git#commit=ef5ce5ad8fff24f3476f3a072f44d31a5cd1d3fc
sha256sums = SKIP
pkgname = airvpn-suite
diff --git a/Changelog-Suite.txt b/Changelog-Suite.txt
index 2f354f4a45d8..3134157bba50 100644
--- a/Changelog-Suite.txt
+++ b/Changelog-Suite.txt
@@ -1,5 +1,125 @@
Changelog for AirVPN Suite
+Version 1.3.0 - 1 June 2023
+
+- [ProMIND] updated to OpenVPN3 AirVPN 3.8.4
+- [ProMIND] replaced include guards with #pragma once in all include files
+- [ProMIND] added file continent_names.csv
+- [ProMIND] installation script: improved group management for specific system cases
+
+
+airvpnmanifest
+
+- [ProMIND] updated to AirVPN document version 288
+- [ProMIND] loadManifest() can now force the loading of the local instance (if any)
+- [ProMIND] loadManifest() statistics are now counted for continent and earth as well
+- [ProMIND] loadManifest() added support for new AirVPNServer class members compliance
+- [ProMIND] processXmlManifest() countryStats now includes closed servers as well
+- [ProMIND] getServerListByCountry() now accepts continents as well
+
+
+airvpnserver
+
+- [ProMIND] renamed specific OpenVPN members
+- [ProMIND] added members for WireGuard support
+- [ProMIND] added members for Perfect Forward Secrecy (PFS) support
+- [ProMIND] members supportIPv4 renamed to IPv4Available
+- [ProMIND] members supportIPv6 renamed to IPv6Available
+
+
+airvpnserverprovider
+
+- [ProMIND] members supportIPv4 renamed to IPv4Available
+- [ProMIND] members supportIPv6 renamed to IPv6Available
+
+
+airvpntools
+
+- [ProMIND] updated to AirVPN document version 288
+- [ProMIND] added int AirVpnDocumentVersion
+- [ProMIND] added std::string wireguardPublicKey
+- [ProMIND] added method getAirVpnDocumentVersion()
+- [ProMIND] requestAirVPNDocument(): in case document version is not set by caller, it is then set to the default value
+- [ProMIND] added methods getWireGuardPublicKey() and setWireGuardPublicKey()
+- [ProMIND] added method getWireGuardProfile()
+- [ProMIND] added method realCountryName(): return the normalized country/continent name
+- [ProMIND] added method loadLinuxModule()
+- [ProMIND] added method replaceAll()
+- [ProMIND] added method formatTimestamp()
+- [ProMIND] added methods getVPNConfigFileType() and getVPNProfileType()
+- [ProMIND] added unit of measure mode to formatTransferRate() and formatDataVolume() methods (defaults to decimal mode)
+
+
+airvpnuser
+
+- [ProMIND] updated to AirVPN document version 288
+- [ProMIND] added WireGuard members to struct UserKey
+- [ProMIND] added method getWireGuardProfile()
+- [ProMIND] getOpenVPNProfile(): replaced "cipher" with "data-ciphers"
+- [ProMIND] getOpenVPNProfile(): removed "comp-lzo" support
+
+
+countrycontinent
+
+- [ProMIND] added method isContinent()
+- [ProMIND] added method getContinentCode()
+- [ProMIND] added method getContinentName()
+
+
+dbusconnector
+
+- [ProMIND] mutex lock operations are now depending on timeout
+
+
+loadmod
+
+- [ProMIND] added MODULE_IS_EMBEDDED, MODULE_DEP_FILE_NOT_FOUND and MODULE_BUILTIN_FILE_NOT_FOUND macros
+- [ProMIND] load_kernel_module(): added check to modules.builtin
+
+
+localnetwork
+
+- [ProMIND] added struct IPAddress and enum IPFamily
+- [ProMIND] removed local struct IPEntry (superseeded by IPAddress and IPFamily)
+- [ProMIND] added method parseIpSpecification()
+
+
+netfilter
+
+- [ProMIND] removed method loadLinuxModule() (moved to airvpntools)
+- [ProMIND] enum Direction replaced by enum Hook
+- [ProMIND] Replaced enum IP with LocalNetwork's enum IPFamily
+- [ProMIND] extensive and complete re-engineering and revision in order to allow a full and dynamic management of rules (notably nftables)
+
+
+openvpnclient
+
+- [ProMIND] added method profileNeedsResolution()
+- [ProMIND] added method resolveProfile()
+- [ProMIND] system DNS operations are now handled by methods saveSystemDNS(), allowSystemDNS() and rejectSystemDNS()
+- [ProMIND] bypass routes are now added at connection establishment in order to allow "redirect-gateway" ignore to work properly
+- [ProMIND] onAssignIpEvent(): add local gateway to netFilter in case gateway has not been redirected (pull-filter ignore "redirect-gateway")
+- [ProMIND] print_stats(): stats are now shown only in case of connection to VPN server
+- [ProMIND] removed references to LocalNetwork::IPEntry and replaced with IPAddress and IPFamily
+- [ProMIND] implemented and overridden all virtual tun_builder_* methods
+- [ProMIND] tun_builder_set_mtu(): now correctly sets MTU according to tun-mtu directive
+- [ProMIND] Replaced struct IPClass with LocalNetwork's enum IPFamily
+- [ProMIND] onResolveEvent(): proxy is now properly added to the network filter
+
+
+vpnclient
+
+- [ProMIND] refactored and renamed to openvpnclient
+
+
+wireguardclient
+
+- [ProMIND] new class
+
+
+*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*
+
+
Version 1.2.1 - 9 December 2022
- [ProMIND] production release
diff --git a/PKGBUILD b/PKGBUILD
index 6d93f9bf4122..89081663a6a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: OpenSorcerer <alex at opensourcery dot eu>
pkgname=airvpn-suite
_pkgname=AirVPN-Suite
-pkgver=1.2.1
+pkgver=1.3.0
pkgrel=1
-_commit="2252964899b6da4221c7ecfe14af8eacc714b40f"
+_commit="ef5ce5ad8fff24f3476f3a072f44d31a5cd1d3fc"
pkgdesc="AirVPN client software collection including Bluetit, Goldcrest and Hummingbird – stable"
arch=('x86_64')
url="https://gitlab.com/AirVPN/$_pkgname"
license=('GPL3')
provides=('hummingbird' 'hummingbird-bin' 'airvpn-suite-bin' 'airvpn-suite-beta-bin')
conflicts=('hummingbird' 'hummingbird-bin' 'airvpn-suite-bin' 'airvpn-suite-beta-bin')
-depends=('dbus' 'libxml2' 'crypto++' 'curl')
-makedepends=('git' 'wget')
+depends=('dbus' 'libxml2' 'crypto++' 'curl' 'zlib' 'lz4' 'openssl' 'zstd' 'xz' 'glibc' 'gcc-libs')
+makedepends=('git' 'wget' 'wireguard-tools')
source=("git+$url.git#commit=$_commit")
sha256sums=('SKIP')
backup=('etc/airvpn/bluetit.rc')
@@ -24,19 +24,22 @@ build() {
export DEP_DIR="$O3/deps" && mkdir "$DEP_DIR"
export DL="$O3/dl" && mkdir "$DL"
cd "$O3"
-
+
# clone and build OpenVPN3 core
git clone https://github.com/AirVPN/openvpn3-airvpn.git core
cd core/scripts/linux
./build-all
-
+
# move directories around for the suite build scripts
cd "$srcdir"
mv "$O3/core" "$srcdir/openvpn3-airvpn"
mv "$O3/deps/asio" "$srcdir"
-
+
# build the suite
- cd AirVPN-Suite
+ cd "$_pkgname"
+ mkdir obj
+ cp /usr/share/wireguard-tools/examples/embeddable-wg-library/wireguard.? src/
+ cp /usr/share/wireguard-tools/examples/embeddable-wg-library/wireguard.h src/include/
./build-bluetit.sh
./build-goldcrest.sh
./build-hummingbird.sh
@@ -63,5 +66,5 @@ package() {
install -Dm644 -t "$pkgdir/etc/dbus-1/system.d/" "$_pkgname"/etc/dbus-1/system.d/*
# place Systemd service
- install -Dm644 "$_pkgname/etc/systemd/system/bluetit.service" "$pkgdir/etc/systemd/system/bluetit.service"
+ install -Dm644 "$_pkgname/etc/systemd/system/bluetit.service" "$pkgdir/usr/lib/systemd/system/bluetit.service"
}