summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOpenSorcerer2023-06-11 11:59:06 +0200
committerOpenSorcerer2023-06-11 11:59:06 +0200
commit462aa9d0b3060d49eeaea77dd8797867eba4a36c (patch)
tree71e35b314adb599ac5873abbb5571bc51006db6b
parentd0385cd161f6639574993b048afc1c99566366fd (diff)
downloadaur-462aa9d0b3060d49eeaea77dd8797867eba4a36c.tar.gz
pkgver++, depends: +glibc +gcc-libs, -curl, makedepends: +curl, new url
-rw-r--r--.SRCINFO13
-rw-r--r--Changelog-Suite.txt120
-rw-r--r--PKGBUILD8
3 files changed, 132 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d6e5bbddb301..d31894f456c5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,20 @@
pkgbase = airvpn-suite-bin
pkgdesc = AirVPN client software collection including Bluetit, Goldcrest and Hummingbird – prebuilt stable
- pkgver = 1.2.1
+ pkgver = 1.3.0
pkgrel = 1
- url = https://gitlab.com/AirVPN/AirVPN-Suite
+ url = https://airvpn.org/linux/suite
install = airvpn-suite-bin.install
changelog = Changelog-Suite.txt
arch = x86_64
arch = armv7l
arch = aarch64
license = GPL3
+ makedepends = curl
+ depends = glibc
+ depends = gcc-libs
depends = dbus
+ depends = openssl
depends = libxml2
- depends = curl
provides = hummingbird
provides = hummingbird-bin
provides = airvpn-suite
@@ -20,7 +23,7 @@ pkgbase = airvpn-suite-bin
conflicts = hummingbird-bin
conflicts = airvpn-suite
conflicts = airvpn-suite-beta-bin
- source = https://eddie.website/repository/AirVPN-Suite/1.2.1/AirVPN-Suite-x86_64-1.2.1.tar.gz
- sha512sums = be3f89fe87aabb4bdf77dd1744fc865c7d2faedb0bfbcaf1d4af9215159eeb62b136c4bfeb74b1a940febe2dfbed985df508ee580babc090e671a58a48f84e93
+ source = https://eddie.website/repository/AirVPN-Suite/1.3.0/AirVPN-Suite-x86_64-1.3.0.tar.gz
+ sha512sums = 2e95f97be1dd3e279c97510a7ee39d7734030d1d20aca77187d6470c0a057ffedc91d75dc341931ba551818d526a88d342065758a25c6d9dc3ea15e84ba4aa79
pkgname = airvpn-suite-bin
diff --git a/Changelog-Suite.txt b/Changelog-Suite.txt
index 2f354f4a45d8..3134157bba50 100644
--- a/Changelog-Suite.txt
+++ b/Changelog-Suite.txt
@@ -1,5 +1,125 @@
Changelog for AirVPN Suite
+Version 1.3.0 - 1 June 2023
+
+- [ProMIND] updated to OpenVPN3 AirVPN 3.8.4
+- [ProMIND] replaced include guards with #pragma once in all include files
+- [ProMIND] added file continent_names.csv
+- [ProMIND] installation script: improved group management for specific system cases
+
+
+airvpnmanifest
+
+- [ProMIND] updated to AirVPN document version 288
+- [ProMIND] loadManifest() can now force the loading of the local instance (if any)
+- [ProMIND] loadManifest() statistics are now counted for continent and earth as well
+- [ProMIND] loadManifest() added support for new AirVPNServer class members compliance
+- [ProMIND] processXmlManifest() countryStats now includes closed servers as well
+- [ProMIND] getServerListByCountry() now accepts continents as well
+
+
+airvpnserver
+
+- [ProMIND] renamed specific OpenVPN members
+- [ProMIND] added members for WireGuard support
+- [ProMIND] added members for Perfect Forward Secrecy (PFS) support
+- [ProMIND] members supportIPv4 renamed to IPv4Available
+- [ProMIND] members supportIPv6 renamed to IPv6Available
+
+
+airvpnserverprovider
+
+- [ProMIND] members supportIPv4 renamed to IPv4Available
+- [ProMIND] members supportIPv6 renamed to IPv6Available
+
+
+airvpntools
+
+- [ProMIND] updated to AirVPN document version 288
+- [ProMIND] added int AirVpnDocumentVersion
+- [ProMIND] added std::string wireguardPublicKey
+- [ProMIND] added method getAirVpnDocumentVersion()
+- [ProMIND] requestAirVPNDocument(): in case document version is not set by caller, it is then set to the default value
+- [ProMIND] added methods getWireGuardPublicKey() and setWireGuardPublicKey()
+- [ProMIND] added method getWireGuardProfile()
+- [ProMIND] added method realCountryName(): return the normalized country/continent name
+- [ProMIND] added method loadLinuxModule()
+- [ProMIND] added method replaceAll()
+- [ProMIND] added method formatTimestamp()
+- [ProMIND] added methods getVPNConfigFileType() and getVPNProfileType()
+- [ProMIND] added unit of measure mode to formatTransferRate() and formatDataVolume() methods (defaults to decimal mode)
+
+
+airvpnuser
+
+- [ProMIND] updated to AirVPN document version 288
+- [ProMIND] added WireGuard members to struct UserKey
+- [ProMIND] added method getWireGuardProfile()
+- [ProMIND] getOpenVPNProfile(): replaced "cipher" with "data-ciphers"
+- [ProMIND] getOpenVPNProfile(): removed "comp-lzo" support
+
+
+countrycontinent
+
+- [ProMIND] added method isContinent()
+- [ProMIND] added method getContinentCode()
+- [ProMIND] added method getContinentName()
+
+
+dbusconnector
+
+- [ProMIND] mutex lock operations are now depending on timeout
+
+
+loadmod
+
+- [ProMIND] added MODULE_IS_EMBEDDED, MODULE_DEP_FILE_NOT_FOUND and MODULE_BUILTIN_FILE_NOT_FOUND macros
+- [ProMIND] load_kernel_module(): added check to modules.builtin
+
+
+localnetwork
+
+- [ProMIND] added struct IPAddress and enum IPFamily
+- [ProMIND] removed local struct IPEntry (superseeded by IPAddress and IPFamily)
+- [ProMIND] added method parseIpSpecification()
+
+
+netfilter
+
+- [ProMIND] removed method loadLinuxModule() (moved to airvpntools)
+- [ProMIND] enum Direction replaced by enum Hook
+- [ProMIND] Replaced enum IP with LocalNetwork's enum IPFamily
+- [ProMIND] extensive and complete re-engineering and revision in order to allow a full and dynamic management of rules (notably nftables)
+
+
+openvpnclient
+
+- [ProMIND] added method profileNeedsResolution()
+- [ProMIND] added method resolveProfile()
+- [ProMIND] system DNS operations are now handled by methods saveSystemDNS(), allowSystemDNS() and rejectSystemDNS()
+- [ProMIND] bypass routes are now added at connection establishment in order to allow "redirect-gateway" ignore to work properly
+- [ProMIND] onAssignIpEvent(): add local gateway to netFilter in case gateway has not been redirected (pull-filter ignore "redirect-gateway")
+- [ProMIND] print_stats(): stats are now shown only in case of connection to VPN server
+- [ProMIND] removed references to LocalNetwork::IPEntry and replaced with IPAddress and IPFamily
+- [ProMIND] implemented and overridden all virtual tun_builder_* methods
+- [ProMIND] tun_builder_set_mtu(): now correctly sets MTU according to tun-mtu directive
+- [ProMIND] Replaced struct IPClass with LocalNetwork's enum IPFamily
+- [ProMIND] onResolveEvent(): proxy is now properly added to the network filter
+
+
+vpnclient
+
+- [ProMIND] refactored and renamed to openvpnclient
+
+
+wireguardclient
+
+- [ProMIND] new class
+
+
+*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*
+
+
Version 1.2.1 - 9 December 2022
- [ProMIND] production release
diff --git a/PKGBUILD b/PKGBUILD
index 3b8999ffc37d..4c177198f971 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
# Maintainer: OpenSorcerer <alex at opensourcery dot eu>
pkgname=airvpn-suite-bin
_pkgname=AirVPN-Suite
-pkgver=1.2.1
-_pkgver=1.2
+pkgver=1.3.0
pkgrel=1
pkgdesc="AirVPN client software collection including Bluetit, Goldcrest and Hummingbird – prebuilt stable"
arch=('x86_64' 'armv7l' 'aarch64')
-url="https://gitlab.com/AirVPN/$_pkgname"
+url="https://airvpn.org/linux/suite"
license=('GPL3')
provides=('hummingbird' 'hummingbird-bin' 'airvpn-suite' 'airvpn-suite-beta-bin')
conflicts=('hummingbird' 'hummingbird-bin' 'airvpn-suite' 'airvpn-suite-beta-bin')
-depends=('dbus' 'libxml2' 'curl')
+depends=('glibc' 'gcc-libs' 'dbus' 'openssl' 'libxml2')
+makedepends=('curl')
source=("https://eddie.website/repository/$_pkgname/$pkgver/$_pkgname-$arch-$pkgver.tar.gz")
sha512sums=(`curl -sLo - "https://eddie.website/repository/$_pkgname/$pkgver/$_pkgname-$arch-$pkgver.tar.gz.sha512"|cut -f1 -d " "`)
install="$pkgname.install"