summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKatie Wolfe2020-07-10 12:12:07 -0400
committerKatie Wolfe2020-07-10 12:12:07 -0400
commit85f2aab08f54434a8e12246625a2b0507963e31f (patch)
treee1de19be13e03ac44e03f22bd88c45e6740cba18
downloadaur-akaitools.tar.gz
Initial commit (1.4)
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..416ce9bbcf6a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = akaitools
+ pkgdesc = Tools for Akai S-series samplers
+ pkgver = 1.4
+ pkgrel = 1
+ url = http://www.lsnl.jp/~ohsaki/software/akaitools/
+ arch = any
+ license = GPL2
+ makedepends = make
+ depends = perl
+ optdepends = sox: support for more file formats
+ provides = akaitools
+ source = http://www.lsnl.jp/~ohsaki/software/akaitools/akaitools-1.4.tar.gz
+ sha512sums = 89c625168476ffebfb13f7219769ce6c27a75044a53508cc7e3f8e8c3f6802adea254e46266e590d56d6688cd5bc5e34873ac5e3ae747927d46002866256baa1
+
+pkgname = akaitools
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d76ae47fcc9f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Katie Wolfe <wolfe@katie.host>
+pkgname=akaitools
+pkgver=1.4
+pkgrel=1
+pkgdesc='Tools for Akai S-series samplers'
+arch=('any')
+url='http://www.lsnl.jp/~ohsaki/software/akaitools/'
+license=('GPL2')
+groups=()
+depends=('perl')
+makedepends=('make')
+optdepends=('sox: support for more file formats')
+provides=('akaitools')
+source=("http://www.lsnl.jp/~ohsaki/software/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+sha512sums=('89c625168476ffebfb13f7219769ce6c27a75044a53508cc7e3f8e8c3f6802adea254e46266e590d56d6688cd5bc5e34873ac5e3ae747927d46002866256baa1')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ perl Makefile.PL
+ make
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}/" install
+}