summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorthorondir2020-08-15 23:44:02 +0930
committerthorondir2020-08-15 23:44:02 +0930
commitf6fbd7b465492db5715befa7cb3e3525a28d81ff (patch)
tree2c4e7b8dc1c2981f1d7e72af920685e31351ccbd
downloadaur-alass-git.tar.gz
Created alass PKGBUILD
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD31
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b820f1551a3d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = alass-git
+ pkgdesc = Command line tool to synchronize subtitles
+ pkgver = 2.0.0.r2
+ pkgrel = 1
+ url = https://github.com/kaegi/alass
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = cargo
+ depends = ffmpeg
+ provides = alass
+ conflicts = alass
+ source = git+https://github.com/kaegi/alass
+ sha256sums = SKIP
+
+pkgname = alass-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5ac1a5314d03
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Ying Stokes <yingstokes@gmail.com>
+
+pkgname=alass-git
+_gitname=alass
+pkgver=2.0.0.r2
+pkgrel=1
+pkgdesc="Command line tool to synchronize subtitles"
+arch=('x86_64')
+url="https://github.com/kaegi/alass"
+license=('GPL3')
+depends=('ffmpeg')
+makedepends=('git' 'cargo')
+provides=('alass')
+conflicts=('alass')
+source=("git+https://github.com/kaegi/alass")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ git describe --long --tag | sed -r 's/-([0-9,a-g,A-G]{7}.*)//' | sed 's/^v//;s/-/.r/'
+}
+
+build() {
+ cd "$srcdir/$_gitname"
+ cargo build --release
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ install -Dm 755 target/release/alass-cli "${pkgdir}/usr/bin/alass"
+}