summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbegin-theadventure2024-01-05 02:53:45 +0100
committerbegin-theadventure2024-01-05 02:53:45 +0100
commitbf91794b0ea68ed49af7cb144313175de1f01a73 (patch)
tree78dcd82c1eba832c371cf557ff3f1f6da9ead5af
parent2d45e4745e4b8c13226210a823ced4152b694a08 (diff)
downloadaur-alfae.tar.gz
Use echo instead of sed, clean up
-rw-r--r--PKGBUILD24
1 files changed, 12 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9931b95daa2f..4abc5e9cac23 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,16 +14,16 @@ source=("git+$url.git#tag=$pkgver")
sha256sums=('SKIP')
prepare() {
- # Create a shortcut
- echo "Categories=Game;" >> desktop
- sed -i '1 i\Comment=An Itch.io/Epic Games/GOG launcher that works through plugins' desktop
- sed -i '1 i\StartupWMClass=Alfae' desktop
- sed -i '1 i\Icon=alfae' desktop
- sed -i '1 i\Type=Application' desktop
- sed -i '1 i\Terminal=false' desktop
- sed -i '1 i\Exec=/opt/Alfae/Alfae %U' desktop
- sed -i '1 i\Name=Alfae' desktop
- sed -i '1 i\[Desktop Entry]' desktop
+# Create a shortcut
+ echo -e "[Desktop Entry]\n\
+Name=Alfae\n\
+Exec=/opt/Alfae/Alfae %U\n\
+Terminal=false\n\
+Type=Application\n\
+Icon=alfae\n\
+StartupWMClass=Alfae\n\
+Comment=An Itch.io/Epic Games/GOG launcher that works through plugins\n\
+Categories=Game;" > desktop
mv desktop alfae.desktop
}
@@ -66,9 +66,9 @@ build() {
}
package() {
- # Create folders
+# Create directories
mkdir -p "$pkgdir/opt/Alfae" "$pkgdir/usr/bin"
- # Install
+# Install
mv Alfae/Release/* "$pkgdir/opt/Alfae"
ln -s /opt/Alfae/Alfae "$pkgdir/usr/bin/alfae"
install -Dm644 Alfae/Launcher/Assets/icon.png "$pkgdir/usr/share/icons/hicolor/512x512/apps/alfae.png"