summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-02-01 07:19:36 +0800
committerzxp198210052024-02-01 07:19:36 +0800
commitdf296dbfc94594e4a207478e42c76c69bd9d87b8 (patch)
tree8506d852a6ab228f5186b17105f93deffd72443d
parent338b20c38935a5c3035d5c93f15f0c02cf860954 (diff)
downloadaur-alibabasans-jp-fonts.tar.gz
fix errors
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dc9fa5f1af3a..208bc85fe03f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = alibabasans-jp-fonts
pkgdesc = A typeface for creating alibaba sans jp in text.阿里巴巴普惠体日文,3字重
pkgver = 1.0
- pkgrel = 3
+ pkgrel = 4
url = https://fonts.alibabagroup.com/#/font
arch = any
- license = custom
+ license = LicenseRef-custom
source = alibabasans-jp-fonts-1.0.zip::https://puhuiti.oss-cn-hangzhou.aliyuncs.com/AlibabaSansJP.zip
source = license.txt
sha256sums = 6085bb7bc272bb975cd98e25e1077d2b1c047c31279af367e53892ec63020d2d
diff --git a/PKGBUILD b/PKGBUILD
index 68290dbfd8dd..2ddc7f85e4db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,25 @@
# PKGBUILD inspiration from fira-code
pkgbase=alibabasans-jp-fonts
pkgname=({eot,otf,ttf,woff,woff2}-"${pkgbase}")
+_fontname=AlibabaSansJP
pkgver=1.0
-pkgrel=3
+pkgrel=4
pkgdesc="A typeface for creating alibaba sans jp in text.阿里巴巴普惠体日文,3字重"
arch=("any")
url='https://fonts.alibabagroup.com/#/font'
-license=('custom')
-source=("${pkgbase}-${pkgver}.zip::https://puhuiti.oss-cn-hangzhou.aliyuncs.com/AlibabaSansJP.zip"
- "license.txt")
+license=('LicenseRef-custom')
+source=(
+ "${pkgbase}-${pkgver}.zip::https://puhuiti.oss-cn-hangzhou.aliyuncs.com/${_fontname}.zip"
+ "license.txt"
+)
sha256sums=('6085bb7bc272bb975cd98e25e1077d2b1c047c31279af367e53892ec63020d2d'
'2588d7120fe60eab0cfe10c8929c93cdcb57e86644e47ad645f0cc1857b02fc4')
function _package {
local _pkgname=$1
local ext="${_pkgname%%-*}"
for weight in Bold Medium Regular;do
- cd "${srcdir}/AlibabaSansJP/AlibabaSansJP-${weight}"
- local fonts=("AlibabaSansJP-${weight}.${ext}")
+ cd "${srcdir}/${_fontname}/${_fontname}-${weight}"
+ local fonts=("${_fontname}-${weight}.${ext}")
local installdir="${ext^^}"
# Prepare destination directory
install -dm755 "${pkgdir}/usr/share/fonts/${installdir}"