summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-02-01 07:35:05 +0800
committerzxp198210052024-02-01 07:35:05 +0800
commit6c21fca7d25c38cd4df66e457c3dc849d7a007ca (patch)
tree2a76926f7463829ce88abaea523c7c4e5527debc
parentc4ec799846dfc23179d4bdc1f0f1328f84f52653 (diff)
downloadaur-alibabasans-viet-fonts.tar.gz
fix errors
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD16
2 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a701ead7ddbd..4ac5fb61b259 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = alibabasans-viet-fonts
pkgdesc = A typeface for creating alibaba sans viet in text.阿里巴巴普惠体越南文,3字重
pkgver = 1.0
- pkgrel = 3
+ pkgrel = 4
url = https://fonts.alibabagroup.com/#/font
arch = any
- license = custom
+ license = LicenseRef-custom
source = alibabasans-viet-fonts-1.0.zip::https://puhuiti.oss-cn-hangzhou.aliyuncs.com/AlibabaSansViet.zip
source = license.txt
sha256sums = 1cd7e0fdcc6f1400ae0d927c83031f4aec87280cdac54023c5f468f43c278d3a
diff --git a/PKGBUILD b/PKGBUILD
index 473686a5a5e7..d495b760770e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,25 @@
# PKGBUILD inspiration from fira-code
pkgbase=alibabasans-viet-fonts
pkgname=({eot,otf,ttf,woff,woff2}-"${pkgbase}")
-_zipname=AlibabaSansViet
+_fontname=AlibabaSansViet
pkgver=1.0
-pkgrel=3
+pkgrel=4
pkgdesc="A typeface for creating alibaba sans viet in text.阿里巴巴普惠体越南文,3字重"
arch=("any")
url="https://fonts.alibabagroup.com/#/font"
-license=("custom")
-source=("${pkgbase}-${pkgver}.zip::https://puhuiti.oss-cn-hangzhou.aliyuncs.com/${_zipname}.zip"
- "license.txt")
+license=("LicenseRef-custom")
+source=(
+ "${pkgbase}-${pkgver}.zip::https://puhuiti.oss-cn-hangzhou.aliyuncs.com/${_fontname}.zip"
+ "license.txt"
+)
sha256sums=('1cd7e0fdcc6f1400ae0d927c83031f4aec87280cdac54023c5f468f43c278d3a'
'2588d7120fe60eab0cfe10c8929c93cdcb57e86644e47ad645f0cc1857b02fc4')
function _package {
local _pkgname=$1
local ext="${_pkgname%%-*}"
for weight in Bd Md Rg;do
- cd "${srcdir}/${_zipname}/${_zipname}-${weight}"
- local fonts=("${_zipname}-${weight}.${ext}")
+ cd "${srcdir}/${_fontname}/${_fontname}-${weight}"
+ local fonts=("${_fontname}-${weight}.${ext}")
local installdir="${ext^^}"
# Prepare destination directory
install -dm755 "${pkgdir}/usr/share/fonts/${installdir}"