summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Lagnese2021-06-06 13:28:31 -0700
committerTim Lagnese2021-06-06 13:28:31 -0700
commit8e07e39ab271b978dddd1f05a8fd3a1b36c831c8 (patch)
tree61de1655fbf1ec42daa182d15ad5aebc963eff21
parent7de77fd3435d238f011e1401e9e9b57d8b738e1c (diff)
downloadaur-8e07e39ab271b978dddd1f05a8fd3a1b36c831c8.tar.gz
Fix dependencies and build with latest GCC
* Add patch to fix https://github.com/alire-project/alire/issues/729 * Add flag to suppress compilation info/warnings (Thanks charlie5)
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8185765c585f..4c1fd317b402 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,9 +8,10 @@ pkgbase = alire
license = GPL3
makedepends = git
makedepends = gprbuild
- depends = glibc
+ depends = gnatcoll-core
source = alire-1.0.0.tar.gz::https://github.com/alire-project/alire/archive/refs/tags/v1.0.0.tar.gz
source = alire.patch
+ source = https://github.com/alire-project/alire/commit/20efc54a47ddd62faeb483301c9cb28a968ca80e.patch
source = git+https://github.com/alire-project/xmlezout.git
source = git+https://github.com/mosteo/ajunitgen.git
source = git+https://github.com/mosteo/aaa.git
@@ -25,6 +26,7 @@ pkgbase = alire
source = git+https://github.com/Fabien-Chouteau/spdx_ada
b2sums = bad08a570d464d454739edb42717a5ad33eb132dea4c3f2752e26bf122aa6a6b058e1b89987a9c8a6c5d432492b29586fbefad0e54207f8e7a9601ef1bbba9a0
b2sums = 898ec902aab5e8d80b12c4b481224dfbc92a3acef049b0ca93db39b8303fefb172fb1e8d933f3dad936d4f3d7fa84c46c4119ad1f28d97cb2a11bf2f6c4681d3
+ b2sums = 46209f7048eaa291768c8609a7173b53b3482005837352dd16dcbfe83d55d9b0bff3ae683bbad8d893605944e86d7fa07b3feea81a9dbec064613e6e366cb6a7
b2sums = SKIP
b2sums = SKIP
b2sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index b62612a383ef..92497cae5492 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,10 +7,13 @@ pkgdesc="A catalog of ready-to-use Ada libraries plus a command-line tool (alr)
arch=('i686' 'x86_64')
url="https://alire.ada.dev/"
license=(GPL3)
-depends=(glibc)
+depends=(gnatcoll-core)
makedepends=(git gprbuild)
source=("$pkgname-$pkgver.tar.gz::https://github.com/alire-project/alire/archive/refs/tags/v$pkgver.tar.gz"
alire.patch
+# Include commit which fixes compilation error with FSF GCC 11.1.0
+# See https://github.com/alire-project/alire/issues/729 for more info
+https://github.com/alire-project/alire/commit/20efc54a47ddd62faeb483301c9cb28a968ca80e.patch
git+https://github.com/alire-project/xmlezout.git
git+https://github.com/mosteo/ajunitgen.git
git+https://github.com/mosteo/aaa.git
@@ -25,6 +28,7 @@ git+https://github.com/mosteo/minirest
git+https://github.com/Fabien-Chouteau/spdx_ada)
b2sums=('bad08a570d464d454739edb42717a5ad33eb132dea4c3f2752e26bf122aa6a6b058e1b89987a9c8a6c5d432492b29586fbefad0e54207f8e7a9601ef1bbba9a0'
'898ec902aab5e8d80b12c4b481224dfbc92a3acef049b0ca93db39b8303fefb172fb1e8d933f3dad936d4f3d7fa84c46c4119ad1f28d97cb2a11bf2f6c4681d3'
+ '46209f7048eaa291768c8609a7173b53b3482005837352dd16dcbfe83d55d9b0bff3ae683bbad8d893605944e86d7fa07b3feea81a9dbec064613e6e366cb6a7'
'SKIP'
'SKIP'
'SKIP'
@@ -43,11 +47,13 @@ prepare()
# Get the submodules from the sources above
cd "$srcdir/$pkgname-$pkgver"
git apply "$srcdir/alire.patch"
+ # Apply patch as workaround for https://github.com/alire-project/alire/issues/729
+ git apply "$srcdir/20efc54a47ddd62faeb483301c9cb28a968ca80e.patch"
}
build() {
cd "$srcdir/$pkgname-$pkgver"
- gprbuild -j0 -P alr_env
+ gprbuild -j0 -P alr_env -cargs -gnatws
}
package() {