summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Lagnese2021-03-24 23:15:40 -0700
committerTim Lagnese2021-03-24 23:16:43 -0700
commitfc4a42c3f5cee23e93338b2ac9c632a2c33692e0 (patch)
treebcee1c55982135d5e2d379da901b286e28bd3814
parentaf6b986677cd30e105e44f69cd4258d45a13ec2a (diff)
downloadaur-fc4a42c3f5cee23e93338b2ac9c632a2c33692e0.tar.gz
Fix SRCINFO and PKGBUILD for tarball
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f04528b0d768..ba648aa7b3a7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = alire
pkgdesc = A catalog of ready-to-use Ada libraries plus a command-line tool (alr) to obtain, build, and incorporate them into your own projects. It aims to fulfill a similar role to Rust's cargo or OCaml's opam.
pkgver = 1.0.0
- pkgrel = 1
+ pkgrel = 2
url = https://alire.ada.dev/
arch = i686
arch = x86_64
@@ -9,7 +9,7 @@ pkgbase = alire
makedepends = git
makedepends = gprbuild
depends = glibc
- source = https://github.com/alire-project/alire/archive/refs/tags/v1.0.0.tar.gz
+ source = alire-1.0.0.tar.gz::https://github.com/alire-project/alire/archive/refs/tags/v1.0.0.tar.gz
source = git+https://github.com/alire-project/xmlezout.git
source = git+https://github.com/mosteo/ajunitgen.git
source = git+https://github.com/mosteo/aaa.git
diff --git a/PKGBUILD b/PKGBUILD
index e6006f872e1d..70bb2239a02f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=alire
pkgver=1.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="A catalog of ready-to-use Ada libraries plus a command-line tool (alr) to obtain, build, and incorporate them into your own projects. It aims to fulfill a similar role to Rust's cargo or OCaml's opam."
arch=('i686' 'x86_64')
url="https://alire.ada.dev/"
@@ -57,12 +57,12 @@ prepare()
}
build() {
- cd "$srcdir/$pkgname"
+ cd "$srcdir/$pkgname-$pkgver"
gprbuild -j0 -P alr_env
}
package() {
- cd "$srcdir/$pkgname"
+ cd "$srcdir/$pkgname-$pkgver"
gprinstall -P alr_env -p --prefix="$pkgdir/usr"
}