summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Krzyszkowiak2020-06-21 05:53:23 +0200
committerSebastian Krzyszkowiak2020-06-21 05:53:23 +0200
commit48ab497b808343cd4442a0b33d327a7e062dbd93 (patch)
treeb39811fb2fc12d9b18e7f7e79e0f005ac09b838d
parent6a739515063e29d801544f54f3803142d8085b95 (diff)
downloadaur-allegro-sdl-git.tar.gz
update
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD27
2 files changed, 14 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0ac262fd43c0..c5ae2865f0cb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,21 @@
pkgbase = allegro-sdl-git
- pkgdesc = Portable library mainly aimed at video game and multimedia programming, built with SDL2 backend
- pkgver = r11496.c9d6a8236
+ pkgdesc = Portable library mainly aimed at video game and multimedia programming
+ pkgver = r11630.ce68911b4
pkgrel = 1
url = https://liballeg.org/
arch = x86_64
- license = ZLIB
+ license = custom
makedepends = cmake
- makedepends = git
makedepends = glu
makedepends = libtheora
makedepends = mesa-libgl
- makedepends = ninja
makedepends = opusfile
makedepends = pandoc
depends = dumb
- depends = gtk2
- depends = jack
depends = libgl
- depends = libpulse
depends = libtheora
depends = libwebp
depends = libxpm
- depends = libxxf86dga
depends = opusfile
depends = physfs
depends = sdl2
diff --git a/PKGBUILD b/PKGBUILD
index f57e80a2f9ac..1b4b9a2f7c84 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,16 +5,16 @@
# Contributor: arjan <arjan@archlinux.org>
pkgname=allegro-sdl-git
-pkgver=r11496.c9d6a8236
+pkgver=r11630.ce68911b4
pkgrel=1
-pkgdesc='Portable library mainly aimed at video game and multimedia programming, built with SDL2 backend'
+pkgdesc='Portable library mainly aimed at video game and multimedia programming'
arch=(x86_64)
url='https://liballeg.org/'
-license=('ZLIB')
+license=(custom)
+makedepends=(cmake glu libtheora mesa-libgl opusfile pandoc)
+depends=(dumb libgl libtheora libwebp libxpm opusfile physfs sdl2)
provides=("${pkgname%-sdl-git}")
conflicts=("${pkgname%-sdl-git}")
-makedepends=(cmake git glu libtheora mesa-libgl ninja opusfile pandoc)
-depends=(dumb gtk2 jack libgl libpulse libtheora libwebp libxpm libxxf86dga opusfile physfs sdl2)
source=("git+https://github.com/liballeg/allegro5.git")
md5sums=('SKIP')
@@ -26,23 +26,18 @@ pkgver() {
build() {
mkdir -p build
cd build
- cmake "../allegro5" \
- -DCMAKE_BUILD_TYPE=Release \
+ cmake ../allegro5 \
-DCMAKE_INSTALL_PREFIX=/usr \
-DALLEGRO_SDL=ON \
- -DWANT_DOCS_HTML=OFF \
- -G Ninja
- ninja
+ -DWANT_DOCS_HTML=OFF
+ make
}
package() {
- DESTDIR="$pkgdir" ninja -C build install
- install -Dm644 "allegro5/LICENSE.txt" \
- "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd build
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "$srcdir"/allegro5/LICENSE.txt -t "$pkgdir"/usr/share/licenses/allegro
# Fix man path
mv -v -f "$pkgdir/usr/man" "$pkgdir/usr/share/man"
}
-
-# getver: liballeg.org/a5docs/trunk
-# vim: ts=2 sw=2 et: