summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302023-04-17 19:36:56 +0200
committerM0Rf302023-04-17 19:36:56 +0200
commit78848ccb172775ca76b9f23458df04301d019f13 (patch)
treeb5999e75a503882a74d74dead00399acba553dc1
parent420a79728948ffd30bdc0acab77a2070f4aaf1fe (diff)
downloadaur-alpaca.cpp-git.tar.gz
alpaca.cpp-git: update
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f10e36085df4..6fe89dc018e1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = alpaca.cpp-git
pkgdesc = Locally run an Instruction-Tuned Chat-Style LLM
- pkgver = 81bd894.r3.6041736
+ pkgver = 81bd894.r4.a0c74a7
pkgrel = 1
url = https://github.com/antimatter15/alpaca.cpp
arch = armv7h
@@ -8,6 +8,9 @@ pkgbase = alpaca.cpp-git
arch = x86_64
license = MIT
makedepends = cmake
+ makedepends = git
+ depends = glibc
+ depends = gcc-libs
provides = alpaca.cpp
conflicts = alpaca.cpp
source = alpaca.cpp::git+https://github.com/antimatter15/alpaca.cpp
diff --git a/PKGBUILD b/PKGBUILD
index 74e7d5b1afb4..69768763fd4d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: robertfoster
pkgname=alpaca.cpp-git
-pkgver=81bd894.r3.6041736
+pkgver=81bd894.r4.a0c74a7
pkgrel=1
pkgdesc="Locally run an Instruction-Tuned Chat-Style LLM"
arch=('armv7h' 'aarch64' 'x86_64')
url="https://github.com/antimatter15/alpaca.cpp"
license=("MIT")
-depends=()
-makedepends=('cmake')
+depends=('glibc' 'gcc-libs')
+makedepends=('cmake' 'git')
conflicts=("${pkgname%-git}")
provides=("${pkgname%-git}")
source=("${pkgname%-git}::git+${url}")
@@ -35,9 +35,11 @@ package() {
cmake --install ./build
install -Dm755 "build/chat" \
- "${pkgdir}/usr/bin/${pkgname%-git}-chat"
+ "${pkgdir}/usr/bin/${pkgname%-git}-chat"
install -Dm755 "build/quantize" \
- "${pkgdir}/usr/bin/${pkgname%-git}-quantize"
+ "${pkgdir}/usr/bin/${pkgname%-git}-quantize"
+ install -Dm644 LICENSE \
+ -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
sha256sums=('SKIP')