summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornick2023-01-10 16:27:33 +0100
committernick2023-01-10 16:27:33 +0100
commit1e817c3ad515b048e738ca89adb9abcbd8693093 (patch)
tree4d42c2364cca5e4a571010565881f3651187a2ad
downloadaur-alpine-chroot-install.tar.gz
Alpine Linux in chroot
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore13
-rw-r--r--PKGBUILD20
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e3581dd2ba89
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = alpine-chroot-install
+ pkgdesc = Install Alpine Linux in chroot with a breeze
+ pkgver = 0.14.0
+ pkgrel = 1
+ url = https://github.com/alpinelinux/alpine-chroot-install
+ arch = any
+ license = GPL2
+ depends = coreutils
+ depends = sh
+ optdepends = qemu-user: for emulation of different architecture
+ optdepends = qemu-user-binfmt-provider: for emulation of different architecture
+ source = https://raw.githubusercontent.com/alpinelinux/alpine-chroot-install/v0.14.0/alpine-chroot-install
+ sha1sums = ccbf65f85cdc351851f8ad025bb3e65bae4d5b06
+
+pkgname = alpine-chroot-install
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1e2b0c0734b7
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,13 @@
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f9ee48fa28d9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: noobping <hello@noobping.dev>
+
+pkgname=alpine-chroot-install
+pkgver=0.14.0
+pkgrel=1
+pkgdesc="Install Alpine Linux in chroot with a breeze"
+arch=(any)
+url="https://github.com/alpinelinux/${pkgname}"
+license=('GPL2')
+depends=('coreutils' 'sh')
+optdepends=(
+ 'qemu-user: for emulation of different architecture'
+ 'qemu-user-binfmt-provider: for emulation of different architecture'
+)
+source=("https://raw.githubusercontent.com/alpinelinux/${pkgname}/v${pkgver}/${pkgname}")
+sha1sums=('ccbf65f85cdc351851f8ad025bb3e65bae4d5b06')
+
+package() {
+ install -Dm755 ${srcdir}/${pkgname} -t ${pkgdir}/usr/bin
+}