summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-04-03 09:20:27 +0800
committerzxp198210052024-04-03 09:20:27 +0800
commitba3be48b189f62b40e11263433651a0a6230c235 (patch)
tree77340d8b65596c28adde538edbea3ec7e4e8d6e9
parentb06da5f7da879b00c08e7249c49bee9bb5f638cc (diff)
downloadaur-altus.tar.gz
update to 5.1.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0c1e8d0aa445..a041a4be02ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = altus
pkgdesc = Desktop client for WhatsApp Web with themes, notifications and multiple account support
- pkgver = 5.0.2
- pkgrel = 2
+ pkgver = 5.1.0
+ pkgrel = 1
url = https://github.com/amanharwara/altus
arch = any
license = GPL-3.0-only
@@ -15,9 +15,9 @@ pkgbase = altus
conflicts = altus
options = !strip
options = !emptydirs
- source = altus.git::git+https://github.com/amanharwara/altus.git#tag=5.0.2
+ source = altus.git::git+https://github.com/amanharwara/altus.git#tag=5.1.0
source = altus.sh
- sha256sums = 95996d80a775cdbf56f5b0c44d0c17da6053ecf3d47fd17229b54d1d18d02aa3
+ sha256sums = 82e16a99adc9deec44a03b130c36577915bc603d7460a37575438d556b659f57
sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
pkgname = altus
diff --git a/PKGBUILD b/PKGBUILD
index 30cbbe31cd83..99dc81d03bae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=altus
_pkgname=Altus
-pkgver=5.0.2
+pkgver=5.1.0
_electronversion=28
_nodeversion=18
-pkgrel=2
+pkgrel=1
pkgdesc="Desktop client for WhatsApp Web with themes, notifications and multiple account support"
arch=('any')
url="https://github.com/amanharwara/altus"
@@ -29,7 +29,7 @@ source=(
"${pkgname}.git::git+${url}.git#tag=${pkgver}"
"${pkgname}.sh"
)
-sha256sums=('95996d80a775cdbf56f5b0c44d0c17da6053ecf3d47fd17229b54d1d18d02aa3'
+sha256sums=('82e16a99adc9deec44a03b130c36577915bc603d7460a37575438d556b659f57'
'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
_ensure_local_nvm() {
export NVM_DIR="${srcdir}/.nvm"
@@ -41,7 +41,7 @@ build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname}|g" \
-e "s|@runname@|app|g" \
- -e "s|@options@||g" \
+ -e "s|@options@|env ELECTRON_OZONE_PLATFORM_HINT=auto|g" \
-i "${srcdir}/${pkgname}.sh"
_ensure_local_nvm
gendesk -q -f -n --categories="Network" --name="${_pkgname}" --exec="${pkgname} %U"
@@ -56,9 +56,9 @@ build() {
mkdir -p "${srcdir}/.electron-gyp"
touch "${srcdir}/.electron-gyp/.yarnrc"
if [ `curl -s ipinfo.io/country | grep CN | wc -l ` -ge 1 ];then
- echo 'registry="https://registry.npmmirror.com/"' >> .npmrc
- echo 'electron_mirror="https://registry.npmmirror.com/-/binary/electron/"' >> .npmrc
- echo 'electron_builder_binaries_mirror="https://registry.npmmirror.com/-/binary/electron-builder-binaries/"' >> .npmrc
+ export npm_config_registry=https://registry.npmmirror.com
+ export npm_config_electron_mirror=https://registry.npmmirror.com/-/binary/electron/
+ export npm_config_electron_builder_binaries_mirror=https://registry.npmmirror.com/-/binary/electron-builder-binaries/
else
echo "Your network is OK."
fi