summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoredward-p2019-09-23 19:16:41 +0800
committeredward-p2019-09-23 19:16:41 +0800
commit1c529147f3fc7250410f139be4e458a486dea7c7 (patch)
tree3289d50ad17f611ae33001f293c58ba1fba57c67
parentdc62484eb8aa5e983b70cecf5936ac4c44c34e41 (diff)
downloadaur-1c529147f3fc7250410f139be4e458a486dea7c7.tar.gz
using kernel_tag && bump version (5 represents 5.x)
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD22
2 files changed, 27 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 25f24bf3816a..f77faf13697b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = alx-wol-dkms
pkgdesc = The alx kernel module with a patch enabling WoL applied
- pkgver = 4
+ pkgver = 5
pkgrel = 1
arch = i686
arch = x86_64
@@ -10,21 +10,21 @@ pkgbase = alx-wol-dkms
optdepends = linux-headers: Needed for build the module for Arch kernel
optdepends = linux-lts-headers: Needed for build the module for LTS Arch kernel
optdepends = linux-zen-headers: Needed for build the module for ZEN Arch kernel
- source = https://git.archlinux.org/linux.git/plain/drivers/net/ethernet/atheros/alx/alx.h
- source = https://git.archlinux.org/linux.git/plain/drivers/net/ethernet/atheros/alx/ethtool.c
- source = https://git.archlinux.org/linux.git/plain/drivers/net/ethernet/atheros/alx/hw.c
- source = https://git.archlinux.org/linux.git/plain/drivers/net/ethernet/atheros/alx/hw.h
- source = https://git.archlinux.org/linux.git/plain/drivers/net/ethernet/atheros/alx/main.c
- source = https://git.archlinux.org/linux.git/plain/drivers/net/ethernet/atheros/alx/reg.h
+ source = alx.h::https://git.archlinux.org/linux.git/plain/drivers/net/ethernet/atheros/alx/alx.h?h=v5.3.1-arch1
+ source = ethtool.c::https://git.archlinux.org/linux.git/plain/drivers/net/ethernet/atheros/alx/ethtool.c?h=v5.3.1-arch1
+ source = hw.c::https://git.archlinux.org/linux.git/plain/drivers/net/ethernet/atheros/alx/hw.c?h=v5.3.1-arch1
+ source = hw.h::https://git.archlinux.org/linux.git/plain/drivers/net/ethernet/atheros/alx/hw.h?h=v5.3.1-arch1
+ source = main.c::https://git.archlinux.org/linux.git/plain/drivers/net/ethernet/atheros/alx/main.c?h=v5.3.1-arch1
+ source = reg.h::https://git.archlinux.org/linux.git/plain/drivers/net/ethernet/atheros/alx/reg.h?h=v5.3.1-arch1
source = 000-enable-alx-wol.patch
source = Kbuild
source = dkms.conf
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
+ sha256sums = 0d39a982d018b70b112e82207a90cc9daf2c177e53644fdab2ee2aacb52ef394
+ sha256sums = 9980a7719f34ed8b1120891196a97afba515f9a6cb9c9646d0a2cdb7a3e89708
+ sha256sums = bf9ac0fa98031523e05d5d62c08ee116fd4a437f66538c95eac18adda10ff89b
+ sha256sums = fcc0306b37382cf8e2f75eafb6bd8696a4a5e360110e5cfe800485f4eebe55aa
+ sha256sums = 036e151038cbe583cf8043caad0c38dcb60b37d67b34526bc3c86944b3145e24
+ sha256sums = 88a23ab8e6fe814efe81910bd8806f5988d367a628458154edaebdf4ccbe4902
sha256sums = 3d0549a45f78595bfdcd9d6e14f115ecc159583a39d51b23aa3c9852630823d0
sha256sums = 8a62bb5adf6e554f470f88f8da58da0ce05cb8276ab56fb45ed5d31c71665d39
sha256sums = f3aefc85fd246a74ee2be831c15b6440d22c497e84fba1f57e152c82f2946d1a
diff --git a/PKGBUILD b/PKGBUILD
index 450511311f10..2cbecb8b8e76 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,9 @@
# Contributor: Kurobac <kurobac(at)foxmail(dot)com>
_pkgbase=alx-wol
+_kernel_tag=5.3.1-arch1
pkgname=${_pkgbase}-dkms
-pkgver=4
+pkgver=5
pkgrel=1
pkgdesc="The alx kernel module with a patch enabling WoL applied"
license=("GPL")
@@ -12,16 +13,21 @@ depends=('glibc' 'dkms')
optdepends=('linux-headers: Needed for build the module for Arch kernel'
'linux-lts-headers: Needed for build the module for LTS Arch kernel'
'linux-zen-headers: Needed for build the module for ZEN Arch kernel')
-source=(https://git.archlinux.org/linux.git/plain/drivers/net/ethernet/atheros/alx/{alx.h,ethtool.c,hw.c,hw.h,main.c,reg.h}
+source=("alx.h::https://git.archlinux.org/linux.git/plain/drivers/net/ethernet/atheros/alx/alx.h?h=v${_kernel_tag}"
+ "ethtool.c::https://git.archlinux.org/linux.git/plain/drivers/net/ethernet/atheros/alx/ethtool.c?h=v${_kernel_tag}"
+ "hw.c::https://git.archlinux.org/linux.git/plain/drivers/net/ethernet/atheros/alx/hw.c?h=v${_kernel_tag}"
+ "hw.h::https://git.archlinux.org/linux.git/plain/drivers/net/ethernet/atheros/alx/hw.h?h=v${_kernel_tag}"
+ "main.c::https://git.archlinux.org/linux.git/plain/drivers/net/ethernet/atheros/alx/main.c?h=v${_kernel_tag}"
+ "reg.h::https://git.archlinux.org/linux.git/plain/drivers/net/ethernet/atheros/alx/reg.h?h=v${_kernel_tag}"
000-enable-alx-wol.patch
Kbuild
dkms.conf)
-sha256sums=('SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
+sha256sums=('0d39a982d018b70b112e82207a90cc9daf2c177e53644fdab2ee2aacb52ef394'
+ '9980a7719f34ed8b1120891196a97afba515f9a6cb9c9646d0a2cdb7a3e89708'
+ 'bf9ac0fa98031523e05d5d62c08ee116fd4a437f66538c95eac18adda10ff89b'
+ 'fcc0306b37382cf8e2f75eafb6bd8696a4a5e360110e5cfe800485f4eebe55aa'
+ '036e151038cbe583cf8043caad0c38dcb60b37d67b34526bc3c86944b3145e24'
+ '88a23ab8e6fe814efe81910bd8806f5988d367a628458154edaebdf4ccbe4902'
'3d0549a45f78595bfdcd9d6e14f115ecc159583a39d51b23aa3c9852630823d0'
'8a62bb5adf6e554f470f88f8da58da0ce05cb8276ab56fb45ed5d31c71665d39'
'f3aefc85fd246a74ee2be831c15b6440d22c497e84fba1f57e152c82f2946d1a')