summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorangelsl2017-12-26 13:15:16 +0800
committerangelsl2017-12-26 13:16:56 +0800
commita7c76b8dffc935ba35a096aa9e0b704ceeb37c0f (patch)
tree216b8d11eb5dcd335e17952e07e10642ec082f3e
downloadaur-a7c76b8dffc935ba35a096aa9e0b704ceeb37c0f.tar.gz
Initial commit
-rw-r--r--.SRCINFO33
-rw-r--r--Kbuild2
-rw-r--r--PKGBUILD28
-rw-r--r--dkms.conf5
4 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6da38b316e81
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+# Generated by mksrcinfo v8
+# Tue Dec 26 05:16:50 UTC 2017
+pkgbase = alx-wol-dkms
+ pkgdesc = The alx kernel module with a patch enabling WoL applied
+ pkgver = 1
+ pkgrel = 1
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = glibc
+ depends = dkms
+ optdepends = linux-headers: Needed for build the module for Arch kernel
+ optdepends = linux-lts-headers: Needed for build the module for LTS Arch kernel
+ optdepends = linux-zen-headers: Needed for build the module for ZEN Arch kernel
+ source = https://github.com/angelsl/linux/blob/alx-wol/drivers/net/ethernet/atheros/alx/alx.h
+ source = https://github.com/angelsl/linux/blob/alx-wol/drivers/net/ethernet/atheros/alx/ethtool.c
+ source = https://github.com/angelsl/linux/blob/alx-wol/drivers/net/ethernet/atheros/alx/hw.c
+ source = https://github.com/angelsl/linux/blob/alx-wol/drivers/net/ethernet/atheros/alx/hw.h
+ source = https://github.com/angelsl/linux/blob/alx-wol/drivers/net/ethernet/atheros/alx/main.c
+ source = https://github.com/angelsl/linux/blob/alx-wol/drivers/net/ethernet/atheros/alx/reg.h
+ source = Kbuild
+ source = dkms.conf
+ sha256sums = afcd186a4710868ba7206bfcebdee5a6adc48e4853a2f7595f4f7c3df0f345af
+ sha256sums = ddba0a3acd62fab181f4de3ffeb85accfcee50110f8aa4762bec6958f235cc0e
+ sha256sums = d775716e32c49ab17455067e1027e3039421444ba515d6e477b2aa3558e6932d
+ sha256sums = 339bb5b3ce4cc99d45740ff8af7afe3a935ee7a7e031027ae91f9e350da38b39
+ sha256sums = e82a3d467fc8ca44c8ca1e9ba0d8027bc5491c65569a68471fdf580eb82b624d
+ sha256sums = dfe82e1d26935071b582d5f287f98a4487ee6b7a2f470ee23a9e23b841ef3282
+ sha256sums = 8a62bb5adf6e554f470f88f8da58da0ce05cb8276ab56fb45ed5d31c71665d39
+ sha256sums = f3aefc85fd246a74ee2be831c15b6440d22c497e84fba1f57e152c82f2946d1a
+
+pkgname = alx-wol-dkms
+
diff --git a/Kbuild b/Kbuild
new file mode 100644
index 000000000000..48271ce9b30e
--- /dev/null
+++ b/Kbuild
@@ -0,0 +1,2 @@
+obj-m += alx.o
+alx-objs := main.o ethtool.o hw.o
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0eddaa95c391
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+_pkgbase=alx-wol
+pkgname=${_pkgbase}-dkms
+pkgver=1
+pkgrel=1
+pkgdesc="The alx kernel module with a patch enabling WoL applied"
+license=("GPL")
+arch=('i686' 'x86_64')
+depends=('glibc' 'dkms')
+optdepends=('linux-headers: Needed for build the module for Arch kernel'
+ 'linux-lts-headers: Needed for build the module for LTS Arch kernel'
+ 'linux-zen-headers: Needed for build the module for ZEN Arch kernel')
+source=(https://github.com/angelsl/linux/blob/alx-wol/drivers/net/ethernet/atheros/alx/{alx.h,ethtool.c,hw.c,hw.h,main.c,reg.h}
+ Kbuild
+ dkms.conf)
+sha256sums=('afcd186a4710868ba7206bfcebdee5a6adc48e4853a2f7595f4f7c3df0f345af'
+ 'ddba0a3acd62fab181f4de3ffeb85accfcee50110f8aa4762bec6958f235cc0e'
+ 'd775716e32c49ab17455067e1027e3039421444ba515d6e477b2aa3558e6932d'
+ '339bb5b3ce4cc99d45740ff8af7afe3a935ee7a7e031027ae91f9e350da38b39'
+ 'e82a3d467fc8ca44c8ca1e9ba0d8027bc5491c65569a68471fdf580eb82b624d'
+ 'dfe82e1d26935071b582d5f287f98a4487ee6b7a2f470ee23a9e23b841ef3282'
+ '8a62bb5adf6e554f470f88f8da58da0ce05cb8276ab56fb45ed5d31c71665d39'
+ 'f3aefc85fd246a74ee2be831c15b6440d22c497e84fba1f57e152c82f2946d1a')
+
+package() {
+ local dest="$pkgdir/usr/src/${_pkgbase}-$pkgver"
+ mkdir -p $dest
+ cp -a Kbuild dkms.conf alx.h ethtool.c hw.c hw.h main.c reg.h $dest
+}
diff --git a/dkms.conf b/dkms.conf
new file mode 100644
index 000000000000..9021222bdbc3
--- /dev/null
+++ b/dkms.conf
@@ -0,0 +1,5 @@
+PACKAGE_NAME="alx-wol"
+PACKAGE_VERSION=KERNEL_VERSION
+BUILT_MODULE_NAME[0]="alx"
+DEST_MODULE_LOCATION[0]="/updates"
+AUTOINSTALL="yes"