summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMiepee2022-08-30 11:49:09 +0200
committerMiepee2022-08-30 11:49:09 +0200
commit3122298d40c95b2f708c213703f9cb6008f7d6dc (patch)
tree5a379000fd170e9b3d629a2e8347cafcc5227183
parent7fe3dd89c08874c3268c4964d376372db3a04fb6 (diff)
downloadaur-am2rlauncher-git.tar.gz
Fix compilation error due to net6.0 bump
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD16
2 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e38a61266562..9ae330accc93 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = am2rlauncher-git
pkgdesc = Application for installing the latest Community Updates, APKs and Mods for AM2R.
- pkgver = 2.1.2.r5.200cc93
- pkgrel = 3
+ pkgver = 2.2.0.r115.dd0e691
+ pkgrel = 1
url = https://github.com/AM2R-Community-Developers/AM2RLauncher
arch = x86_64
license = GPL3
makedepends = git
- makedepends = dotnet-sdk>=5
- depends = dotnet-runtime>=5
+ makedepends = dotnet-sdk>=6
+ depends = dotnet-runtime>=6
depends = dotnet-host
depends = gtk3
depends = libappindicator-gtk3
diff --git a/PKGBUILD b/PKGBUILD
index 80591d94fb6a..f9feacb31921 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
-# Maintainer: Miepee <janbidler00 at tutanota dot com>
+# Maintainer: Miepee <janbidler00 at protonmail dot com>
pkgname=am2rlauncher-git
-pkgver=2.1.2.r5.200cc93
-pkgrel=3
+pkgver=2.2.0.r115.dd0e691
+pkgrel=1
pkgdesc="Application for installing the latest Community Updates, APKs and Mods for AM2R."
arch=(x86_64)
url="https://github.com/AM2R-Community-Developers/AM2RLauncher"
license=('GPL3')
-depends=('dotnet-runtime>=5' 'dotnet-host' 'gtk3' 'libappindicator-gtk3' 'webkit2gtk' 'openssl' 'icu' 'xdelta3' 'fuse2' 'lib32-libpulse' 'lib32-openal')
-makedepends=('git' 'dotnet-sdk>=5')
+depends=('dotnet-runtime>=6' 'dotnet-host' 'gtk3' 'libappindicator-gtk3' 'webkit2gtk' 'openssl' 'icu' 'xdelta3' 'fuse2' 'lib32-libpulse' 'lib32-openal')
+makedepends=('git' 'dotnet-sdk>=6')
optdepends=('jre-openjdk: Creating APKs')
conflicts=('am2rlauncher')
source=("git+$url")
@@ -17,7 +17,7 @@ options=(!strip)
pkgver() {
cd "AM2RLauncher"
- printf %s "$(git describe --tags --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g;s/^v//g')"
+ git describe --tags --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g;s/^v//g'
}
build() {
@@ -28,12 +28,12 @@ build() {
package() {
# remame file properly
- mv -f AM2RLauncher/AM2RLauncher/AM2RLauncher.Gtk/bin/release/net5.0/ubuntu.18.04-x64/publish/AM2RLauncher.Gtk AM2RLauncher/AM2RLauncher/AM2RLauncher.Gtk/bin/release/net5.0/ubuntu.18.04-x64/publish/AM2RLauncher
+ mv -f AM2RLauncher/AM2RLauncher/AM2RLauncher.Gtk/bin/release/net6.0/ubuntu.18.04-x64/publish/AM2RLauncher.Gtk AM2RLauncher/AM2RLauncher/AM2RLauncher.Gtk/bin/release/net6.0/ubuntu.18.04-x64/publish/AM2RLauncher
mkdir -p "$pkgdir/usr/bin/"
mkdir -p "$pkgdir/opt/am2rlauncher/"
- cp -Rf AM2RLauncher/AM2RLauncher/AM2RLauncher.Gtk/bin/release/net5.0/ubuntu.18.04-x64/publish/* "$pkgdir/opt/am2rlauncher/"
+ cp -Rf AM2RLauncher/AM2RLauncher/AM2RLauncher.Gtk/bin/release/net6.0/ubuntu.18.04-x64/publish/* "$pkgdir/opt/am2rlauncher/"
cp -f "AM2RLauncher/AM2RLauncher/AM2RLauncher.Gtk/icon64.ico" "$pkgdir/opt/am2rlauncher/AM2RLauncher.ico"
ln -sf "/opt/am2rlauncher/AM2RLauncher" "$pkgdir/usr/bin/AM2RLauncher"