summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIsmaël Bouya2015-11-25 10:23:23 +0100
committerIsmaël Bouya2015-11-25 10:23:23 +0100
commit5b4afb621e8dc46d3164b4d4166e787b57a38e22 (patch)
tree20b148620ade43a10a506c790514387c86470ab7
parent3264aaf169cca8a1278c6f5858122944d6c4f536 (diff)
downloadaur-5b4afb621e8dc46d3164b4d4166e787b57a38e22.tar.gz
Upgrade to Anaconda 2.3.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD16
-rw-r--r--conda_install.patch36
-rw-r--r--installer_sh_x86.patch22
-rw-r--r--installer_sh_x86_64.patch22
5 files changed, 50 insertions, 58 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b783149b6166..158372bd26df 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = anaconda
pkgdesc = Completely free enterprise-ready Python distribution for large-scale data processing, predictive analytics, and scientific computing.
- pkgver = 2.3.0
+ pkgver = 2.4.0
pkgrel = 1
url = https://store.continuum.io/cshop/anaconda/
arch = x86
@@ -9,14 +9,14 @@ pkgbase = anaconda
makedepends = patch
options = !strip
options = libtool
- source = https://3230d63b5fc54e62148e-c95ac804525aac4b6dba79b00b39d1d3.ssl.cf1.rackcdn.com/Anaconda3-2.3.0-Linux-x86_64.sh
+ source = https://3230d63b5fc54e62148e-c95ac804525aac4b6dba79b00b39d1d3.ssl.cf1.rackcdn.com/Anaconda3-2.4.0-Linux-x86_64.sh
source = installer_sh_x86.patch
source = installer_sh_x86_64.patch
source = conda_install.patch
- sha256sums = 3be5410b2d9db45882c7de07c554cf4f1034becc274ec9074b23fd37a5c87a6f
- sha256sums = 809d8bcb6a6ab8a51dd9fafa89a24dd29403162d708e03e2b939c0508ba14418
- sha256sums = 359243cca1dd5c325ffcafdb53d4971f04146c815d72eb7088d3bcff85fad404
- sha256sums = 9ccd29b053a1b8eba2840c3320a041fa5d869ef60e05e2f720272d5c916e2726
+ sha256sums = fb4e480059e991f2fa632b5a9bcdd284c7f0677814cd719c11d524453f96a40d
+ sha256sums = e5110519a6977fc0636fb94148d1b7bc070167cda3402d4a2cdecd7dbb4eca08
+ sha256sums = fe62ec395b9346f721a8ad7f73bb1c98cb8ce65de06e9aeef3be99c5e040364b
+ sha256sums = efc7f93d4c2ce50e70ca74169f4af62a40a8510bda8c7d0999f7256e61579654
pkgname = anaconda
diff --git a/PKGBUILD b/PKGBUILD
index 667b5e7d2429..0487feac2706 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor : Martin Wimpress <code@flexion.org>
pkgname=anaconda
-pkgver=2.3.0
+pkgver=2.4.0
pkgrel=1
pkgdesc="Completely free enterprise-ready Python distribution for large-scale data processing, predictive analytics, and scientific computing."
arch=('x86' 'x86_64')
@@ -14,17 +14,17 @@ source=("https://3230d63b5fc54e62148e-c95ac804525aac4b6dba79b00b39d1d3.ssl.cf1.r
"installer_sh_x86_64.patch"
"conda_install.patch")
options=(!strip libtool)
-sha256sums=('3be5410b2d9db45882c7de07c554cf4f1034becc274ec9074b23fd37a5c87a6f'
- '809d8bcb6a6ab8a51dd9fafa89a24dd29403162d708e03e2b939c0508ba14418'
- '359243cca1dd5c325ffcafdb53d4971f04146c815d72eb7088d3bcff85fad404'
- '9ccd29b053a1b8eba2840c3320a041fa5d869ef60e05e2f720272d5c916e2726')
-_pythonver='3.4.3-1'
-_condaver='3.14.1'
+sha256sums=('fb4e480059e991f2fa632b5a9bcdd284c7f0677814cd719c11d524453f96a40d'
+ 'e5110519a6977fc0636fb94148d1b7bc070167cda3402d4a2cdecd7dbb4eca08'
+ 'fe62ec395b9346f721a8ad7f73bb1c98cb8ce65de06e9aeef3be99c5e040364b'
+ 'efc7f93d4c2ce50e70ca74169f4af62a40a8510bda8c7d0999f7256e61579654')
+_pythonver='3.5.0-1'
+_condaver='3.18.3'
_pkgarch=`uname -m`
if [ "$CARCH" == "x86" ]; then
_pkgarch="x86"
- sha256sums[0]='4cc10d65c303191004ada2b6d75562c8ed84e42bf9871af06440dd956077b555'
+ sha256sums[0]='f6080c6493cefc603cfeb67aaf6c3c4c6b80a66788f03db48ffd3cfa52017c0a'
source[0]="https://3230d63b5fc54e62148e-c95ac804525aac4b6dba79b00b39d1d3.ssl.cf1.rackcdn.com/Anaconda3-${pkgver}-Linux-x86.sh"
fi
diff --git a/conda_install.patch b/conda_install.patch
index f8f9a73072bf..89a7bb992b2a 100644
--- a/conda_install.patch
+++ b/conda_install.patch
@@ -1,6 +1,6 @@
---- a/pkgs/conda-3.14.1-py34_0/lib/python3.4/site-packages/conda/install.py 2015-07-03 11:04:48.348322309 +0200
-+++ b/pkgs/conda-3.14.1-py34_0/lib/python3.4/site-packages/conda/install.py 2015-07-03 11:04:52.078277806 +0200
-@@ -251,21 +251,23 @@
+--- a/pkgs/conda-3.18.3-py35_0/lib/python3.5/site-packages/conda/install.py 2015-11-25 09:59:32.301105554 +0100
++++ b/pkgs/conda-3.18.3-py35_0/lib/python3.5/site-packages/conda/install.py 2015-11-25 10:17:19.506243545 +0100
+@@ -257,21 +257,23 @@
return res
def update_prefix(path, new_prefix, placeholder=prefix_placeholder,
@@ -28,7 +28,7 @@
else:
sys.exit("Invalid mode:" % mode)
-@@ -550,7 +552,7 @@
+@@ -586,7 +588,7 @@
def load_meta(prefix, dist):
return is_linked(prefix, dist)
@@ -37,16 +37,7 @@
'''
Set up a package in a specified (environment) prefix. We assume that
the package has been extracted (using extract() above).
-@@ -569,6 +571,8 @@
- # linking or unlinking some packages
- log.warn('Ignored: %s' % dist)
- return
-+ if instdir is None:
-+ instdir = prefix
-
- source_dir = join(pkgs_dir, dist)
- if not run_script(source_dir, dist, 'pre-link', prefix):
-@@ -614,7 +618,7 @@
+@@ -639,7 +641,7 @@
for f in sorted(has_prefix_files):
placeholder, mode = has_prefix_files[f]
try:
@@ -55,7 +46,7 @@
except PaddingError:
sys.exit("ERROR: placeholder '%s' too short in: %s\n" %
(placeholder, dist))
-@@ -749,6 +753,10 @@
+@@ -767,6 +769,10 @@
default=sys.prefix,
help="prefix (defaults to %default)")
@@ -66,7 +57,7 @@
p.add_option('--pkgs-dir',
action="store",
default=join(sys.prefix, 'pkgs'),
-@@ -778,9 +786,14 @@
+@@ -796,9 +802,14 @@
pkgs_dir = opts.pkgs_dir
prefix = opts.prefix
@@ -81,7 +72,7 @@
if opts.list:
pprint(sorted(linked(prefix)))
-@@ -795,14 +808,14 @@
+@@ -813,7 +824,7 @@
for dist in dists:
if opts.verbose or linktype == LINK_COPY:
print("linking: %s" % dist)
@@ -90,11 +81,12 @@
messages(prefix)
elif opts.extract:
- extract(pkgs_dir, dist)
-
- elif opts.link:
-- link(pkgs_dir, prefix, dist)
-+ link(pkgs_dir, prefix, dist, instdir=instdir)
+@@ -823,7 +834,7 @@
+ linktype = (LINK_HARD
+ if try_hard_link(pkgs_dir, prefix, dist) else
+ LINK_COPY)
+- link(pkgs_dir, prefix, dist, linktype)
++ link(pkgs_dir, prefix, dist, linktype, instdir=instdir)
elif opts.unlink:
unlink(prefix, dist)
diff --git a/installer_sh_x86.patch b/installer_sh_x86.patch
index 97b410da7baa..2661f7684426 100644
--- a/installer_sh_x86.patch
+++ b/installer_sh_x86.patch
@@ -1,32 +1,32 @@
---- a/Anaconda3-2.3.0-Linux-x86.sh 2015-07-03 10:58:15.083001201 +0200
-+++ b/Anaconda3-2.3.0-Linux-x86.sh 2015-07-03 10:59:12.242322446 +0200
+--- a/Anaconda3-2.4.0-Linux-x86.sh 2015-11-25 09:24:34.653797870 +0100
++++ b/Anaconda3-2.4.0-Linux-x86.sh 2015-11-25 09:51:24.299710869 +0100
@@ -73,9 +73,9 @@
fi
fi
# verify the size of the installer
--wc -c "$THIS_PATH" | grep 338272927 >/dev/null
-+wc -c "$THIS_PATH" | grep 338272934 >/dev/null
+-wc -c "$THIS_PATH" | grep 290842015 >/dev/null
++wc -c "$THIS_PATH" | grep 290842022 >/dev/null
if (( $? )); then
-- echo "ERROR: size of $THIS_FILE should be 338272927 bytes" >&2
-+ echo "ERROR: size of $THIS_FILE should be 338272934 bytes" >&2
+- echo "ERROR: size of $THIS_FILE should be 290842015 bytes" >&2
++ echo "ERROR: size of $THIS_FILE should be 290842022 bytes" >&2
exit 1
fi
-@@ -386,7 +386,7 @@
- extract_dist _cache-0.0-x0
+@@ -415,7 +415,7 @@
+ extract_dist _cache-0.0-py35_x0
mkdir $PREFIX/envs
-mkdir $HOME/.continuum 2>/dev/null
+#mkdir $HOME/.continuum 2>/dev/null
- PYTHON="$PREFIX/pkgs/python-3.4.3-1/bin/python -E"
+ PYTHON="$PREFIX/pkgs/python-3.5.0-1/bin/python -E"
$PYTHON -V
-@@ -396,7 +396,7 @@
+@@ -425,7 +425,7 @@
uname -a
exit 1
fi
-
+exit 0
echo "creating default environment..."
- CONDA_INSTALL="$PREFIX/pkgs/conda-3.14.1-py34_0/lib/python3.4/site-packages/conda/install.py"
+ CONDA_INSTALL="$PREFIX/pkgs/conda-3.18.3-py35_0/lib/python3.5/site-packages/conda/install.py"
$PYTHON $CONDA_INSTALL --prefix=$PREFIX --pkgs-dir=$PREFIX/pkgs --link-all || exit 1
diff --git a/installer_sh_x86_64.patch b/installer_sh_x86_64.patch
index 1e0676df65de..7a4a1db43882 100644
--- a/installer_sh_x86_64.patch
+++ b/installer_sh_x86_64.patch
@@ -1,32 +1,32 @@
---- a/Anaconda3-2.3.0-Linux-x86_64.sh 2015-07-03 10:44:50.662500605 +0200
-+++ b/Anaconda3-2.3.0-Linux-x86_64.sh 2015-07-03 10:47:37.900536717 +0200
+--- a/Anaconda3-2.4.0-Linux-x86_64.sh 2015-11-25 09:24:34.503799502 +0100
++++ b/Anaconda3-2.4.0-Linux-x86_64.sh 2015-11-25 09:52:22.885744680 +0100
@@ -70,9 +70,9 @@
fi
fi
# verify the size of the installer
--wc -c "$THIS_PATH" | grep 353018424 >/dev/null
-+wc -c "$THIS_PATH" | grep 353018431 >/dev/null
+-wc -c "$THIS_PATH" | grep 299023674 >/dev/null
++wc -c "$THIS_PATH" | grep 299023681 >/dev/null
if (( $? )); then
-- echo "ERROR: size of $THIS_FILE should be 353018424 bytes" >&2
-+ echo "ERROR: size of $THIS_FILE should be 353018431 bytes" >&2
+- echo "ERROR: size of $THIS_FILE should be 299023674 bytes" >&2
++ echo "ERROR: size of $THIS_FILE should be 299023681 bytes" >&2
exit 1
fi
-@@ -385,7 +385,7 @@
- extract_dist _cache-0.0-x0
+@@ -414,7 +414,7 @@
+ extract_dist _cache-0.0-py35_x0
mkdir $PREFIX/envs
-mkdir $HOME/.continuum 2>/dev/null
+#mkdir $HOME/.continuum 2>/dev/null
- PYTHON="$PREFIX/pkgs/python-3.4.3-1/bin/python -E"
+ PYTHON="$PREFIX/pkgs/python-3.5.0-1/bin/python -E"
$PYTHON -V
-@@ -395,7 +395,7 @@
+@@ -424,7 +424,7 @@
uname -a
exit 1
fi
-
+exit 0
echo "creating default environment..."
- CONDA_INSTALL="$PREFIX/pkgs/conda-3.14.1-py34_0/lib/python3.4/site-packages/conda/install.py"
+ CONDA_INSTALL="$PREFIX/pkgs/conda-3.18.3-py35_0/lib/python3.5/site-packages/conda/install.py"
$PYTHON $CONDA_INSTALL --prefix=$PREFIX --pkgs-dir=$PREFIX/pkgs --link-all || exit 1