summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJingbei Li2016-10-29 22:26:53 +0800
committerJingbei Li2016-10-29 22:26:53 +0800
commit642d7f22d4e1cca5996b386602d6596a95c80f3c (patch)
treee073244e04d4b389ba64dc8d9720a808b3395451
parente80d62d3605c0224eb134daeac98bfc0552e21b5 (diff)
downloadaur-642d7f22d4e1cca5996b386602d6596a95c80f3c.tar.gz
fixed install.py.patch
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD4
-rw-r--r--install.py.patch30
4 files changed, 22 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 37561f40d17e..833391f25314 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue Oct 25 18:07:49 UTC 2016
+# Sat Oct 29 14:26:49 UTC 2016
pkgbase = anaconda
pkgdesc = Completely free enterprise-ready Python distribution for large-scale data processing, predictive analytics, and scientific computing.
pkgver = 4.2.0
- pkgrel = 1
+ pkgrel = 2
url = https://store.continuum.io/cshop/anaconda/
arch = x86
arch = x86_64
@@ -14,7 +14,7 @@ pkgbase = anaconda
source = http://repo.continuum.io/archive/Anaconda3-4.2.0-Linux-x86_64.sh
source = install.py.patch
sha256sums = 73b51715a12b6382dd4df3dd1905b531bd6792d4aa7273b2377a0436d45f0e78
- sha256sums = c8b3c3a0b2ff76e21991b936f935db4bc168eae311a446ca2d947f8b41181b19
+ sha256sums = 9fbb8d46f0864e034cb56bbe33281f475091b021a64df500b89bcb06f2081e71
pkgname = anaconda
diff --git a/.gitignore b/.gitignore
index b44823988ce5..d60513f05ff7 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,5 @@
Anaconda3*.sh
pkg/
src/
+*.log
+*.pkg*
diff --git a/PKGBUILD b/PKGBUILD
index e83995733be0..e826952a8bf1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=anaconda
pkgver=4.2.0
-pkgrel=1
+pkgrel=2
pkgdesc="Completely free enterprise-ready Python distribution for large-scale data processing, predictive analytics, and scientific computing."
arch=('x86' 'x86_64')
url="https://store.continuum.io/cshop/anaconda/"
@@ -14,7 +14,7 @@ source=("http://repo.continuum.io/archive/Anaconda3-${pkgver}-Linux-x86_64.sh"
"install.py.patch")
options=(!strip libtool)
sha256sums=('73b51715a12b6382dd4df3dd1905b531bd6792d4aa7273b2377a0436d45f0e78'
- 'c8b3c3a0b2ff76e21991b936f935db4bc168eae311a446ca2d947f8b41181b19')
+ '9fbb8d46f0864e034cb56bbe33281f475091b021a64df500b89bcb06f2081e71')
_pythonver='3.5.2-0'
_condaver='4.2.9'
diff --git a/install.py.patch b/install.py.patch
index c25587f18c1d..779c0a7701f8 100644
--- a/install.py.patch
+++ b/install.py.patch
@@ -1,7 +1,7 @@
---- a/pkgs/.install.py> 2016-10-22 22:34:35.739932506 +0800
-+++ b/pkgs/.install.py> 2016-10-22 22:35:04.296779737 +0800
+--- a/pkgs/.install.py 2016-10-22 22:34:35.739932506 +0800
++++ b/pkgs/.install.py 2016-10-22 22:35:04.296779737 +0800
@@ -44,6 +44,7 @@
--
+
# these may be changed in main()
ROOT_PREFIX = sys.prefix
+instdir = ROOT_PREFIX
@@ -10,8 +10,8 @@
FORCE = False
@@ -1145,7 +1146,9 @@
return res
--
--
+
+
-def update_prefix(path, new_prefix, placeholder, mode):
+def update_prefix(path, new_prefix, placeholder, mode, instdir=None):
+ if not instdir is None:
@@ -21,8 +21,8 @@
# to escape backslashes - replace with unix-style path separators
@@ -1269,7 +1272,7 @@
return set(fn[:-5] for fn in os.listdir(meta_dir) if fn.endswith('.json'))
--
--
+
+
-def link(prefix, dist, linktype=LINK_HARD):
+def link(prefix, dist, linktype=LINK_HARD, instdir=None):
'''
@@ -43,22 +43,22 @@
assert dist in IDISTS
- link(prefix, dist, linktype)
+ link(prefix, dist, linktype, instdir)
--
+
for dist in duplicates_to_remove(linked(prefix), dists):
meta_path = join(prefix, 'conda-meta', dist + '.json')
@@ -1419,7 +1422,7 @@
--
--
+
+
def main():
- global ROOT_PREFIX, PKGS_DIR, FORCE
+ global ROOT_PREFIX, PKGS_DIR, FORCE, instdir
--
+
p = OptionParser(description="conda link tool used by installers")
--
+
@@ -1428,6 +1431,10 @@
default=abspath(join(__file__, '..', '..')),
help="root prefix (defaults to %default)")
--
+
+ p.add_option('--instdir',
+ action="store",
+ help="install dir (defaults to root prefix)")
@@ -67,12 +67,12 @@
action="store",
help="perform post extract (on a single package), "
@@ -1439,6 +1446,10 @@ p.error('no arguments expected')
--
+
ROOT_PREFIX = opts.root_prefix
+ if not opts.instdir:
+ instdir = ROOT_PREFIX
+ else:
+ instdir = opts.instdir
PKGS_DIR = join(ROOT_PREFIX, 'pkgs')
--
+
if opts.post: