summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIsmaël Bouya2015-07-03 11:11:39 +0200
committerIsmaël Bouya2015-07-03 11:11:39 +0200
commitfbd2de4142e0ab59395aa7fc9744c794c12280a9 (patch)
tree2ebbeaeaec342a178486a4997273e0877d1ace76
parent31d2e6ccb29f13fdb373fccdab21816c04842f39 (diff)
downloadaur-fbd2de4142e0ab59395aa7fc9744c794c12280a9.tar.gz
Upgrade to Anaconda 2.3.0
-rw-r--r--PKGBUILD18
-rw-r--r--conda_install.patch22
-rw-r--r--installer_sh_x86.patch20
-rw-r--r--installer_sh_x86_64.patch20
4 files changed, 40 insertions, 40 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ad2f8be821f0..6e7b6b80242e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor : Martin Wimpress <code@flexion.org>
pkgname=anaconda
-pkgver=2.2.0
+pkgver=2.3.0
pkgrel=1
pkgdesc="Completely free enterprise-ready Python distribution for large-scale data processing, predictive analytics, and scientific computing."
arch=('x86' 'x86_64')
@@ -14,17 +14,17 @@ source=("https://3230d63b5fc54e62148e-c95ac804525aac4b6dba79b00b39d1d3.ssl.cf1.r
"installer_sh_x86_64.patch"
"conda_install.patch")
options=(!strip libtool)
-sha256sums=('4aac68743e7706adb93f042f970373a6e7e087dbf4b02ac467c94ca4ce33d2d1'
- 'e304a2cbf3f6cddd80abc1a21488e6e20798ccdc714e999e68c24f937704ed4c'
- 'e5f90b6210926704f110cbab0e57c8dd06ca05cbdf5e697a97ffbb184d35ea26'
- 'de91d0b08d24f632c7d282ed6457ffe2e3d5ecab5967b8e3c000fcf5091e3711')
-_pythonver='3.4.3-0'
-_condaver='3.10.0'
+sha256sums=('3be5410b2d9db45882c7de07c554cf4f1034becc274ec9074b23fd37a5c87a6f'
+ '809d8bcb6a6ab8a51dd9fafa89a24dd29403162d708e03e2b939c0508ba14418'
+ '359243cca1dd5c325ffcafdb53d4971f04146c815d72eb7088d3bcff85fad404'
+ '9ccd29b053a1b8eba2840c3320a041fa5d869ef60e05e2f720272d5c916e2726')
+_pythonver='3.4.3-1'
+_condaver='3.14.1'
_pkgarch=`uname -m`
-if [ "$CARCH" == "i686" ]; then
+if [ "$CARCH" == "x86" ]; then
_pkgarch="x86"
- sha256sums[0]='223655cd256aa912dfc83ab24570e47bb3808bc3b0c6bd21b5db0fcf2750883e'
+ sha256sums[0]='4cc10d65c303191004ada2b6d75562c8ed84e42bf9871af06440dd956077b555'
source[0]="https://3230d63b5fc54e62148e-c95ac804525aac4b6dba79b00b39d1d3.ssl.cf1.rackcdn.com/Anaconda3-${pkgver}-Linux-x86.sh"
fi
diff --git a/conda_install.patch b/conda_install.patch
index d46a189cf336..f8f9a73072bf 100644
--- a/conda_install.patch
+++ b/conda_install.patch
@@ -1,6 +1,6 @@
---- a/pkgs/conda-3.10.0-py34_0/lib/python3.4/site-packages/conda/install.py 2015-04-06 18:15:53.455377831 +0200
-+++ b/pkgs/conda-3.10.0-py34_0/lib/python3.4/site-packages/conda/install.py 2015-04-06 18:16:14.235119572 +0200
-@@ -244,21 +244,23 @@
+--- a/pkgs/conda-3.14.1-py34_0/lib/python3.4/site-packages/conda/install.py 2015-07-03 11:04:48.348322309 +0200
++++ b/pkgs/conda-3.14.1-py34_0/lib/python3.4/site-packages/conda/install.py 2015-07-03 11:04:52.078277806 +0200
+@@ -251,21 +251,23 @@
return res
def update_prefix(path, new_prefix, placeholder=prefix_placeholder,
@@ -28,16 +28,16 @@
else:
sys.exit("Invalid mode:" % mode)
-@@ -490,7 +492,7 @@
- return None
-
+@@ -550,7 +552,7 @@
+ def load_meta(prefix, dist):
+ return is_linked(prefix, dist)
-def link(pkgs_dir, prefix, dist, linktype=LINK_HARD, index=None):
+def link(pkgs_dir, prefix, dist, linktype=LINK_HARD, index=None, instdir=None):
'''
Set up a package in a specified (environment) prefix. We assume that
the package has been extracted (using extract() above).
-@@ -504,6 +506,8 @@
+@@ -569,6 +571,8 @@
# linking or unlinking some packages
log.warn('Ignored: %s' % dist)
return
@@ -46,7 +46,7 @@
source_dir = join(pkgs_dir, dist)
if not run_script(source_dir, dist, 'pre-link', prefix):
-@@ -542,7 +546,7 @@
+@@ -614,7 +618,7 @@
for f in sorted(has_prefix_files):
placeholder, mode = has_prefix_files[f]
try:
@@ -55,7 +55,7 @@
except PaddingError:
sys.exit("ERROR: placeholder '%s' too short in: %s\n" %
(placeholder, dist))
-@@ -667,6 +671,10 @@
+@@ -749,6 +753,10 @@
default=sys.prefix,
help="prefix (defaults to %default)")
@@ -66,7 +66,7 @@
p.add_option('--pkgs-dir',
action="store",
default=join(sys.prefix, 'pkgs'),
-@@ -696,9 +704,14 @@
+@@ -778,9 +786,14 @@
pkgs_dir = opts.pkgs_dir
prefix = opts.prefix
@@ -81,7 +81,7 @@
if opts.list:
pprint(sorted(linked(prefix)))
-@@ -713,14 +726,14 @@
+@@ -795,14 +808,14 @@
for dist in dists:
if opts.verbose or linktype == LINK_COPY:
print("linking: %s" % dist)
diff --git a/installer_sh_x86.patch b/installer_sh_x86.patch
index 1ad1733d86bc..97b410da7baa 100644
--- a/installer_sh_x86.patch
+++ b/installer_sh_x86.patch
@@ -1,32 +1,32 @@
---- a/Anaconda3-2.2.0-Linux-x86.sh 2015-04-06 18:33:01.272567022 +0200
-+++ b/Anaconda3-2.2.0-Linux-x86.sh 2015-04-06 18:34:04.221780206 +0200
+--- a/Anaconda3-2.3.0-Linux-x86.sh 2015-07-03 10:58:15.083001201 +0200
++++ b/Anaconda3-2.3.0-Linux-x86.sh 2015-07-03 10:59:12.242322446 +0200
@@ -73,9 +73,9 @@
fi
fi
# verify the size of the installer
--wc -c "$THIS_PATH" | grep 328483185 >/dev/null
-+wc -c "$THIS_PATH" | grep 328483192 >/dev/null
+-wc -c "$THIS_PATH" | grep 338272927 >/dev/null
++wc -c "$THIS_PATH" | grep 338272934 >/dev/null
if (( $? )); then
-- echo "ERROR: size of $THIS_FILE should be 328483185 bytes" >&2
-+ echo "ERROR: size of $THIS_FILE should be 328483192 bytes" >&2
+- echo "ERROR: size of $THIS_FILE should be 338272927 bytes" >&2
++ echo "ERROR: size of $THIS_FILE should be 338272934 bytes" >&2
exit 1
fi
-@@ -378,7 +378,7 @@
+@@ -386,7 +386,7 @@
extract_dist _cache-0.0-x0
mkdir $PREFIX/envs
-mkdir $HOME/.continuum 2>/dev/null
+#mkdir $HOME/.continuum 2>/dev/null
- PYTHON="$PREFIX/pkgs/python-3.4.3-0/bin/python -E"
+ PYTHON="$PREFIX/pkgs/python-3.4.3-1/bin/python -E"
$PYTHON -V
-@@ -388,7 +388,7 @@
+@@ -396,7 +396,7 @@
uname -a
exit 1
fi
-
+exit 0
echo "creating default environment..."
- CONDA_INSTALL="$PREFIX/pkgs/conda-3.10.0-py34_0/lib/python3.4/site-packages/conda/install.py"
+ CONDA_INSTALL="$PREFIX/pkgs/conda-3.14.1-py34_0/lib/python3.4/site-packages/conda/install.py"
$PYTHON $CONDA_INSTALL --prefix=$PREFIX --pkgs-dir=$PREFIX/pkgs --link-all || exit 1
diff --git a/installer_sh_x86_64.patch b/installer_sh_x86_64.patch
index 63a1cc97a468..1e0676df65de 100644
--- a/installer_sh_x86_64.patch
+++ b/installer_sh_x86_64.patch
@@ -1,32 +1,32 @@
---- a/Anaconda3-2.2.0-Linux-x86_64.sh 2015-04-06 17:42:20.230488424 +0200
-+++ b/Anaconda3-2.2.0-Linux-x86_64.sh 2015-04-06 17:43:37.089513561 +0200
+--- a/Anaconda3-2.3.0-Linux-x86_64.sh 2015-07-03 10:44:50.662500605 +0200
++++ b/Anaconda3-2.3.0-Linux-x86_64.sh 2015-07-03 10:47:37.900536717 +0200
@@ -70,9 +70,9 @@
fi
fi
# verify the size of the installer
--wc -c "$THIS_PATH" | grep 342778122 >/dev/null
-+wc -c "$THIS_PATH" | grep 342778129 >/dev/null
+-wc -c "$THIS_PATH" | grep 353018424 >/dev/null
++wc -c "$THIS_PATH" | grep 353018431 >/dev/null
if (( $? )); then
-- echo "ERROR: size of $THIS_FILE should be 342778122 bytes" >&2
-+ echo "ERROR: size of $THIS_FILE should be 342778129 bytes" >&2
+- echo "ERROR: size of $THIS_FILE should be 353018424 bytes" >&2
++ echo "ERROR: size of $THIS_FILE should be 353018431 bytes" >&2
exit 1
fi
-@@ -377,7 +377,7 @@
+@@ -385,7 +385,7 @@
extract_dist _cache-0.0-x0
mkdir $PREFIX/envs
-mkdir $HOME/.continuum 2>/dev/null
+#mkdir $HOME/.continuum 2>/dev/null
- PYTHON="$PREFIX/pkgs/python-3.4.3-0/bin/python -E"
+ PYTHON="$PREFIX/pkgs/python-3.4.3-1/bin/python -E"
$PYTHON -V
-@@ -387,7 +387,7 @@
+@@ -395,7 +395,7 @@
uname -a
exit 1
fi
-
+exit 0
echo "creating default environment..."
- CONDA_INSTALL="$PREFIX/pkgs/conda-3.10.0-py34_0/lib/python3.4/site-packages/conda/install.py"
+ CONDA_INSTALL="$PREFIX/pkgs/conda-3.14.1-py34_0/lib/python3.4/site-packages/conda/install.py"
$PYTHON $CONDA_INSTALL --prefix=$PREFIX --pkgs-dir=$PREFIX/pkgs --link-all || exit 1