summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonzalo Exequiel Pedone2024-03-28 12:51:34 -0300
committerGonzalo Exequiel Pedone2024-03-28 12:51:34 -0300
commit0433854ae0e800a67c9fd7e06dd779361b549331 (patch)
tree0508e2714c9ce267a8818c927c80d777a3509eed
downloadaur-android-armv7a-eabi-json-c.tar.gz
New package.
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD41
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b08c344176e3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = android-armv7a-eabi-json-c
+ pkgdesc = A JSON implementation in C (Android armv7a-eabi)
+ pkgver = 0.17
+ pkgrel = 1
+ url = https://github.com/json-c/json-c/wiki
+ arch = any
+ license = MIT
+ makedepends = android-cmake
+ depends = android-ndk
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ options = !emptydirs
+ source = https://github.com/json-c/json-c/archive/refs/tags/json-c-0.17-20230812.tar.gz
+ md5sums = 6d724389b0a08c519d9dd6e2fac7efb8
+
+pkgname = android-armv7a-eabi-json-c
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b5b03b115225
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+pkg
+src
+*.tar.xz
+*.tar.gz
+*.tar.bz2
+*.asc
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9e5932fef11f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Gonzalo Exequiel Pedone <hipersayan DOT x AT gmail DOT com>
+# Contributor: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
+# Contributor: Geoffroy Carrier <geoffroy.carrier@koon.fr>
+# Contributor: congyiwu <congyiwu AT gmail DOT com>
+
+_android_arch=armv7a-eabi
+
+pkgname=android-${_android_arch}-json-c
+pkgver=0.17
+_pkgverdate=20230812
+pkgrel=1
+arch=('any')
+pkgdesc="A JSON implementation in C (Android ${_android_arch})"
+url="https://github.com/json-c/json-c/wiki"
+license=('MIT')
+depends=('android-ndk')
+makedepends=('android-cmake')
+options=(!strip !buildflags staticlibs !emptydirs)
+source=("https://github.com/json-c/json-c/archive/refs/tags/json-c-${pkgver}-${_pkgverdate}.tar.gz")
+md5sums=('6d724389b0a08c519d9dd6e2fac7efb8')
+
+build() {
+ cd "${srcdir}/json-c-json-c-${pkgver}-${_pkgverdate}"
+ source android-env ${_android_arch}
+
+ android-${_android_arch}-cmake \
+ -DBUILD_STATIC_LIBS=ON \
+ -DENABLE_THREADING=ON \
+ -DENABLE_RDRAND=OFF \
+ .
+ make $MAKEFLAGS
+}
+
+package() {
+ cd "${srcdir}/json-c-json-c-${pkgver}-${_pkgverdate}"
+ source android-env ${_android_arch}
+
+ make DESTDIR="$pkgdir" install
+ ${ANDROID_STRIP} -g --strip-unneeded "${pkgdir}"/${ANDROID_PREFIX_LIB}/*.so
+ ${ANDROID_STRIP} -g "$pkgdir"/${ANDROID_PREFIX_LIB}/*.a
+}