summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonzalo Exequiel Pedone2024-04-28 13:13:02 -0300
committerGonzalo Exequiel Pedone2024-04-28 13:13:02 -0300
commit1a85e7a4d141ecbdcb983b4aa74938a4408be2e2 (patch)
tree4200c1cfe2d9dd17008e833468c15fd7e15a4961
downloadaur-android-armv7a-eabi-libraw1394.tar.gz
New package.
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD37
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6dbe1a8d6965
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = android-armv7a-eabi-libraw1394
+ pkgdesc = Provides an API to the Linux IEEE1394 (FireWire) driver (Android armv7a-eabi)
+ pkgver = 2.1.2
+ pkgrel = 1
+ url = https://ieee1394.wiki.kernel.org/index.php/Main_Page
+ arch = any
+ license = LGPL2.1
+ makedepends = android-configure
+ depends = android-ndk
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ options = !emptydirs
+ source = https://www.kernel.org/pub/linux/libs/ieee1394/libraw1394-2.1.2.tar.xz
+ sha256sums = 03ccc69761d22c7deb1127fc301010dd13e70e44bb7134b8ff0d07590259a55e
+
+pkgname = android-armv7a-eabi-libraw1394
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b5b03b115225
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+pkg
+src
+*.tar.xz
+*.tar.gz
+*.tar.bz2
+*.asc
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8aacb61397d6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Gonzalo Exequiel Pedone <hipersayan DOT x AT gmail DOT com>
+# Contributor: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+
+_android_arch=armv7a-eabi
+
+pkgname=android-${_android_arch}-libraw1394
+pkgver=2.1.2
+pkgrel=1
+arch=('any')
+pkgdesc="Provides an API to the Linux IEEE1394 (FireWire) driver (Android ${_android_arch})"
+url="https://ieee1394.wiki.kernel.org/index.php/Main_Page"
+license=('LGPL2.1')
+depends=('android-ndk')
+makedepends=('android-configure')
+options=(!strip !buildflags staticlibs !emptydirs)
+source=("https://www.kernel.org/pub/linux/libs/ieee1394/libraw1394-${pkgver}.tar.xz")
+sha256sums=('03ccc69761d22c7deb1127fc301010dd13e70e44bb7134b8ff0d07590259a55e')
+
+build() {
+ cd "${srcdir}/libraw1394-${pkgver}"
+ source android-env ${_android_arch}
+
+ android-${_android_arch}-configure
+ make $MAKEFLAGS
+}
+
+package () {
+ cd "${srcdir}/libraw1394-${pkgver}"
+ source android-env ${_android_arch}
+
+ make DESTDIR="${pkgdir}" install
+ rm -rf "$pkgdir/${ANDROID_PREFIX_BIN}"
+ rm -rf "$pkgdir/${ANDROID_PREFIX_SHARE}"
+ ${ANDROID_STRIP} -g --strip-unneeded "${pkgdir}"/${ANDROID_PREFIX_LIB}/*.so
+ ${ANDROID_STRIP} -g "$pkgdir"/${ANDROID_PREFIX_LIB}/*.a
+}