summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonzalo Exequiel Pedone2024-03-08 18:54:55 -0300
committerGonzalo Exequiel Pedone2024-03-08 18:54:55 -0300
commita7f8bafb185f133e0d1561275cdefce07ef8e7f8 (patch)
tree826ede0b6c6d06661425446ffde9c7a6f6c09cef
parent662f619c4a21a13d6ae9f50f7ebcd452f9a0fd29 (diff)
downloadaur-android-armv7a-eabi-libssh.tar.gz
Package updated to 0.10.6.
-rw-r--r--.SRCINFO12
-rw-r--r--0002-Fix-missing-prototype-error.patch11
-rw-r--r--PKGBUILD25
-rw-r--r--staticlibfix.patch14
4 files changed, 18 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f90d400bd64d..c76e72d344ab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = android-armv7a-eabi-libssh
- pkgdesc = Library for accessing ssh client services through C libraries (android)
- pkgver = 0.9.6
- pkgrel = 3
+ pkgdesc = Library for accessing ssh client services through C libraries (Android armv7a-eabi)
+ pkgver = 0.10.6
+ pkgrel = 1
url = https://www.libssh.org/
arch = any
groups = android-libssh
@@ -15,11 +15,9 @@ pkgbase = android-armv7a-eabi-libssh
options = !buildflags
options = staticlibs
options = !emptydirs
- source = https://www.libssh.org/files/0.9/libssh-0.9.6.tar.xz
+ source = https://www.libssh.org/files/0.10/libssh-0.10.6.tar.xz
source = 0001-Fix-static-lib.patch
- source = 0002-Fix-missing-prototype-error.patch
- md5sums = 0174df377361221a31a9576afbaba330
+ md5sums = 5f46371aa8bfa7e6bff7f2a6f3edf80e
md5sums = 66588a420aac9c580c31018a5b1c78cf
- md5sums = 768b2bee29d9f55f09f74279ef06f48d
pkgname = android-armv7a-eabi-libssh
diff --git a/0002-Fix-missing-prototype-error.patch b/0002-Fix-missing-prototype-error.patch
deleted file mode 100644
index 671d5f2bb0d0..000000000000
--- a/0002-Fix-missing-prototype-error.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src/init.c 2021-03-15 04:11:33.000000000 -0300
-+++ b/src/init.c 2024-01-16 17:47:40.548501135 -0300
-@@ -269,7 +269,7 @@
- *
- * @see ssh_init()
- */
--bool is_ssh_initialized() {
-+bool is_ssh_initialized(void) {
-
- bool is_initialized = false;
-
diff --git a/PKGBUILD b/PKGBUILD
index 12e790cafd0b..3de2c5e62b47 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,26 +10,23 @@
_android_arch=armv7a-eabi
pkgname=android-${_android_arch}-libssh
-pkgver=0.9.6
-pkgrel=3
+pkgver=0.10.6
+pkgrel=1
arch=('any')
-pkgdesc="Library for accessing ssh client services through C libraries (android)"
+pkgdesc="Library for accessing ssh client services through C libraries (Android ${_android_arch})"
license=('LGPL')
url="https://www.libssh.org/"
depends=("android-${_android_arch}-zlib"
"android-${_android_arch}-openssl")
-groups=(android-libssh)
-options=(!strip !buildflags staticlibs !emptydirs)
+groups=('android-libssh')
makedepends=('android-cmake'
'doxygen'
'python')
+options=(!strip !buildflags staticlibs !emptydirs)
source=("https://www.libssh.org/files/${pkgver%.*}/libssh-$pkgver.tar.xz"
- '0001-Fix-static-lib.patch'
- '0002-Fix-missing-prototype-error.patch')
-
-md5sums=('0174df377361221a31a9576afbaba330'
- '66588a420aac9c580c31018a5b1c78cf'
- '768b2bee29d9f55f09f74279ef06f48d')
+ '0001-Fix-static-lib.patch')
+md5sums=('5f46371aa8bfa7e6bff7f2a6f3edf80e'
+ '66588a420aac9c580c31018a5b1c78cf')
prepare() {
cd "${srcdir}/libssh-${pkgver}"
@@ -38,12 +35,15 @@ prepare() {
sed 's/find_package(OpenSSL)/#find_package(OpenSSL)/' -i CMakeLists.txt
patch -Np1 -i "../0001-Fix-static-lib.patch"
- patch -Np1 -i "../0002-Fix-missing-prototype-error.patch"
}
build() {
+ cd "${srcdir}/libssh-${pkgver}"
source android-env ${_android_arch}
+ export CFLAGS="${CFLAGS} -D__USE_BSD"
+ export CXXFLAGS="${CXXFLAGS} -D__USE_BSD"
+
version=$(cat ${ANDROID_PREFIX_INCLUDE}/openssl/opensslv.h | grep "OPENSSL_VERSION_TEXT" | sed 's/^[^\"]*"OpenSSL //' | sed 's/ .*$//')
libssl=${ANDROID_PREFIX_LIB}/libssl.so
libcrypto=${ANDROID_PREFIX_LIB}/libcrypto.so
@@ -88,6 +88,7 @@ build() {
}
package(){
+ cd "${srcdir}/libssh-${pkgver}"
source android-env ${_android_arch}
# install static library
diff --git a/staticlibfix.patch b/staticlibfix.patch
deleted file mode 100644
index 06bf7505c938..000000000000
--- a/staticlibfix.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -ruN libssh-0.9.2/src/CMakeLists.txt patched/src/CMakeLists.txt
---- libssh-0.9.2/src/CMakeLists.txt 2019-11-07 16:14:46.000000000 +0100
-+++ patched/src/CMakeLists.txt 2019-12-05 17:35:42.941031097 +0100
-@@ -324,6 +324,10 @@
-
- add_library(ssh::ssh ALIAS ssh)
-
-+if (WIN32 AND NOT BUILD_SHARED_LIBS)
-+ set_target_properties(ssh PROPERTIES COMPILE_FLAGS "-DLIBSSH_STATIC")
-+endif ()
-+
- if (WITH_SYMBOL_VERSIONING AND HAVE_LD_VERSION_SCRIPT)
- if (ABIMAP_FOUND)
- # Change path to devel map file