summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonzalo Exequiel Pedone2024-06-15 09:05:20 -0300
committerGonzalo Exequiel Pedone2024-06-15 09:05:20 -0300
commitd3ed11f221b262895201bfb8f72e8a1ed6d834ec (patch)
tree095f8cc5b5f2454b40aa6d5840be411ff5c02460
parentae7bc7d2725d2f93371496e2e881d366754ba3f9 (diff)
downloadaur-android-armv7a-eabi-pcsclite.tar.gz
Package updated to 2.2.3.
-rw-r--r--.SRCINFO14
-rw-r--r--0001-Fix-pcsc-arch.patch20
-rw-r--r--0002-Disable-issetugid.patch13
-rw-r--r--0003-Fix-missing-pthread_cancel.patch11
-rw-r--r--PKGBUILD13
5 files changed, 40 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 07535a69f2ea..f96e9e5d73ac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = android-armv7a-eabi-pcsclite
pkgdesc = PC/SC Architecture smartcard middleware library (Android armv7a-eabi)
- pkgver = 2.2.0
+ pkgver = 2.2.3
pkgrel = 1
url = https://pcsclite.apdu.fr/
arch = any
@@ -11,12 +11,14 @@ pkgbase = android-armv7a-eabi-pcsclite
options = !buildflags
options = staticlibs
options = !emptydirs
- source = https://pcsclite.apdu.fr/files/pcsc-lite-2.2.0.tar.xz
- source = https://pcsclite.apdu.fr/files/pcsc-lite-2.2.0.tar.xz.asc
- source = 0001-Fix-pcsc-arch.patch
+ source = https://pcsclite.apdu.fr/files/pcsc-lite-2.2.3.tar.xz
+ source = https://pcsclite.apdu.fr/files/pcsc-lite-2.2.3.tar.xz.asc
+ source = 0002-Disable-issetugid.patch
+ source = 0003-Fix-missing-pthread_cancel.patch
validpgpkeys = F5E11B9FFE911146F41D953D78A1B4DFE8F9C57E
- md5sums = 9e4006e1f3210ffa7dd0fadbc9083dc2
+ md5sums = 1a5f60ade943393f9e609e0e55bb1417
md5sums = SKIP
- md5sums = 0d862bb58084ec6e7da1ccc764de4ac4
+ md5sums = 17cc08c1b9ed2c5912be2fd2b368c669
+ md5sums = 3050ecacb997c4c6f901ddd18d4c87fc
pkgname = android-armv7a-eabi-pcsclite
diff --git a/0001-Fix-pcsc-arch.patch b/0001-Fix-pcsc-arch.patch
deleted file mode 100644
index d0e0e20e8579..000000000000
--- a/0001-Fix-pcsc-arch.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/meson.build
-+++ b/meson.build
-@@ -116,16 +116,7 @@
- features += 'systemd'
- endif
-
--target_system = target_machine.system()
--if target_system == 'darwin'
-- pcscd_dep += dependency('appleframeworks', modules : ['foundation', 'IOKit'])
-- pcscd_src += files(['src/hotplug_macosx.c', 'src/dyn_macosx.c'])
-- conf_data.set_quoted('PCSC_ARCH', 'MacOS')
--elif target_system == 'linux'
-- conf_data.set_quoted('PCSC_ARCH', 'Linux')
--elif target_system == 'netbsd'
-- conf_data.set_quoted('PCSC_ARCH', 'NetBSD')
--endif
-+conf_data.set_quoted('PCSC_ARCH', 'Linux')
- pcscd_dep += [polkit_dep, systemd_dep]
-
- features += conf_data.get_unquoted('PCSC_ARCH')
diff --git a/0002-Disable-issetugid.patch b/0002-Disable-issetugid.patch
new file mode 100644
index 000000000000..17251ef157bc
--- /dev/null
+++ b/0002-Disable-issetugid.patch
@@ -0,0 +1,13 @@
+--- a/src/sys_unix.c
++++ b/src/sys_unix.c
+@@ -170,10 +170,6 @@
+ #ifdef HAVE_SECURE_GETENV
+ return secure_getenv(name);
+ #else
+- /* Otherwise, make sure current process is not tainted by uid or gid
+- * changes */
+- if (issetugid())
+- return NULL;
+ return getenv(name);
+ #endif
+ }
diff --git a/0003-Fix-missing-pthread_cancel.patch b/0003-Fix-missing-pthread_cancel.patch
new file mode 100644
index 000000000000..1de7fce35348
--- /dev/null
+++ b/0003-Fix-missing-pthread_cancel.patch
@@ -0,0 +1,11 @@
+--- a/src/eventhandler.c
++++ b/src/eventhandler.c
+@@ -182,7 +182,7 @@
+ if ((IFD_SUCCESS == rv) && (1 == dwGetSize) && ucGetData[0])
+ {
+ Log1(PCSC_LOG_INFO, "Killing polling thread");
+- (void)pthread_cancel(rContext->pthThread);
++ (void)pthread_kill(rContext->pthThread, 0);
+ }
+ else
+ {
diff --git a/PKGBUILD b/PKGBUILD
index 40e073051a34..ffefa873abfb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
_android_arch=armv7a-eabi
pkgname=android-${_android_arch}-pcsclite
-pkgver=2.2.0
+pkgver=2.2.3
pkgrel=1
arch=('any')
pkgdesc="PC/SC Architecture smartcard middleware library (Android ${_android_arch})"
@@ -17,16 +17,19 @@ depends=('android-ndk')
makedepends=('android-meson')
options=(!strip !buildflags staticlibs !emptydirs)
source=("https://pcsclite.apdu.fr/files/pcsc-lite-${pkgver}.tar.xz"{,.asc}
- '0001-Fix-pcsc-arch.patch')
-md5sums=('9e4006e1f3210ffa7dd0fadbc9083dc2'
+ '0002-Disable-issetugid.patch'
+ '0003-Fix-missing-pthread_cancel.patch')
+md5sums=('1a5f60ade943393f9e609e0e55bb1417'
'SKIP'
- '0d862bb58084ec6e7da1ccc764de4ac4')
+ '17cc08c1b9ed2c5912be2fd2b368c669'
+ '3050ecacb997c4c6f901ddd18d4c87fc')
validpgpkeys=('F5E11B9FFE911146F41D953D78A1B4DFE8F9C57E') # Ludovic Rousseau <rousseau@debian.org>
prepare() {
cd "${srcdir}/pcsc-lite-$pkgver"
- patch -Np1 -i ../0001-Fix-pcsc-arch.patch
+ patch -Np1 -i ../0002-Disable-issetugid.patch
+ patch -Np1 -i ../0003-Fix-missing-pthread_cancel.patch
}
build() {