summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhang Hai2017-06-22 02:01:26 +0800
committerZhang Hai2017-06-22 02:01:26 +0800
commit33fe744121e974c1f1aef31e941f6b2373c9d83a (patch)
treec6269c3c588dbeaa7c05fb55c8fb5dad558a4c6c
parentb4251445dde8d2f6f1966f6b1293ad35b50aa2ae (diff)
downloadaur-33fe744121e974c1f1aef31e941f6b2373c9d83a.tar.gz
Refactor dependencies.
-rw-r--r--.SRCINFO36
-rw-r--r--PKGBUILD26
2 files changed, 36 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 04d4eb2643b5..698273cb5f6e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sat May 6 07:35:59 UTC 2017
+# Wed Jun 21 17:47:50 UTC 2017
pkgbase = android-sdk
pkgdesc = Google Android SDK
pkgver = 26.0.2
@@ -23,25 +23,23 @@ pkgbase = android-sdk
sha1sums = 145bdf3eb41a56574b289c1577a24bc47097ec83
sha1sums = bfb91be7e0b602d765b7a1fcaf0ce1b7e1a93faa
depends_x86_64 = java-environment
- depends_x86_64 = lib32-alsa-lib
- depends_x86_64 = lib32-openal
- depends_x86_64 = lib32-libstdc++5
- depends_x86_64 = lib32-libxv
- depends_x86_64 = lib32-mesa
- depends_x86_64 = lib32-ncurses
- depends_x86_64 = lib32-sdl
- depends_x86_64 = lib32-zlib
- depends_x86_64 = lib32-fontconfig
- depends_x86_64 = lib32-libpulse
- depends_x86_64 = swt
+ depends_x86_64 = libxtst
+ depends_x86_64 = fontconfig
+ depends_x86_64 = freetype2
+ depends_x86_64 = lib32-gcc-libs
+ depends_x86_64 = lib32-glibc
+ depends_x86_64 = libx11
+ depends_x86_64 = libxext
+ depends_x86_64 = libxrender
+ depends_x86_64 = zlib
depends_i686 = java-environment
- depends_i686 = alsa-lib
- depends_i686 = openal
- depends_i686 = libstdc++5
- depends_i686 = libxv
- depends_i686 = sdl
- depends_i686 = ncurses
- depends_i686 = swt
+ depends_i686 = libxtst
+ depends_i686 = fontconfig
+ depends_i686 = freetype2
+ depends_i686 = gcc-libs
+ depends_i686 = libx11
+ depends_i686 = libxext
+ depends_i686 = libxrender
depends_i686 = zlib
pkgname = android-sdk
diff --git a/PKGBUILD b/PKGBUILD
index ff8b87f4614b..7e02e062dc14 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,19 +3,31 @@
# Contributor: Daniel Micay <danielmicay@gmail.com>
# Contributor: Gordin <9ordin@gmail.com>
+# Finding dependencies:
+# ELF dependencies:
+# cd /lib/ && find /opt/android-sdk/tools/ -type f -executable \
+# | LANG=C xargs readelf -d 2>/dev/null \
+# | grep -oP '(?<=Shared library: \[).*(?=\])' | LANG=C xargs pacman -Qo \
+# | cut -d' ' -f5 | sort | uniq
+# .so in JAR files:
+# find /opt/android-sdk/tools/ -type f -exec unzip -l {} 2>&1 \; \
+# | grep -P '^Archive:|\.so$' \
+# | awk 'BEGIN { archive = ""; } { if (NF == 2) { archive = $0; } else { \
+# if (length(archive) > 0) { print archive; archive="" } print $0; } }'
+# Note that dependency on libxtst is from swt.
+
pkgname=android-sdk
pkgver=26.0.2
-pkgrel=1
+pkgrel=2
pkgdesc='Google Android SDK'
arch=('x86_64' 'i686')
url='https://developer.android.com/studio/releases/sdk-tools.html'
license=('custom')
-depends_i686=('java-environment' 'alsa-lib' 'openal' 'libstdc++5' 'libxv' 'sdl'
- 'ncurses' 'swt' 'zlib')
-depends_x86_64=('java-environment' 'lib32-alsa-lib' 'lib32-openal'
- 'lib32-libstdc++5' 'lib32-libxv' 'lib32-mesa' 'lib32-ncurses'
- 'lib32-sdl' 'lib32-zlib' 'lib32-fontconfig' 'lib32-libpulse'
- 'swt')
+depends_i686=('java-environment' 'libxtst' 'fontconfig' 'freetype2' 'gcc-libs'
+ 'libx11' 'libxext' 'libxrender' 'zlib')
+depends_x86_64=('java-environment' 'libxtst' 'fontconfig' 'freetype2'
+ 'lib32-gcc-libs' 'lib32-glibc' 'libx11' 'libxext' 'libxrender'
+ 'zlib')
optdepends=('android-emulator: emulator has become standalone since 25.3.0'
'android-sdk-platform-tools: adb, aapt, aidl, dexdump and dx'
'android-udev: udev rules for Android devices')