summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJérémy "Vrakfall" Lecocq2018-11-02 07:25:01 +0100
committerJérémy "Vrakfall" Lecocq2018-11-02 07:25:01 +0100
commitb03e9fd264ecc889eeb5b87ef4707c2f284db020 (patch)
tree513e4c28009248c977e88cb4ac31c885d424b4c0
parent6aba1df9fe0ed71139e48fad746f3ffa364a9a47 (diff)
downloadaur-b03e9fd264ecc889eeb5b87ef4707c2f284db020.tar.gz
Updated to `Android sources v26-r01 (8.0.0)` and changed version numbering to align with other source packages.
Signed-off-by: Jérémy "Vrakfall" Lecocq <jeremy@artphotolaurent.be>
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore11
-rw-r--r--PKGBUILD30
3 files changed, 34 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 927e31109419..5e2b693d1f9d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
-# Generated by mksrcinfo v8
-# Sat Dec 31 05:42:31 UTC 2016
+#@IgnoreInspection BashAddShebang
pkgbase = android-sources
pkgdesc = Android SDK Sources, latest API
- pkgver = 25_r01
+ pkgver = 8.0.0_r01
pkgrel = 1
- url = http://developer.android.com/sdk/index.html
+ url = https://developer.android.com/studio/index.html
arch = any
license = custom
+ conflicts = android-sources=26
options = !strip
- source = https://dl-ssl.google.com/android/repository/sources-25_r01.zip
- sha1sums = bbc72efd1a9bad87cc507e308f0d29aad438c52c
+ source = https://dl.google.com/android/repository/sources-26_r01.zip
+ sha256sums = a1461c180c414eed7866a8aebada38c64846ed0084814d2f5f773584338440f5
pkgname = android-sources
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c51efac612b0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,11 @@
+# IntelliJ project files
+.idea
+*.iml
+out
+gen
+
+# Generated files
+sources-*.zip
+android-sources-*.pkg.tar.xz
+src
+pkg \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 9efd0688558d..283160223c58 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,30 @@
-# Maintainer: lestb <tkhdlstfl dot l plus aur at gmail dot com>
+#@IgnoreInspection BashAddShebang
+# Maintainer: Jérémy "Vrakfall" Lecocq <jeremy at artphotolaurent dot be>
+# Contributor: Bence Hornák <hornak dot bence at gmail dot com>
+# Contributor: lestb <tkhdlstfl dot l plus aur at gmail dot com>
# Contributor: danyf90 <daniele.formichelli@gmail.com>
# Contributor: Philipp Wolfer <ph.wolfer@gmail.com>
# Contributor: Joel Pedraza <joel@joelpedraza.com>
# Contributor: Jakub Schmidtke <sjakub-at-gmail-dot-com>
-# Package Repository: https://github.com/mij-aur-packages/android-sources
_rev=r01
-_apilevel=25
-pkgname=android-sources
-pkgver=${_apilevel}_${_rev}
+_sdkint=26
+_sdkver=8.0.0
+pkgname="android-sources"
+pkgver="${_sdkver}_${_rev}"
pkgrel=1
pkgdesc="Android SDK Sources, latest API"
arch=('any')
-url="http://developer.android.com/sdk/index.html"
+url="https://developer.android.com/studio/index.html"
license=('custom')
+conflicts=("android-sources=${_sdkint}")
options=('!strip')
-source=("https://dl-ssl.google.com/android/repository/sources-25_r01.zip")
-sha1sums=('bbc72efd1a9bad87cc507e308f0d29aad438c52c')
+source=("https://dl.google.com/android/repository/sources-${_sdkint}_${_rev}.zip")
+sha256sums=('a1461c180c414eed7866a8aebada38c64846ed0084814d2f5f773584338440f5')
-package() {
- install -d "${pkgdir}/opt/android-sdk/sources/"
- mv "${srcdir}/src" "${pkgdir}/opt/android-sdk/sources/android-${_apilevel}"
- chmod -R ugo+rX "${pkgdir}/opt"
-}
+package() {
+ mkdir -p "${pkgdir}/opt/android-sdk/sources/"
+ cp -dpr --no-preserve=ownership "${srcdir}/src" "${pkgdir}/opt/android-sdk/sources/android-${_sdkint}"
+ chmod -R ugo+rX "${pkgdir}/opt"
+} \ No newline at end of file