summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArtem Vorotnikov2015-06-08 20:42:33 +0300
committerArtem Vorotnikov2015-06-08 20:42:33 +0300
commit4c8726b3f15ac78988507e3d8855f996d8bb3ac8 (patch)
treee1d504c69ea8d63b422a5957a66b21d5c16456b3
downloadaur-angelscript-2.22.1.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD53
3 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0dca6eca5628
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = angelscript-2.22.1
+ pkgdesc = An extremely flexible cross-platform scripting library. - Specific version for Rigs of Rods
+ pkgver = 2.22.1
+ pkgrel = 3
+ url = http://angelcode.com/angelscript/
+ arch = i686
+ arch = x86_64
+ license = custom:ZLIB
+ depends = gcc-libs
+ conflicts = angelscript
+ source = http://angelcode.com/angelscript/sdk/files/angelscript_2.22.1.zip
+ source = LICENSE
+ sha512sums = 92a2b990044b128c1f34a2033b7e46108d771408f5c7208c4327b2784cd0aa3f3a11f58d97b1419fdca233217305a94835e59e52c05c959d57bff524d372b824
+ sha512sums = b9e7197d47b55b28f9fea4dafb51d221af46a6d794a783c3875778e9b2f748396bbdaa93d3c1ca0ef2391fa797e85cfd7e27ac5178ec4578c1e7999c0e58b366
+
+pkgname = angelscript-2.22.1
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..3915fab59def
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+AngelCode Scripting Library
+Copyright (c) 2003-2013 Andreas Jonsson
+
+This software is provided 'as-is', without any express or implied
+warranty. In no event will the authors be held liable for any
+damages arising from the use of this software.
+
+Permission is granted to anyone to use this software for any
+purpose, including commercial applications, and to alter it and
+redistribute it freely, subject to the following restrictions:
+
+1. The origin of this software must not be misrepresented; you
+must not claim that you wrote the original software. If you use
+this software in a product, an acknowledgment in the product
+documentation would be appreciated but is not required.
+
+2. Altered source versions must be plainly marked as such, and
+must not be misrepresented as being the original software.
+
+3. This notice may not be removed or altered from any source
+distribution.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8270aba3f248
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Artem Vorotnikov <artem@vorotnikov.me>
+
+pkgname=angelscript-2.22.1
+pkgver=2.22.1
+pkgrel=3
+pkgdesc="An extremely flexible cross-platform scripting library. - Specific version for Rigs of Rods"
+arch=('i686' 'x86_64')
+url="http://angelcode.com/angelscript/"
+license=('custom:ZLIB')
+depends=('gcc-libs')
+conflicts=("angelscript")
+source=("http://angelcode.com/angelscript/sdk/files/angelscript_2.22.1.zip"
+ LICENSE)
+sha512sums=('92a2b990044b128c1f34a2033b7e46108d771408f5c7208c4327b2784cd0aa3f3a11f58d97b1419fdca233217305a94835e59e52c05c959d57bff524d372b824'
+ 'b9e7197d47b55b28f9fea4dafb51d221af46a6d794a783c3875778e9b2f748396bbdaa93d3c1ca0ef2391fa797e85cfd7e27ac5178ec4578c1e7999c0e58b366')
+
+build() {
+ cd "$srcdir/sdk/angelscript/projects/gnuc"
+
+ sed -i -e "/^LOCAL/s:=.*:= ${pkgdir}/usr:" \
+ -e '/\sCXXFLAGS/s:-g::' \
+ -e '/^install/s/:.*/:/' \
+ -e 's/ln -s/ln -fs/' \
+ makefile
+
+ make
+ make SHARED=1 VERSION=$pkgver
+}
+
+package() {
+ cd "$srcdir/sdk/angelscript/projects/gnuc"
+
+ install -d "$pkgdir"/usr/{lib,include} \
+ "$pkgdir"/usr/share/{licenses,doc}/$pkgname \
+ "$pkgdir"/usr/share/$pkgname \
+ "$pkgdir"/usr/share/doc/$pkgname/{articles,manual}
+
+ make install
+ make install SHARED=1 VERSION=$pkgver
+
+ chmod 644 "$pkgdir"/usr/include/*
+
+ msg "Installing add-ons..."
+ cd "$srcdir/sdk"
+ cp -rf add_on "$pkgdir/usr/share/$pkgname/"
+
+ msg "Installing documentation and license..."
+ cd "$srcdir/sdk/docs"
+ install -m644 articles/* "$pkgdir/usr/share/doc/$pkgname/articles"
+ install -m644 manual/* "$pkgdir/usr/share/doc/$pkgname/manual"
+ install -m644 index.html "$pkgdir/usr/share/doc/$pkgname"
+ install -Dm644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname"
+}